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About PrintShop Mail

About PrintShop Mail
Developed to simplify the production of variable data printing (VDP) jobs, PrintShop Mail Design is the perfect application for
digital print operations and is a standalone application.
Pre-designed PDF or EPS files are imported into the application and variable information from a database file is overlaid by a
simple drag-and-drop operation. Business rules can be added, and the data can be formatted and sorted using an expression
wizard.
On the output side, PrintShop Mail Design caches static elements of the print job, which results in an optimized print stream
that minimizes network congestion, decreases ripping time and allows digital printers to run near or at rated speed.
A VDP assembly technology, PrintShop Mail Design removes the need to use plug-ins to graphics design tools. Users can
simply take the provided designs and overlay the variable data and variable images.
For more information about the possibilities of PrintShop Mail, please visit http://www.printshopmail.com/
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Getting Started

Getting Started
Installing PrintShop Mail

9

Upgrading PrintShop Mail

10

Installing the Hardware Key

11

This section will get you started with the installation and setup of PrintShop Mail, as well as its activation procedure.

Installing PrintShop Mail
Before you start
If you are installing PrintShop Mail on a computer with Windows 2000, XP, 2003 or Vista, make sure you are logged in with full
administrative rights before running the installation program.

Installing in Windows
Your installation file may have been delivered digitally or downloaded through our website. In this case, "CD-Rom"
refers to the download location of the software and "Setup.exe" refers to a file that may be called "PrintShop Mail
Suite 7.exe"
1. Locate the setup.exe file on the CD-ROM.
2. Double click this file to start the installation wizard.
The installer loads the setup (this may take a few minutes).
3. Select the language you want to use for the installation then click OK.
4. If your computer is missing prerequisites necessary for PrintShop Mail to be installed, a dialog appears and indicates
that they will be installed.
5. Click Next to download and install the required components.
6. A warning is displayed indicating that PrintShop Mail Web will be installed with a demo license, if it is installed. Click OK
to dismiss the message.
7. Click Next. The License Agreement page is shown.
8. When you have read and understood the license agreement, click on I accept the terms of the license agreement. Click Next.
You must accept the terms of the license agreement to continue.
9. Check the features that you want to install with PrintShop Mail. You cannot unselect PrintShop Mail itself, but can choose
not to install its optional components. If you want to install PrintShop Mail Web, check that option. Click Next.
10. The Destination Folder screen displays the drive and folder where PrintShop Mail will be installed. To install the software elsewhere, click Change... and navigate to the desired folder.
11. The Program Folder name determines the name that appears in the Start Menu. Keep the default name or change the
name as desired, then click Next.
12. Click Next to start copying the files and install the software. The Setup Wizard starts installing the files.
When the copying is complete, the final window appears.
You may check Check for Updates to check for updates after the installation has finished (recommended).
13. Click Finish to complete the installation of PrintShop Mail.
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Installing on Mac OS
PrintShop Mail 5.4 is supported on Macintosh Operating System 10.4.11 and later (including Operating System 10.5).
1.
2.
3.
4.
5.
6.

Locate the PrintShop Mail 5.4.x.dmg file on the CD-ROM or download location.
Double click on this file.
Select the language you want to use for the installation.
Read the license agreement and select " Agree". (If you select " Disagree" , the installation will be canceled).
A window will be displayed " Opening PrintShop Mail 5.4.x.dmg".
You can drag the PrintShop Mail icon to the Applications folder or to any other location on your computer.

Upgrading PrintShop Mail
The hardware key contains the license information of the PrintShop Mail application.
To view the license information, select Help/Credit Information.
To use certain features in PrintShop Mail, your license must be upgraded before you are allowed to use this feature. This count
for the amount of credits, CARE, automated printing and multi user licenses.
Credits
Unlimited or Production version, allows unlimited records to be printed.
Limited or Standard version, allows 200,000 records to be printed.
CARE
The care date determines which PrintShop Mail version is licensed. Each PrintShop Mail version has an own release date,
which is compared with your care date. If your care date is equal or newer than the release date, the application will run as
licensed, otherwise the application will run in demo mode.
Cross Platform
All current PrintShop Mail dongles are cross platform and any user that has a valid OL Care contract can request a voucher for
a cross platform license.
PrintShop Mail upgrade options
The Upgrade options are only enabled when the PrintShop Mail hardware key is attached to the computer where the upgrade
procedure is performed.
To upgrade your hardware key
From the Help menu, you can select from three different upgrade menu items:
l

l

l

Voucher: If you have a PrintShop Mail voucher number, click on the "Voucher" option. A PrintShop Mail voucher web
page will open. Here you need to enter the voucher number and some additional information to confirm the request.
Upgrade request: If you want to add credits, upgrade the version, add OL CARE or another option, click on the
"Upgrade" option. The PrintShop Mail Upgrade page will open. Here you select the options you want and some additional information to confirm the request.
Activate dongle: If you have received an Authorization code back from your voucher or upgrade request (by email),
you have to copy that code into the Activate dongle screen. Then click "Activate".
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Installing the Hardware Key
Without a hardware key, also known as "Dongle", PrintShop Mail runs in Designer mode. In this mode, all PrintShop Mail functions are available, but you can only print up to 25 records per session and a watermark is printed over each layout output.
This is a picture of the USB hardware key (though your key may differ slightly in appearance).

Figure 1-0: The Hardware Key
You can use each credit on your hardware key to print one record.
To install the hardware key
Windows
Attach the hardware key to the USB port on your computer.
Though Windows should recognize your key by default and install it without intervention, in some cases it may not be
able to do so. In these cases, you will need to manually download and install the Aladdin HASP key drivers, available
online at: http://www.aladdin.com/support/hasp/enduser.aspx
To view the amount of credits available on the hardware key:
1. Start PrintShop Mail.
2. From the Help menu, select Credit Information.
Mac OS
Attach the hardware key to the USB port on your computer.
1. Start PrintShop Mail
2. From the Help menu, select Install Dongle Software...
3. Follow the instructions on the screen
To view the amount of credits available on the hardware key:
1. Start PrintShop Mail.
2. From the Help menu, select Credit Information.
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The PrintShop Mail program interface
The PrintShop Mail Program Window
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The PrintShop Mail Program Window
The PrintShop Mail Program Window is divided into multiple sections:
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Figure 1-0: The PrintShop Mail Program Window and its components: (1) The Menu contains all of the useable menus referred
to in this documentation. (2) The "Standard Toolbar" (page 15) lets you manipulate documents as well as clipboard functions.
(3) The "Text Formatting Toolbar" (page 15) lets you set text and paragraph styles and formatting. (4) The "Objects Toolbar"
(page 16) lets you manipulate object properties. (5) The "Text Link Toolbar" (page 16) lets you set links for text objects. (6)
The "Tools Toolbar" (page 17) lets you add and manipulate objects in your document. (7) The Layout area is where your document and its objects appear. (8) The "Dockable Panels" (page 19) display various utilities such as your layouts, variables,
data fields and more. (9) The "Warnings Panel" (page 21) displays warnings about errors in your document. (10) The "View
Toolbar" (page 18) lets you change how you see your document by zooming in and out. (11) The "Database Toolbar" (page
18) lets you navigate through the records in your database.

PrintShop Mail Toolbars
The PrintShop Mail Program Window contains multiple toolbars that can be moved and customized. This section looks at each
toolbar and its buttons.
Main (Top) Toolbar:
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l
l
l
l

Standard Toolbar
Text Formatting Toolbar
Objects Toolbar
Text Link Toolbar

Objects Toolbar:
l

Tools Toolbar

Bottom Toolbar:
l
l

View Toolbar
Database Toolbar

Standard Toolbar

Figure 1-0: The Standard Toolbar and its button.
Button Function
Create a new document, based on a blank layout.
Open an existing document.
Save your current document.
Preview the current document.
Print the current document.
Publish templates to PrintShop Web.
Cut the selected object(s).
Copy the selected object(s).
Paste the selected object(s).
Undo the last action.
Redo the last action.
To undo or redo multiple actions at one time, click the drop-down button next to the arrow.

Text Formatting Toolbar

Figure 1-0: The Text Formatting Toolbar and its button.
Click this button...
To do this...
Select the font name
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Click this button...

To do this...
Select the font size.
Make the selection bold.
Make the selection italic.
Underline the selection.
Select the font color.
Left align text.
Center text.
Right align text.
Justify text.
Change the text to "Right to Left".
Vertical Layout

Objects Toolbar

Figure 1-0: The Objects Toolbar and its button.
Click this button... To do this...
Add or Remove anchor.
Align left edges to the left edge of the last selected object.
Align right edges to the right edge of the last selected object.
Align top edges to the top edge of the last selected object.
Align bottom edges to the bottom edge of the last selected object.
Rotate the object 90 degrees counter-clockwise.
Rotate the object 90 degrees clockwise.
Select the fill color.
Specify the border width (or no border).
Specify the border style
Select the border color.

Text Link Toolbar
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Figure 1-0: The Text Link Toolbar and its button.
Click this button... To do this...
Create Forward Text Link.
Break Forward Text Link.
Select Previous Text Box.
Select Next Text Box.
Not only can multiple text boxes can be linked together with text flowing between them, they can also be linked
across layouts. See "Linking Text Objects" (page 37) for more details.

Tools Toolbar
Windows

Figure 1-0: The Tools Toolbar and its button.
Click this butTo do this...
ton...
Select the Select tool. Click on an object to select it.
Select the Pan tool. You can then click and hold within the design area and move the mouse to pan the area in
all directions (best used when zoomed in).
Select the edit text tool. Click on an existing text object to edit it (same effect as double-clicking a text object).
Select the zoom tool left click to zoom in, right click or hold down CTRL to zoom out.
Pick a Fill, Text, or Border color based on the RGB values of any pixel on the screen.
Place a PDF file. See Place PDF.
Place a static image. See Image Object.
Select the place text tool. See Text Object.
Place a barcode object. See "Barcode Properties" (page 31).
Select the place variable image tool. See Image Object.
Rotate the selected object to any angle by dragging the mouse cursor.
Place a DirectSmile object.
Place AcceptGiro object.
Mac OS

Figure 1-0: The Tools Toolbar and its button in Mac OS.
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Click this button... To do this...
Select the tool.
Select the edit text tool.
Select the place variable image tool.
Place a static image.
Select the zoom tool.

View Toolbar

Figure 1-0: The View Toolbar and its button.
Click this button... To do this...
Go to the first layout.
Go to the previous layout.
Go to the next layout.
Go to the last layout.
Fit Layout Width
Display Whole Layout
Display the Layout Actual Size
Zoom In
Zoom Out
Specify the zoom level
Show or hide Formatting Marks.
Toggle Preview mode.
Show or hide the rulers.
Show or hide a specific toolbar.

Database Toolbar

Figure 1-0: The Database Toolbar and its button.
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Click this button... To do this...
Go to the first record.
Go to the previous record.
Go to the next record.
Go to the last record.
Go to the current record.
Display the total number of records in the database.
The Total number of records edit box is read-only when a database is open.
When no database is open, you can change the total number of records, in the Database toolbar. To do this, enter the
desired number of records and press Enter.
Finding a Record
Though not part of the Database Toolbar, a very useful feature for open databases is the Find Record feature. This feature is
available from the Database menu, or via its shortcut key (CTRL+F). It is only available when a database is open, and will be
grayed out otherwise.
The find record dialog appears with the following options:
l
l
l

l

l
l
l

Find what: Enter a term (word, phrase, character) to search for.
Look in: Click the drop-down to select the database field in which to search.
Match whole word only: Only match if the word is separated. For example, if this is selected the word tom would
not be found in the word tomatoes. If it is not selected, words part of others will be matched.
Match case: Click to force a match only if each letter of the word is in the same case. For example, if this is selected,
Tom will not be matched with tom or ToM. Otherwise, the search is case insensitive.
Direction: Select whether to look forward in the records (down) or backwards in previous records (up).
Find Next: Click to find the next occurrence of the search term.
Cancel: Closes the dialog.

Dockable Panels
The PrintShop Mail Program makes it easy to view the correct information precisely when you need it, by dividing that information into different panels. These panels will change depending on the situation.
These panels can be undocked and moved in order to customize the interface to your liking.

Layouts Panel
The Layouts panel contains the layout(s) and their object(s). The objects are listed as a part of the layout in a tree view.
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Figure 1-0: The Layout Panel, showing two layouts and a few objects.

Variables Panel
The Variables panel shows the list of variables, the Name, Expression and calculated Result.

Figure 1-0: The Variables panel, showing the name, expression and result for each variable.
To edit a variable:
1. Double click on the variable. This will open the Expressions Editor ("The Expressions Editor" (page 121)).
2. Modify the expression, then click OK.
To edit a variable's properties and change its category:
1. Click on the variable.
2. Click on the Window menu, then Properties.
3. Change the properties of the variable (see "Variables Properties" (page 30))
To copy a variable's expression:
1.
2.
3.
4.

Right-click on the variable.
Click Copy Expression.
Right-click on another variable where you want to paste the expression.
Click Paste Expression.
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For detailed information about how to format variables, see "Variables Properties" (page 30).

Data Fields Panel
The Data Fields panel will show the field names , database name of the opened database and the number of records it contains.
The entries you will find in the Data Fields panel in PrintShop Mail, represent data fields that occur in the document. These
fields are either referred to in expressions (for variables or layout conditions, without the need to directly being linked to a
database), or they refer to actual database fields (when the document is already linked to a specific database).
When a data field is used in the PrintShop Mail document, it will have a check mark in the Data Fields panel.
You can browse the records in the database by clicking the browse buttons in the Database toolbar, or by making the following
selections from the Database menu:
l
l
l
l
l

First Record (ALT+Up)
Previous Record (ALT+Left)
Next Record (ALT+Right)
Last Record (ALT+Down)
Record...Allows you to select a specific record.

Figure 1-0: The Data Fields panel, showing the name, value and type of each of your database fields.

Warnings Panel
While you are working, PrintShop Mail will dynamically check for any possible errors on the layout and will display any occurring errors in the Warnings panel.
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Figure 1-0: The Warnings Panel, showing any warning that occurs in your document.

Fonts Panel
The Fonts panel will show the fonts used in the PrintShop Mail document and any missing font.

Figure 1-0: The Fonts Panel, showing any all the fonts used in your document.

Verification Result Panel
When you select from the Layout menu, Verify Document a progress bar will be displayed, showing the amount of records being checked. The warnings for the whole document will be listed in the Verification Result panel.
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Figure 1-0: The Verification Results Panel, showing the results of the Verify Document procedure.
It is possible to save messages displayed in the Warnings panel and the Verification Results panel by right clicking on
the message and Copy/Paste the text to a text file.

Properties Panel
You can change the properties for any object in the Properties Panel.
These properties are grouped as follows:

Object Group
Option

Description

Name

The unique name that identifies an object.

The following limitations apply to "objects name":
l
l
l

No white spaces leading or trailing.
Maximum 255 characters.
Not editable when multiple objects are selected.
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Frame Group
Option

Description

Lock PosiLocks the position, size and rotation attributes of this object.
tion
Bounding Displays the dimensions of the bounding box using the location of the top left corner, and the height and width.
Box
These values can also be entered manually.
Snap
Frame to
Content
(Windows
Only)

Snaps the frame to the proportions of the content.
When this option is set to "Yes", the object’s bounding box (frame) will automatically resize to the dimensions
of the image or resize vertically to accommodate larger amounts of variable text that would otherwise not fit in
the text box. When set to "No", a verification warning will be shown, when variables do not fit in the box.
Note: When using text linking, Snap Frame to Content is only allowed for the last object in the chain.

Border
Size

Change the border size. You can choose from hairline width, or a pixel width (1-12px). You can also create a
Custom Size.

Border
Color

You can choose one of the standard colors, or create your own custom RGB, CMYK, Gray or Spot color for the
border. To learn more about PrintShop Mail Spot Colors click "Specify Spot Colors" (page 70).
Choose the border style. The following options are available:

Border
Style
(Windows
Only)

l
l
l
l
l
l
l

Solid ——————
Square dot ......
Dash — — — — —
Dash Dot — - — - — Long Dash —— —— ——
Long Dash Dot —— - —— Long Dash Dot Dot —— - - —— - -

Fill Color

The fill color can be transparent, or it can be set to a solid fill color. The standard Windows palette is available,
but you can also create your own custom RGB, CMYK, Gray or Spot color. To learn more about PrintShop Mail
Spot colors click "Specify Spot Colors" (page 70).

Rotation

Shows the current rotation applied to the item.

Anchor

Master Object: Master object name to anchor to.
Horizontal: Horizontal aspect of the master object to anchor to.
Vertical: Vertical aspect of the master object to anchor to.

Printing Group
Option

Description

Print

Specifies whether the object will be printed or previewed only.

Global
Scope
Specifies whether an image should get Global Scope. Images with a Global Scope can be reused on the printer
for
across multiple PPML or PPML/VDX jobs. When set to "Yes" images will be stored in a specified Environment and
PPML
can be reused in others print jobs. This property will be ignored for other technologies.
(images
only)
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Text Properties
The Text Properties lets you change all of the properties for any text object in your document. The options available are different in the Windows and Mac OS versions of the software.
To open the text properties in Windows
1. Click on the text object of which you want to display the properties.
2. Click in the Window menu, then click Properties.
3. The Properties window appears or, if it is already present, is brought to the front and selected.
To open the text properties in Mac OS
1. Click on the text object of which you want to display the properties.
2. Click on Items, then Show Object Properties. You can also right-click on the text object and select Show Object Properties from the drop-down menu.
3. The Object Properties dialog appears.
Available Options
All objects share some properties. To see these shared properties (the "Object", "Frame" and "Printing" groups), see Properties Panel.
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Content Group
Option

Description

Alignment horizontal

Horizontal Text alignment (Left, Centered, Right, Justified).

Alignment vertical

Vertical text alignment (Top, Centered, Bottom)

Copy fitting

Copy fitting is a feature that will automatically shrink text by reducing the font size when there is more text than the text box can hold.
The font size will be reduced to the font size needed to fit the text in
the text box. However, text will not be shrunk beyond the specified
minimum font size. When the text needs to be resized, all text will be
resized step by step until the text fits or the minimum font size is
reached.
Minimum font size: When Copy Fitting is enable, the minimum
size the font can reach is 1, by default the minimum font size is 8.
Allow line breaks is a feature which automatically replaces some
of the blank spaces between words by line breaks, in a way that each
line fits in the viewable window. In PrintShop Mail "Allow line breaks"
is set to Yes by default.
When Copy Fitting is set to "Yes", individual words can be broken due
to word wrap.
When Copy Fitting is set to "No", text only fit if the individual words
are not broken. Text will break on spaces only.
Note: Copy Fitting is not allowed for linked objects.

Remove Empty Lines

This setting allows you to remove empty lines in a text box.
When set to "No", empty lines will be shown in the text box. This is
useful where the variable is for instance an address and some records in the database have empty fields. If you select this function the
empty lines caused by the empty field(s) will be preserved.
When set to "Yes", both empty lines which are caused by empty
fields in the database and white lines which are manually inserted will
be removed.
When set to "Only in variables", all empty lines will be removed in the
variables only, static empty lines will be preserved.

Vertical Layout

This setting is specifically designed for vertical text with Asian characters which need to be printed vertically, other characters will
simply be rotated 90°.
This feature is supported under Windows XP, Windows 2003 and Windows Vista.

Mac OS Note: The "Remove Empty Lines" feature can be switched on using a checkbox in the Expression Editor
Window.

Image Properties
The Image Properties lets you change all of the properties for any image object in your document. The options available are
different in the Windows and Mac OS versions of the software.
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To open the image properties in Windows
1. Click on the object of which you want to display the properties.
2. Click in the Window menu, then click Properties.
3. The Properties window appears or, if it is already present, is brought to the front and selected.
To open the image properties in Mac OS
1. Click on the object of which you want to display the properties.
2. Click on Items, then Show Object Properties. You can also right-click on the object and select Show Object Properties
from the drop-down menu.
3. The Object Properties dialog appears.
Available Options
All objects share some properties. To see these shared properties (the "Object", "Frame" and "Printing" groups), see "Properties Panel" (page 23).
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Content Group
Set this option...

To specify...

Alignment horizontal Horizontal alignment of the images (Left, Centered, Right).
Alignment vertical

Vertical alignment of the images (Top, Centered, Bottom).

Scale (Windows)
Clipping (Mac OS)

Here you can specify options on how the image is resized relative to
the bounding box.
Original size: The image is always shown in its original size, regardless of the size of the frame. Original size resets the image content to
100%.
Fit in Frame: The image will be resized to fill the frame, maintaining
the image aspect ratio, showing the actual scale percentage of the
image. Images are not clipped.
Crop to Frame: Proportionally scales the images filling the entire
frame. Images may be clipped.

Image Filename

Displays the image filename. The contents can only be changed
through the Expression Editor.

Image Folder

This points to the path where the variable images are stored. Clicking
on the icon allows you to browse to a different search folder.

Search Subfolders

Specify whether PrintShop Mail should only look for files in subfolders.
When set to "No" PrintShop Mail will only look in the current folder.
When set to "Yes" PrintShop Mail will look in subfolders as well.

Page Number

The PDF page number represents the page number in the original PDF
file, ranging from one to the number of pages in the PDF. An image
object can be linked to a single PDF file. As a PDF can contain multiple
pages you can specify the page(s) to be used in your document
through an expression (TOTALPAGES), in that case you can use variable pages within that PDF file. If the page number refers to a non
existing page, a warning will be shown in the warnings panel:"Page
number X is invalid; this file contains Y pages only.

Two Color
(Windows only)

Convert to Two Colors: When set to "No" images will shown it's
original color. Setting this option to "Yes" will convert the image to two
colors.
Background Color: Convert background color to specified color.
Foreground Color: Convert foreground color to specified color.

The following limitations apply to "Two Color" option for images:
l
l

l

The Two Color option does not support the image format EPS.
Two Color option will be disabled when using the Print Technology specific options, OPI, APR and Do no send images
(VIPP).
The Print Technology PPML support the Two Color option, when you check "Embed Images in PDF" in the Print Dialog.
PrintShop Mail for Windows preserves the color space in images format EPS, TIFF and JPEG. To learn more about
Color Management, click "Color Settings" (page 46).
PrintShop Mail for Macintosh converts the color space that is embedded in the image to the color space of the printer
driver. You can check the color space of the printer driver, selecting from the File menu, Print/ColorSync.
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Layout Properties
When you select a layout in the Layouts panel, the following properties will be displayed.

Figure 1-0: The Layout Properties Panel, which lets you set your layout properties.

Option

Description

Layout
Name

Name of the selected layout.

Layout Size

Size of the selected layout.
More information about this topic , can be found in Specify the Layout Size.

Description

Select a standard size: Fit to Page (Default), Fit to Objects, Custom Size, A3, A4, A5, B5, US Letter, US Legal.

Width

Enter custom width. This setting is editable if you select "Custom Size".

Height

Enter custom height. This setting is editable if you select "Custom Size".

Paper Size

Size and orientation of the paper for the current layout.
More information about this topic can be found in Page Setup.

Description

Select the paper size for the selected layout. The paper size depends on the printer driver selected in the Page
Setup dialog.

Width

The width of the page.

Height

The height of the page.

Paper Tray

If your printer supports different paper trays and your document consists of multiple layouts, you can send dif-
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Option

Description
ferent layouts to different trays.
More information about this topic can be found in Select Paper Trays

Action

The action to be performed for this layout, PRINT, BLANK or SKIP.
More information about this topic can be found in Use Layout Condition.

Number of
copies

Number of copies to be printed for the selected layout, must be at least one.
More information about this topic can be found in Number of Copies.

Variables Properties
The Variables Properties lets you change all of the properties for any variable used in your document. This panel is only available in the Windows version of PrintShop Mail.
To open the variables properties
1.
2.
3.
4.

Open the Variables panel. To do this, click the Window menu, then click Variables.
Click on the variable of which you want to change the properties.
Click in the Window menu, then click Properties.
The Properties window appears or, if it is already present, is brought to the front and selected.

Available Options
Variable Group:
l

l

Name: This value can only be changed for global variables (it cannot be changed for variables created by objects, or
typed in a text box).
In Use: This value cannot be changed, it displays whether or not the variable is used by any text object.

Format Group:
l

Category: Sets the category of the variable. Changing the category will change the rest of the available options.

Text Category: This category does not have any options. Text variables have no special formatting and are displayed as-is.
Email Category: This category does not have any options. Email variables will only accept values that correspond to a valid
email address: [identifier]@[domain].[tld]
Date Category: This category is used for dates used in your documents, and has the following options:
l
l

Locale: Specify the locale and language used for the date.
Date Format: Specify the exact format of the date (available options depends on the locale)

Currency Category: This category is used for amounts in your local currency, and has the following options:
l
l
l
l
l

l

l

l

Locale: Specify the locale and language used for the currency display.
Currency Symbol: Specify what symbol will be used for currency.
Positive Format: Specify how positive currency amounts will be displayed.
Negative Format: Specify how negative currency amount will be displayed.
Decimal Symbol: Specify what character is used to separate the amount with its decimals (for example, dollars and
cents)
Decimal Places: Specify how many decimal places to display after the decimal symbol. Note that the amount will be
rounded to the last decimal displayed.
Digit Grouping Symbol: Specify what character is used to separate groupings (for example, a space or comma to
separate thousands, millions, billions)
Digit Grouping: Specify how many digits to group together (for example, 3 for north-American currencies).
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Number Category: This category is used to display numbers. It has the same options as the currency, except for the following options:
l
l
l

Positive Format is not displayed
Currency Symbol is not displayed
Leading Zeroes is added: Specify how many leading zeroes to add at the end of the decimal places, up until the
number specified by the decimal places option.

Barcode Properties
The Barcode Properties lets you change all of the properties for any barcode object in your document. The options available
are different in the Windows and Mac OS versions of the software.
To open the barcode properties in Windows
1. Click on the object of which you want to display the properties.
2. Click in the Window menu, then click Properties.
3. The Properties window appears or, if it is already present, is brought to the front and selected.
To open the barcode properties in Mac OS
1. Click on the object of which you want to display the properties.
2. Click on Items, then Show Object Properties. You can also right-click on the text object and select Show Object Properties from the drop-down menu.
3. The Object Properties dialog appears.
Available Options
All objects share some properties. To see these shared properties (the "Object", "Frame" and "Printing" groups), see Properties Panel.
Content Group
The Content group options may change depending on the barcode. The greatest majority of barcodes have the following options only.
Option

Description

Data

The expression used as data for the barcode. Please refer to the documentation for your barcode reader or the barcode itself to learn
which information is supported for any particular barcode. See "The
Expressions Editor" (page 121)

Encoding

Select the encoding type, either String or Hexadecimal. Refer to
the barcode reader documentation to know what option to choose.

Alignment

Horizontal: Select whether the barcode itself is aligned at the left,
center or right of the barcode object.
Vertical:Select whether the barcode itself is aligned at the bottom,
center or top of the barcode object.

Barcode Group
The Barcode group options may change depending on the barcode. The greatest majority of barcodes have the
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following options only.
Option

Description

Type

Specifies the barcode type that will be printed. For a list of available
barcodes in PrintShop Mail, see "Barcodes Supported by PrintShop
Mail" (page 79).

Module Width

Specifies the width of the barcode object (and not the barcode itself).
It can be automatic or manually entered.

Align to Pixel Raster

Aligns and resizes the barcode in order to correctly fit your print area.
This ensures a more precise output at the printer since the barcode
bars will now precisely fit within your printer's output resolution.

Dot Gain Compensation

Dot gain occurs when ink bleeds or spreads as it is absorbed by
paper, enlarging the pixels. The amount of dot gain varies for each
printer and depends on ink coverage on the printing press. You can
compensate for the effect by specifying a value between 0 and 100 for
the Dot Gain Compensation property (0 disables the feature).

Quiet Zone

The quiet zone is the blank margin on either side of the barcode that's
used to tell the barcode reader where a barcode's symbology starts
and stops. You can specify any value in points in this box.

Indicates whether you want a human-readable (alphanumerical)
Human Readable Text string to appear below or above the barcode, or none at all. This
option is only visible on barcodes that support human-readable text.
Font Size

Specifies the font size for the human-readable text, when it is available.

Check Digit Method

Specifies the check digit method to calculate the barcode's check digit.
Select Automatic to use the default for this barcode, or select another
check digit method. Refer to your barcode reader's documentation to
know which option to enter here.

Mac OS Note: PrintShop Mail 5 for Mac OS still uses fonts to create its barcodes.

DirectSmile Properties
The DirectSmile Properties lets you change all of the properties for any DirectSmile object in your document. The options available are different in the Windows and Mac OS versions of the software.
To open the DirectSmile properties in Windows
1. Click on the object of which you want to display the properties.
2. Click in the Window menu, then click Properties.
3. The Properties window appears or, if it is already present, is brought to the front and selected.
Available Options
All objects share some properties. To see these shared properties (the "Object", "Frame" and "Printing" groups), see Properties Panel.
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DirectSmile Group
Option

Description

Host

The IP, network computer name or domain name of a server where
DirectSmile Generator is installed. Clicking on this opens the DirectSmile Editor window.

Image Set

The image set used to generate the image, from a list of available sets
on the DirectSmile Generator server. Clicking on this opens the
DirectSmile Editor window.

Text on Layer X

These expressions determine the text that will appear in the DirectSmile image that is being generated. The number of available properties (X) is determined by the image set and will be one or more.

Some DirectSmile templates may not be designed to support all characters of a language. In this case, a warning may
pop up, or the generated image may contain no personalization.

Manipulating Objects
You can manipulate objects that are on the page easily using the tools in this section. For more information on the different
types of objects you can use, see "Objects in PrintShop Mail" (page 75).

Selecting Objects
There are several ways to select objects.
l
l
l

Select a first object then press SHIFT or CTRL while clicking on another object on the layout.
Drag a selection box (lasso) around more than one object.
From the Edit menu, choose Select All or press CTRL+A (Windows) or Command+A (Mac OS)

To select underlying objects
If you cannot select an object with a mouse click because it is covered by another object, repeatedly press the TAB key to
cycle through the objects on the visible layout.
Press SHIFT+TAB to select the previous object.
To extend a selection
There are several ways to extend a selection. You can:
l
l
l

Press and hold SHIFT or CTRL to ensure that any active selection is not cleared.
To extend the current selection, press and hold SHIFT while left clicking on additional objects.
To toggle an object selection state, press and hold CTRL while left clicking on the object.
You can also combine the use of SHIFT and CTRL with the lasso object to add multiple objects at once.

©2010 Objectif Lune Inc

- 33 -

The PrintShop Mail program interface

Moving and Resizing Objects
To move objects using the mouse
Windows

1. Select one or more objects.
2. Left click on the selection and drag it to the new location.
While dragging, the objects will be snapped to any nearby guide line.
Mac OS

1. Select one or more objects.
2. Click on the selection, hold down the mouse and drag it to the new location.
To move objects using the keyboard
Windows

1. Select one or more objects.
2. Use the arrow keys on your keyboard to nudge the selection to a new location on the layout. (Each nudge offsets the
objects by one pixel.)
To move objects by entering the new coordinates (to place an object at a specific location)
Windows

1. Select the object.
2. In the Properties panel/ Bounding box, enter the desired Left and Top position.
Mac OS

1.
2.
3.
4.

Select the object.
From the Item menu, select Show Object Properties, or press Shift and double click.
In Position, enter the X and Y coordinates.
Click OK.

To resize an object using the mouse
1. Select the object.
2. (Windows): Left click on one of the sizing handles.
(Mac OS): Click on the sizing handles and hold down the mouse button.
3. Drag the handle to resize the object.
For static images, resizing always maintains the original aspect ratio of the image. For any other object, resize proportionally by holding down the CTRL key while dragging. While dragging, the sides of the objects that you are resizing will be snapped to any nearby guide line.
To resize an object by entering the new dimensions
Windows

1. Select the object.
2. In the Properties panel/ Bounding box, enter the new Width and Height.
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Snap Frame to Content
Snap the frame to the proportions of the content.
When this option is set to "Yes", the object bounding box (frame) will automatically resize according to its contents. In case of
an image it will resize to the dimensions of the image. In case of text (static or variable) it will resize vertically to accommodate larger amounts of text that would otherwise not fit in the text box. When set to "No", a verification warning will be
shown at printing time, when objects do not fit in the box.
When you have linked text boxes, Snap Frame to Content will only work for the last text box in the chain.
Mac OS

1.
2.
3.
4.

Select the object.
From the Item menu, select Show Object Properties, or press Shift and double click.
In Position, enter the new Width and Height.
Click OK.

Copying Objects
To copy objects using the mouse
1. Right click and drag one or more selected objects to another location.
2. Release the mouse button.
3. On the menu, choose Copy Here to create duplicates of the selected objects.
To copy objects using the clipboard
1. Select one or more objects.
2. From the Edit menu, select Copy or press CTRL+C in Windows, COMMAND+C in Mac OS.
To paste an object in the clipboard
1. Go to the layout where you want to paste the object.
2. From the Edit menu, select Paste or press CTRL+V in Windows, COMMAND+V in Mac OS.
You can paste the contents of the clipboard to any layout, even in a separate instance of PrintShop Mail .
To paste objects to multiple layouts
If your document consists of more than one layout, you can create multiple copies throughout your document. Choose either:
l

l

Edit, then Paste To and then Entire Document to paste the contents of the clipboard to every layout in your document.
Edit, then Paste To and then Remainder of Document to paste to the remainder of your document (for example,
to every layout, starting with the next layout).
If the current layout happens to be the last layout in your document, the option Remainder of Document is not
available.

Aligning Objects
You align the edges of the objects in the selection to the object LAST selected. You can align to the left, right, top or bottom
edges of the object.
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To align objects:
l

l

In Windows:
1. Select the objects which you want to align, ending with the object you want to align to.
2. Either use one of the alignment buttons in the Tools toolbar, or go to the Object menu then Align Edges and
click one of the options.
In Mac OS:
1. Hold down the Shift key while you select the objects you wish to align, or draw a box (lasso) that encloses all
objects that need to be aligned.
2. From the Item menu, select Align.
3. Select one of the available options from the submenu. (see figure below)

Mac OS Alignment options:
Alignment Option Description
Left Edges

To align the selected objects along their left edges.

Right Edges

To align the selected objects along their right edges.

Top Edges

To align the selected objects along their top edges.

Bottom Edges

To align the selected objects along their bottom edges.

Horizontal Centers

To align the selected objects along their horizontal edges.

Vertical Centers

To align the selected objects along their vertical edges.

If you don't know which object you selected last, for example if you selected everything with Select All or pressing
CTRL+A, reselect the object to align to, while holding down the SHIFT key.

Arranging Objects
You can move objects in front or behind each other.
1. Select the object.
2. From the Object menu, select Arrange. You can also right click on the selection and select an option from the submenu under Arrange.
3. Select the appropriate option:
l Bring to Front: To move the object in front of all other objects.
l Bring Forward: To move the object one position forward.
l Send Backward: To move the object one position backward.
l Send to Back: To move the object behind all other objects.

Locking Objects
Locking an object, protects it from accidental changes in size or position. The text in a text box remains editable, however.
To lock an object
1. In Windows:
l Select the object.
l From the Object menu, select Lock Position. Alternately, right click the object and choose Lock, or from the
Properties panel change Lock Position to Yes.
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2. In Mac OS:
l Select the object.
l From the Item menu, select Show Object Properties, click on Unlocked. Alternately, from the Item
menu select Lock Position.
To unlock an object
1. In Windows:
l Select the locked object.
l From the Object menu, select Unlock Position. Alternately, right click the object and choose Unlock, or
from the Properties panelchange Lock Position to No.
2. In Mac OS:
l Select the object.
l From the Item menu, select Show Object Properties, click on Locked. Alternately, from the Item menu
select Unlock Position.

Linking Text Objects
Multiple text object can be linked together in order to have text overflow between them.
Text objects can be linked within a page, but they can also be linked between pages (Page Overflow).
To link text objects
1.
2.
3.
4.

Make sure the destination text object(s) to which you want your text to flow towards already exists.
Select the first text object.
From the Text menu, select Create Forward Link, or on the Text Link toolbar, click the Create Text Link button.
Point with the mouse cursor to the text object where you want your text to overflow towards (the destination object).

When you move the mouse over a text object which can be linked to, the border of this object will become green if it is possible to link to this object, and red if this is not possible.

Anchored Objects
Anchored objects are items, such as images or text boxes, that are connected to each other in such a way that a change in position or size of the Master object will affect the position of any number of Child objects.
An example use of this technique is to add a signature at the bottom of a letter. If the letter has a height that changes between
records, the text box could potentially be too small (the signature is too far down) or too large (the text goes over the signature). This can happen if, for example, your text box contains a variable that displays the content of a database field with
text that can vary in size. Using the Anchor tool, you can force the signature (Child) to lock to the bottom of your text box
(Master) , moving up and down as the height of the text object changes.
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Figure 1-0: Two anchored objects: (1) the Anchor Master, (2) Distance between the Master and Child, (3) Anchored Child.
To anchor two object through the "Objects Toolbar" (page 16)
1.
2.
3.
4.

Select the object to be anchored (anchor Child).
In the Object toolbar, click on the “Add or Remove Anchor” button.
Move the mouse over another object (anchor Master).
Left click on this object that serves as anchor Master to link the two objects together.

To anchor two object through the "Properties Panel" (page 23)
1. Select the object to be anchored (anchor Child).
2. In the Properties panel, click on the Anchor property, to expand the Master Object property.
3. Select the name of the anchor Master object.
When anchoring objects, the object will be highlighted in green if it is a valid anchor Master or in red if it is not.
To remove anchoring through the "Objects Toolbar" (page 16)
l
l

Select the anchored object (anchor Child).
In the Objects toolbar, click on the “Add or Remove Anchor” button, to remove the anchor.

To remove anchoring through the "Properties Panel" (page 23)
l
l
l

Select the anchored object (anchor Child).
In the Properties panel, click on the Anchor property, to expand the Master Object property.
From the drop down menu, select the “empty” option.
A Child object can only have one Master, but a Master can have more than one Child. To change the Master of a Child
object, start by removing the anchor for the Child, then add a new anchor to the other Master.

Anchor settings
Anchor settings can be changed in the Properties panel of the object.
Horizontal anchors:
l
l

Left: The anchor Child position will be relative to the left side of the anchor Master.
Right: The anchor Child position will be relative to the right side of the anchor Master.
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l

Width: The anchor Child width will be relative to the width of the anchor Master.

Vertical anchors:
l
l
l

Top: The anchor Child position will be relative to the top side of the anchor Master.
Bottom: The anchor Child position will be relative to the bottom side of the anchor Master.
Height: The anchor Child height will be relative to the height of the anchor Master.

Default Setting:
These defaults will be selected when you first create the anchor between a Child and Master, depending on the position:
l
l
l
l

If the anchored Child is positioned to the left of the anchor Master, the Horizontal position will be set to Left.
If the anchored Child is positioned to the right of the anchor Master, the Horizontal position will be set to the Right.
If the anchor Master is positioned under the Child, the Vertical position will be set to Top.
If the anchor Master is positioned above the Child, the Vertical position will be set to Bottom.

When resizing or moving an anchored Child, it is possible to modify the distance between two anchored objects.
When an anchor Master object is deleted, the link between the Master and Child objects is broken. In the Properties panel of
the Child object, Master Object property, will get the suffix “Unresolved”. To re-establish the anchor, you can either link the
Child to a new Master, or create a new object and call it the same name as the previous Master.

Formatting Text
Text formatting in PrintShop Mail can be applied in three different ways. You can apply styles directly to part of your text (see
"Text Style" (page 39)), apply formatting to a paragraph (see "Paragraph Style" (page 40)), or use "Rich Text File" formatting
by using the Text_File function and an external .RTF file (see "TEXT_FILE" (page 153)).

Text Style
You can change the text style (for example, font name, size, color, and style properties) of any part of the text in a text object
or for multiple text objects.
PrintShop Mail offers multiple ways of formatting your text. These styles can be combined for better control.
l
l
l
l
l
l

Bold (example)
Underlined (example)
Italic (example)
Superscript (example)
Subscript (
)
example
Strikethrough (example)

You can also modify the following text properties:
l
l
l

Font: Change the fonts using available system fonts (see PrintShop Mailk Fonts section below)
Font Size: Allows you to make the fonts look bigger or smaller.
Font Color: Allows you to change the color of a font.

To change the styles and properties, first select either a text object, multiple text objects, or any number of characters within a
text object. Then use one of the following options:
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l

l

In Windows:
l The Text menu allows you to change the following styles: Font Size, Bold, Italic, Underline, Font Color.
l The Font dialog (menu Text -> Font...) allows you to change the following styles: Font, Font Size, Bold,
Italic, Underline, Font Color, Superscript, Subscript, Strikethrough
l The Font toolbar allows you to change the following styles: Font, Font Size, Bold, Italic, Underline, Font Color
In Mac OS:
l The Text menu allows you to change the following styles: Kerning, Baseline (subscript/superscript), Bold,
Italic, Underline, Font Color.
l The Fonts dialog (menu Text, Font, Show Fonts) allows you to change the following styles: Font, Font
Size, Bold, Italic, Underline.
l The Font Toolbar allows you to change the following styles: Font, Font Size, Bold, Italic, Underline, Font
Color.

You can also use keyboard shortcuts to control some of the styles:
l
l
l

CTRL+B (Windows) or COMMAND+B (Mac OS): triggers Bold
CTRL+I (Windows) or COMMAND+I (Mac OS): triggers Italic
CTRL+U (Windows) or COMMAND+U (Mac OS): triggers Underline

Note: The text style of a variable depends on the style of the first delimiter, the character marking the beginning of a variable.
(Applying style to variable = apply style to first marker)
Note: The precision of a font size is up to 0.5 points. For example, a font size of 10.5 points is allowed, but 10.3 is rounded to
the nearest half (10.5).

PrintShop Mail Fonts
PrintShop Mail, just like any other software on your system, enables you to use any font installed in your system folders. Additionally (in Windows only), PrintShop Mail can also read any font file located in the same folder as the PrintShop Mail Document, or a Fonts subfolder located in the same folder as the PrintShop Mail Document.
Windows Only: Font reading priority: If you have fonts of the same name in all three possible locations, the priority in which
PrintShop Mail reads the fonts is as such: Fonts in the same folder as the document are checked first. Fonts in the Fonts subfolder are checked second. Fonts in your operating system fonts folder are checked last.
Fonts can always be used by multiple PrintShop Mail Documents.

Paragraph Style
A paragraph is a contiguous range of characters sharing formatting properties such as:
l
l
l
l
l
l

Alignment
Margins
Indentation
Tab stops
Formatting marks
Copy Fitting

Paragraphs are separated by carriage returns. To start a new paragraph, press ENTER while you are typing text.
To align text

To apply alignment to all paragraphs in one or more text objects:
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1. Select the objects.
2. (Windows): Click an alignment button in the Text Formatting toolbar. Alternatively in the Properties Panel, select
Alignment.
(Mac OS): Click an alignment button in the Text Formatting toolbar. Alternatively from the Text menu, select Alignment.
To apply text alignment for a specific paragraph:
1. Double click in a text object to enter Edit mode.
2. Select a paragraph.
3. (Windows): Click an alignment button in the Text Formatting toolbar. Alternately, from the Text menu, select Paragraph. In the dialog box, you can specify alignment, margins and first line indentation values. An appearance sample
is provided to preview the current settings.

(Mac OS): Click an alignment button in the Text Formatting toolbar. Alternatively from the Text menu, select Alignment.
Text direction

To apply text direction.
1. Double click in the text box to enter in Edit mode.
2. In the Text Formatting toolbar, click on the Right to Left button.
Windows

About tab stops

Tab stops enable you to line up text to the left, right or center.
You can select the following tab stops:
Left Tab

Text extend to the right from the tab stop.
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Center Tab Text is centered at the tab stop.
Right Tab Text extends to the left from the tab stop until the tab's space is filled, and then the text extends to the right.
To set and change tab stop positions

To change default tab stop positions:
1. From the Text menu, select Default Tab Stops.
2. Choose your interval value.
3. Click OK.
To set and remove custom tab stop positions, there are two methods available:
l
l

Use the Tab Stops dialog box.
Use the horizontal ruler.

To use the Tab Stops dialog box:
1. Double click in a text object to enter Edit mode.
2. Select a paragraph.
3. From the Text menu, select Tab Stops.
Tab stop positions are relative to the left side of the text object.
4. To add a position, type a value in the edit box and click Set.
5. To add alignment, you can select:
Left: Left text extends to the right from the tab stop.
Center: Center text is centered at the tab stop.
Right: Right text extends to the left from the tab stop until the tab's space is filled, and then the text extends to the
right.
6. To remove a position and alignment, select it in the list box and click Clear.

Formatting marks

PrintShop Mail enables you to control whether formatting marks are hidden or visible in text objects. Formatting marks are
newlines, tabs, and spaces. By default, after starting PrintShop Mail, all formatting marks will be hidden.
You can tell PrintShop Mail to show formatting marks by selecting from the View menu Formatting Marks, or by using the
button "Show or Hide Formatting Marks" on the View toolbar. This works as a toggle for all text objects.
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Formatting marks are just a visual aid, they will not be printed. The marks will scale to the zoom factor of your document, and
they will scale to the font size of the surrounding text. They will also be visible while you're editing text.
New line symbol: ¶
Space symbol: .
Tab symbol: (right arrow)
Copy Fitting

Copy fitting is a feature that will automatically shrink text by reducing the font size, when there is more text than the text box
can hold. The font size will be reduced to the font size needed to fit the text in the text box. However, text will not be shrunk
beyond the specified minimum font size. When the text needs to be resized, all text will be resized step by step until the text
fits or the minimum font size is reached.
Minimum font size

When Copy Fitting is enabled, the minimum font size the font can reach is 1; by default the minimum font size is 8. The downsizing of the text in the box stops if one of the containing font sizes reaches the minimum value or if the text fits.
Allow line breaks

By default the Allow line breaks feature is set to Yes.
When Allow line breaks is set to "Yes", the texts only fit if the individual words are not broken. Text will break on spaces
only. It can occur that lines are broken at spaces, but individual words won't be broken.
When Allow line breaks is set to “No”, the text won't break at spaces, only at returns. The text will be downsized until it fits
(or gives a warning if it still doesn’t fit)
To change this option:
1.
2.
3.
4.

Select the text box. If you have multiple text boxes, you can select all of them.
In the Properties Panel/ Content, select Copy Fitting.
Set Reduce Font Size to Yes.
Change the Minimum Font Size to the desired value.

Mac OS

To change Paragraph settings

You can set the space between lines of text by using the Spacing pop up menu on the PrintShop Mail ruler when a text box is
in edit mode.

To set the line spacing, double click on the text object and select the text you want to adjust and choose Single, Double, or
Other from the Spacing pop up menu.
If you chose Other, choose options for:
l
l
l

Line height: Distance from the top of a line to the top of the line below it.
Inter-line spacing: Distance from the bottom of a line to the top of the line below it.
Paragraph spacing: Distance from the bottom of a paragraph to the top of the first line in the paragraph below it.
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To change default tab stop positions:

You can set margins, paragraph indentation, and text tabs by using the ruler in the edit mode of the text box.
There are four kinds of tab stops and two types of margins, each indicated by a differently shaped icon:
l
l
l
l
l
l

A right facing triangle indicates a tab stop at which text will be left justified.
A diamond indicates a tab stop at which text will be centered.
A left facing triangle indicates a tab stop at which text will be right justified.
A circle indicates a decimal tab stop at which numbers will be justified around a decimal point.
A downward facing triangle indicates a page margin.
A horizontal rectangle indicates the indentation of the first line of a paragraph.

To use the horizontal ruler:
1. Left click on the horizontal ruler to add a paragraph marker.
The marker type depends on the state of the paragraph marker button in the intersecting area of the two rulers (topleft).
2. Left click the paragraph marker button to cycle through all possible paragraph marker types, including first line indentation, or right click this button to select a marker type from the menu.
Note: You can also use the horizontal ruler to specify left and right margins. To do this, left click on the position of either the
left or right side of the text box and drag the margin to the desired location.
Copy Fitting

To change this option:
1.
2.
3.
4.

Select the text box.
From the Item menu, select Show Objects Properties.
In the Object Properties, change Copy Fitting to Yes.
Change the Minimum Font Size to the desired value.

The Preferences Window
The Preferences window lets you set up preferences and settings for PrintShop Mail as well as for the currently opened document. This section demonstrates each section of the Preferences window and its features.
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Program Settings
To specify program preference settings
1. (Windows): From the Edit menu (CTRL+K), select Preferences.
(Mac OS): From the PrintShop Mail menu (Command,), select Preferences .
2. In the left pane, click the Program Settings icon.

About general preferences

Set this option...

To do this...

Variable Markers

Specify the characters that delimit (enclose) the variables in your text objects. See

Measurement in

Select the unit of measurement for PrintShop Mail.

Items without database

Specify the total number of records when no database is open.

Interface language (Windows
Specify which language you want to use.
Only)
Interface theme (Windows
Only)

Specify the appearance of the application user interface. It is possible to choose from:
Classic, Blue, Aqua.

Panels fade out (Mac OS
Only)

When inactive, panels from the Window menu fade out, moving the mouse over a
panel fades it back in.
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About layout appearance preferences

Set this option...

To do this...

Bleed

Specify color.

Folding lines

Specify color.

Crop marks (Mac OS Only)

Specify color.

Printable area

Specify the order in which the printable areas are drawn, relative to the objects. Top specifies that the areas are always visible, Bottom that they are obscured by objects.

Guide lines

Specify the order in which the guide lines are drawn, relative to the objects. Top specifies
that the lines are always visible, Bottom that they are obscured by objects.

Magnetic strength

Define guide line sensitivity when moving or resizing objects. When the cursor comes
within the specified pixel range on either side of a guide line the object snaps to it.

Generate EPS for vertical
text objects(Mac OS Only)

During printing, PostScript for vertical text object is generated in an alternative way.

Color Settings
Color Management compares the color space in which a color was created to the color space in which the same color will
be outputted, and makes the necessary adjustments to represent the color as consistently as possible.
PrintShop Mail Color Management is designed to accurately display the same on-screen color as the color on the printed
output. When you install PrintShop Mail, the color space profiles (Adobe ICC Profiles) will be installed in "Windows\System32\spool\drivers\color\" . When staring PrintShop Mail, the application will load the profiles allowing you to
define colors for the different objects placed in your document.
PrintShop Mail handles the Color Management at two levels:
1. PrintShop Mail originated colors. The colors defined in PrintShop Mail for objects, like border color, fill color and text
color.
2. PrintShop Mail Embedded Color Management. The colors defined for certain image file types, like TIFF, EPS, JPG
Note: PrintShop Mail does not change the Color Management of your image, if your image files have embedded color profiles,
these colors will not be overruled by PrintShop Mail’s Color Management.
You can enable Color Management in the PrintShop Mail Preferences, by default this option is off. Once the Color Management is enabled it is possible to change the working spaces profiles, which allows for colors to be adjusted.
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The default working space color profiles settings are:
RGB: sRGB
CMYK: U.S Web Coated (SWOP) v2
Gray: Gamma 1.8
Rendering: Absolute colorimetric
For example

Suppose you have a colored text box with the following CMYK values:
l
l
l
l

Cyan: 100 %
Magenta: 0%
Yellow: 0%
Black: 0%

These values are an indication of the color intended to be printed, but because of the different monitors, printers, inks, types of
paper these values may yield a different color on the printed output.
To avoid this, Color Management translates colors with the help of color profiles.
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To enable Color Management:

From the Edit menu, select Preferences or press Ctrl+K and click on the Colors icon.
1. Check the option “Enable colormanagement”.
2. In the working space section select your desired color profile.
3. Click Apply.
The colored object will change slightly depending on the chosen color profile, but in the Properties panel the CMYK values for
that color will stay the same.
Rendering

Rendering is the process of converting one color space to another color space. The result of choosing a rendering intent
depends on the content of documents and on the profiles used to specify color spaces. Some profiles produce identical results
for different rendering intents. Differences between rendering intents are apparent only when you print a document or convert
it to a different color space.
The following rendering intent options are available:
l
l
l
l

Absolute colorimetric
Perceptual
Relative colorimetric
Saturation

In a Color Management workflow, you can use the precision of color profiles to soft proof your document directly on the monitor. You can display an on-screen preview of how your document’s colors will look when reproduced on a particular output
device. The reliability of the soft proof depends upon the quality of your monitor, the profiles of your monitor and output
devices. To preview how the color will look when printed, select Print Preview and click ColorSoft proof.
Soft proof colors show the color profile defined in the Color Management.
Note: This feature is enabled when Color Management is activated.
Color Management for on-screen preview is different from Color Management reproduced in a particular output device. You
have more control over the appearance of the document on a particular output device than with on-screen preview, because
your document may appear on a wide range of possible uncalibrated monitors and video display systems which limits control
over the color consistency.
To control the color consistency it is possible to assign a color profile to the monitor. In a workflow such a profile would be provided by the monitor manufacturer or the profile would be created using specialized equipment that measures the monitor's
color space.
To provide a practical means for color consistence you can change the monitor color profile to match your output device. To do
this:
Windows 2000 and Windows XP
1.
2.
3.
4.
5.

In the Control Panel, select Display.
Click on the Setting tab.
Click on Advanced
Select the “Color Management” tab.
Click on Add, to add the desired monitor color profile for your documents

Note: You need to restart PrintShop Mail for the changes to take effect.
Windows Vista
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1.
2.
3.
4.

In the Control Panel, select Personalization.
Select Display Settings from the list.
Click on the Advanced Setting tab.
Select the “Color Management” tab.
Here you can add color profiles for each device on your system (monitor and printers).
5. Click on the Advanced tab and from the drop down menus select the desired color profiles.

Print Job Settings
To specify print job preference settings
1. (Windows): From the Edit menu (CTRL+K), select Preferences.
(Mac OS): From the PrintShop Mail menu (Command,), select Preferences .
2. In the left pane, click the Print Job Settings icon.
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About print job preferences
Set this option...

To do this...
Print Margins are empty spaces all around the page. The margin (top, bottom, left, right) is
usually the empty space between where the page is cut and the layout area of the page.
PrintShop Mail allows you to make changes to the print margin for all layouts in the document. It
is possible to:

Print Margins

l
l

l

Center (Windows only): Where the layout(s) will be centered on the paper.
Offset: Where you can specify different values for each print margin: Top-Bottom (Y offset) and Left-Right (X offset).
Note: PrintShop Mail supports different paper sizes within one document. Print Margins
settings will be applied to the whole document.

Technology

Select which print technology is used to optimize your PostScript output. See "Printing Basics"
(page 102) for more information on these options.

Print report page

Specify that a report page is printed at the end of the job.

Send custom error
handler (Windows
only)

Specifies whether a Postscript error will generate a custom error page containing tips on how to
solve the problem. Leave this box unchecked if you want your printer to handle any errors.

Repetition Settings
Use these settings bellow for Multi-up printing. See How to Use Layout Repetition for more information.
To specify repetition preference settings
1. (Windows): From the Edit menu (CTRL+K), select Preferences .
(Mac OS): From the PrintShop Mail menu, select Preferences .
2. In the left pane, click the Repetition Settings icon.

©2010 Objectif Lune Inc

- 50 -

The PrintShop Mail program interface

©2010 Objectif Lune Inc

- 51 -

The PrintShop Mail program interface

About repetition preferences
Set this option...

To do this...
Specify how the actual multi-up is done. The number
between parentheses indicates the maximum number of
repetitions possible with the current layout and print settings.

Layout Repetition

l

l

Horizontal repetition: Specify the amount of layouts positioned in the horizontal direction (number of
columns).
Vertical repetition: Specify the amount of layouts
positioned in the vertical direction (number of rows).

Spacing between layouts

Specify the horizontal and vertical distance between each
layouts when using layout repetition.

Repetition Preview

Shows the repetition order on the page. When the defined
Horizontal and Vertical repetition does not fit on the page,
the layouts on the left and bottom are represented with a
dash line.
Specify the priorities (1,2,3) and direction (Left to Right,
Right to Left , Top to Bottom, Bottom to Top, Front to Back,
Back to Front) in which the records in your document are
going to be printed. You can specify:

Priorities

l

l

l

Left to Right, Right to Left: Influences the horizontal repetition.
Top to Bottom, Bottom to Top: Influences the
vertical repetition.
Front to Back, Back to Front: Allows printing
Through-the-stack

Specify that the positions of the layouts on the back of each
page should match de positions of the layouts on the front of
each page. In effect, the layout positions on the back will
mirror the layouts in front of the page.
l

Mirroring

l

l

l

Based on driver settings: The document will be
printed duplex according to the settings in the printer
driver, provided the driver supports this.
Flip on long edge: Layouts in the back side of the
page will be mirrored through the long edge of the
page.
Flip on short edge(Windows only): Layouts in
the back side of the page will be mirrored through
the short edge of the page.
Simplex: The document does not require mirroring
of the layouts.

PrintShop Mail for Windows supports mixed layout sizes, except when layout repetition is used. When using layout
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repetition, the first layout size will be the layout size for the complete document.

Imposition Settings

To open the Impositions preference dialog:
1. (Windows): From the Edit menu (CTRL+K), select Preferences.
(Mac OS): From the PrintShop Mail menu (Command,), select Preferences .
2. In the left pane, click the Imposition Settings icon.
Available options:
l

l

l
l

Bleed Margins: This specifies bleed margins (see "Bleed Margin" (page 60))
l Page Level (Windows Only): To add bleed to the page, the bleed is positioned around a set of layouts, thus
keeping the layout size the same as before.
l None: No bleed margin will be used.
l Include in Job: To subtract the bleed margin from your layout, the bleed is positioned around each layout,
thus keeping your layout size the same as before.
l Width: To set the width of the bleed margin.
Crop Marks: Specify crop marks settings (see "Crop Marks" (page 61)). This option is only available if the Bleed Margins is not set to None.
l None: No crop marks will be drawn.
l Standard: One line will be indicated for each trim position.
l Japanese: Two lines will be indicated for each trim position.
l Double Sided: When using duplex and you select this option the crop marks will be printed in both sides of the
paper.
l Gap size: Specify gap size as the distance between the actual crop mark and the edge of the layout.
l Color (Windows Only): It is possible to select a color for the Crop marks.
Folding Lines: Specify the length of folding lines. (See "Folding Lines" (page 59))
Center Layouts on page (Mac OS Only): Select this option to center layouts on the physical paper.
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PrintShop Web Settings
Note: Use the settings bellow to fill in the URL and the login account for your company Web Server. See Publishing Documents, for more information about creating and publishing PrintShop Mail documents to PrintShop Web.
To specify PrintShop Web Preference settings
1. From the Edit menu (CTRL+K), select Preferences.
2. In the left pane, click the Publish to Web
icon.
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About PrintShop Web preferences
Set this option...

To do this...

Server address
(URL)

Specify the company Web Server.

Login (Username Specify the username and password assigned by the administrator to log in the company Web Server.
and Password)
If you do not have an account, please contact your Web server's administrator.
Test Connection...

To establish a connection with the publication server.

Also publish dataTo add the opened database to the published document.
base

PlanetPress Suite
PlanetPress Suite settings
PlanetPress Watch is a powerful printing software for transforming and distributing print jobs from virtually any host. Transforming and distributing print jobs allows for automated local and remote printing, integrated PDF generation for archiving,
emailing and faxing.
Options for the PlanetPress Suite can be added to a PrintShop Mail output job through the Preferences panel, which enables
you to send PrintShop Mail output to a location or queue that is being watched by PlanetPress Watch. This makes that PrintShop Mail output can be further processed to be archived or emailed or sent by fax.
For example, PDF files can be automatically generated and mailed to addresses defined by the customer.
Defining fields in PrintShop Mail
1. Create a PrintShop Mail document.
2. From the File menu, select Preferences, click on the Publish to Web icon.
Make sure the Server address and login settings are empty.
3. Click on the PlanetPress Suite icon.
4. Define the output type for your document.
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Set this
option...

To do this...

Fax

Number: Specify the fax number from the data fields of the currently opened database or the variable you created.
Description: Specify the description from the data fields of the currently opened database or the
variable you created.

Email

Number: Specify the email address from the data fields of the currently opened database or the
variable you created.
Subject: Specify the email subject from the data fields of the currently opened database or the variable you created.
Body text: Specify the email content from the data fields of the currently opened database or the
variable you created.

PDF Bookmark

Create a standard PDF bookmark.

Archive

Name: Defines a descriptive name for the archive or for the item to be archived.
Variable: Specify a data field of the currently opened database or the variable you created.

5. Click on the Publish to Web icon in the Standard toolbar or from the File menu select the submenu Publish to
Web.
6. When you click Finish in the Publish to Web dialog, a window will be opened to save the document as a zip file.
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7. PlanetPress Watch captures the PostScript file (zip fle) and routes it to the appropriate device to output the document.
For more information about PlanetPress Watch, please visit http://www.objectiflune.com/

Default Settings
When you start PrintShop Mail, it always opens with a blank document that uses default settings for the layout sizes and other
preferences. You can change those preferences so that new blank documents will have your own, custom settings. This can
be a time saver if you often create new documents and have to set your preferences each time.
To modify the default preferences:
1. Close your currently opened document by clicking on the File menu then selecting Close.
2. Open the Preferences menu:
l In Windows: From the Edit menu, select Preferences (or use the CTRL+K keyboard shortcut)
l In Mac OS: From the PrintShop Mail menu, select Preferences (or use the
+, keyboard shortcut)
3. Make the changes you want to any of the sections of the preferences.
4. Click OK in the preferences window to save the changes.
Starting from now, any new document that you create will use these preferences. To change the default settings in the future,
simply repeat these steps.
To reset PrintShop Mail to its default settings
You can reset the preferences to the default settings that were in effect when you first installed PrintShop Mail.
1. Close PrintShop Mail
2. Double-Click on the PrintShop Mail icon on your desktop, or click on it from the Start Menu, Programs, PrintShop
Mail Suite 7
3. Immediately when the Splash Screen appears, press and hold the CTRL and SHIFT keys on your keyboard.
The following dialog is displayed:

4. Check the settings that you want to reset to the defaults:
l Window positions: Resets all of the windows and panels to their original, default locations and states.
l Toolbar configuration: Resets the position, order and appearance of all the toolbars and their buttons to
their original defaults.
l Preferences: Resets all of the Preferences to their original defaults, except for the language of the interface.
5. Click OK to apply the reset and open PrintShop Mail.
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Layout Basics
A PrintShop Mail document can consist of multiple layouts.
To insert a layout
1. From the Layout menu, select Insert.
2. Choose where you want to insert the layout.
3. Click OK.
To see your current layouts:
l
l

In Windows: Open the "Layouts Panel" (page 19) from the Window menu.
Mac OS: Select Show Document Layouts from the Window menu.

To duplicate a layout
1. Go to the layout which needs to be duplicated.
2. From the Layout menu, select Duplicate.
Alternatively (Windows): in the Layouts Panel, right click on the layout you want to duplicate and from the submenu
select Duplicate.
Alternatively (Mac OS): in the Layout Panel, click on the layout you want to duplicate, then click on the plus sign at
the lower right corner of the panel.
To remove a layout
1. Go to the layout which needs to be removed.
2. From the Layout menu, select Remove.
Alternatively (Windows): in the Layouts Panel, right click on the layout you want to remove and from the submenu
select Remove.
Alternatively (Mac OS): in the Layout Panel, click on the layout you want to remove, then click on the minus sign at
the lower right corner of the panel.
To change the layout size and orientation
1. From the Layout menu, select Size.
2.
3. Make the appropriate changes.
Under Windows, you can apply the changes to:
l
l
l
l

Selected Layout
Current Layout
This point forward
Whole document
Under Mac OS, PrintShop Mail does not support multiple layout sizes within one document.

Guide Lines
Guide lines are non printing grid lines to help you to arrange and position objects. Moving or resizing objects to within a certain
distance of a guide line causes the selection to snap to the line.
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To add a guide line
Windows
1-Insert from the Insert menu
From the Insert menu, select Guide line
Select Horizontal or Vertical line.
Drag the mouse to the exact position where you want to place the guide line and left click on it.
2-Insert from the Ruler
Right click on the ruler. The contextual menu will show “Guide line” and “Folding line”.
Select Guide Line.
Use the horizontal ruler to add a vertical guide, and the vertical ruler to add a horizontal guide. Left clicking on a ruler
adds either a guide line or a folding line, depending on the icon displayed in the top left corner of your work area.
Mac
From the View menu, select Layout Ruler. Select either a horizontal or vertical guide line.

Note: When you drag a guide line, its default behavior is to snap to any existing objects. You can change this behavior by
selecting or clearing the Guides Snap to Objects option in the View menu .
To set the "snap to" distance
Set the distance required for objects to snap to guide lines in Program settings, under Magnetic strength. The indicated number
of points is the distance from the guide, within which an object will be drawn to the guide position.
To modify a Guide line position
1. Select the Guide line.
2. Right click on it.
3. From the menu select “Position”.
The window will show the current coordinates of the Guide line.
4. Enter the new coordinates for the line position.
To remove a guide line
It is possible to remove a guide line by dragging it to an invalid location outside the layout. The drag cursor is updated to reflect
whether releasing the mouse button will move or remove the folding line. Alternatively right click on the guide line and from
the menu select " Remove" .

Folding Lines
You can use folding lines to determine where to fold documents. Folding lines are printed on the visible part of the document
(the part that will remain when the document is cut to the right size, for example they are also printed when there is no bleed
margin). Unlike guide lines, folding lines are part of the print output, they are printed on either side of the document.
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To add a folding line
Windows
1-Insert from the Insert menu
From the Insert menu, select Folding line
Select Horizontal or Vertical line.
Drag the mouse to the exact position where you want to place the folding line and left click on it.
2-Insert from the Ruler
Right click on the ruler. The contextual menu will show “Guide line” and “Folding line”.
Select Folding Line.
Use the horizontal ruler to add a vertical line, and the vertical ruler to add a horizontal line. Left clicking on a ruler adds
either a guide line or a folding line, depending on the icon displayed in the top left corner of your work area.
Mac
From the View menu, select Layout Ruler. Select either a horizontal or vertical guide line.

To change a folding line:
l

l

Length - Use the Imposition settings dialog box to change the length of the folding line. The overlay length of a folding
line specifies the length on the visible part of your document (for example, excluding any bleed margin).
Color - Use the Program settings dialog box to change the color of the folding line.

To modify a folding line position
1. Select the Folding line.
2. Right click on it.
3. From the menu select "Position"
The window will show the current coordinates of the folding line.
4. Enter the new coordinates for the line position.
To remove a folding line
It is possible to remove a folding line by dragging it to an invalid location outside the layout. The drag cursor is updated to
reflect whether releasing the mouse button will move or remove the folding line. Alternatively right click on the folding line and
from the menu select " Remove" .

Bleed Margin
A bleed margin is a part of your layout that is printed to the edge of a finished page.
Once a page is reproduced on press, the bleed margin is removed.
In PrintShop Mail, your total layout size (as seen in Size in the Layout menu) includes the bleed margin. To learn how to set
bleed margins, see "Imposition Settings" (page 53).
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When applying a Custom size to a layout and the bleed margin selected is at Page Level, the bleed is not displayed at
the edge of the paper, but around the set of layouts.
Once you specified the Bleed Margin, check the "Crop marks" option and specify the Gap size, which is the distance between
the crop marks and the edge of the document.

Crop Marks
Crop marks are printed lines that make it easier to trim the document to its finished size after the bleed margin is removed.
Crop marks are only printed if the layout includes a bleed margin.
To learn how to add crop marks, please see "Imposition Settings" (page 53).

Supported Image Formats
These are the supported graphical formats and associated filename extensions:
Graphics Format

Filename Extension

Encapsulated PostScript

EPS or EPSF

Windows Bitmap

BMP

Portable Document Format (*)

PDF

JPEG File Interchange Format

JPG, JPE or JPEG

Tagged Image File Format (**) TIF or TIFF
Windows MetaFile

WMF

PNG

PNG

GIF

GIF

l
l

(*) Microsoft Word documents (DOC, DOCX) are converted to PDF.
(**) PrintShop Mail fully supports LZW-compression.
The Mac version of PrintShop Mail uses QuickTime to handle image files. The supported image file formats therefore
depend on your version of QuickTime. For a list of image file formats you can visit www.apple.com.

Windows Shortcuts
The following keyboard shortcuts can be used to save some time by using the keyboard instead of reaching for the mouse.
File Menu
Menu

Action

New Blank Document

Ctrl+N

New PDF Based Document Ctrl+Shift+N
Open

Ctrl+O

Close

Ctrl+W
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Menu

Action

Save

Ctrl+S

Save As...

Ctrl+Shift+S

Page Setup

Ctrl+Shift+P

Print Preview

Ctrl+F2

Print

Ctrl+P

Exit

Ctrl+Q
Edit Menu

Menu

Action

Undo

Ctrl+Z

Redo

Ctrl+Y

Cut

Ctrl+X

Copy

Ctrl+C

Paste

Ctrl+V

Select All

Ctrl+A

Preferences Ctrl+K
View Menu
Menu

Action

Preview

F2

Zoom In

Ctrl++

Zoom Out

Ctrl+-

Actual Size

Ctrl+Alt+0

Whole Layout

Ctrl+0

Rulers

Ctrl+R

Object Borders Ctrl+H
Insert Menu
Menu

Action

PDF

Ctrl+Shift+W

Image File

Ctrl+Shift+E

Variable Text Ctrl+Shift+T
Image Box

Ctrl+Shift+G

Text Menu
Menu

Action

Italic

Ctrl+I

Bold

Ctrl+B

Underline Ctrl+U
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Editing Text (advanced)
Action

Keys

Change bullet style

Ctrl+Shift+L

Line spacing = 1 lines

Ctrl+1

Line spacing = 2 lines

Ctrl+2

Line spacing = 1.5 lines

Ctrl+5

Select font name

Ctrl+Shift+F

Increase font size

Ctrl+Shift+>

Decrease font size

Ctrl+Shift+<

Increase character spacing Ctrl+Shift+]
Decrease character spacing Ctrl+Shift+[
Reset character spacing

Ctrl+Space

Database Menu
Menu

Action

Open

Ctrl+D

Close

Ctrl+Shift+D

First Record

Alt+Up

Previous Record Alt+Left
Next Record

Alt+Right

Last Record

Alt+Down

Find Record

Ctrl+F

Window Menu
Menu

Action

Layouts

Ctrl+1

Variables

Ctrl+2

Database

Ctrl+3

Warnings

Ctrl+4

Verification Result Ctrl+5
Properties

Ctrl+6

Fonts

Ctrl+7

Help Menu
Menu

Action

Help Topics F1
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Macintosh Shortcuts
PrintShop Mail Menu
Menu

Action

Preferences

Command,

Hide PrintShop Mail Command + H
Hide Others

Alt + Command + H

Quit PrintShop Mail

Command + Q
File Menu

Menu

Action

New

Command + N

New PDF based Document.. Shift + Command + N
Open

Command + O

Close

Command + W

Save

Command + S

Save As...

Shift + Command + S

Page Setup

Shift + Command + P

Print...

Command + P

Print Record

Alt + Shift + Command + P

Print Report Page

Alt + Command + P

Edit Menu
Menu

Action

Undo

Command + Z

Redo

Shift + Command + Z

Cut

Command + X

Copy

Command + C

Paste

Command + V

Delete

Backspace

Select All

Command + A

Spelling

Command:

Check Spelling Command;
View Menu
Menu

Action

Toolbar

Alt + Command + T

Preview

Command + Y

Layout Rulers Alt + Command + R
Zoom in

Command + +
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Menu

Action

Zoom out

Command + -

Actual size

Command + =
Insert Menu

Menu

Action

Image File

Shift + Command + E

Variable Text

Shift + Command + T

Variable Image Shift + Command + G
Item Menu
Menu

Action

Lock Position

Command + L

Unlock Position

Shift + Command + L

Show Object Properties Command + Return
Text Menu
Menu

Action

Show Fonts

Command + T

Copy Font

Alt + Command + C

Paste Font

Alt + Command + V

Style Bold

Command + B

Style Italic

Command + I

Style Underline Command + U
Copy Tabruler

Command + 8

Paste Tabruler

Command + 9

Show Colors

Shift + Command + C
Layout Menu

Menu

Action

First

Alt + Shift + Command + Left

Next

Shift + Command + Right

Previous Shift + Command + Left
Last

Alt + Shift + Command + Right

Go To...

Command + J
Database Menu

Menu

Action

Open

Alt + Command + O

Close

Alt + Command + W

First Record

Alt + Left

Next Record

Command + Right
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Menu

Action

Previous Record Command + Left
Last Record

Alt + Right
Window Menu

Menu

Action

Minimize

Command + M

Show Database

Command + 1

Show Variables

Command + 2

Show Layout Conditions

Command + 3

Show Fonts

Command + 4

Show Document Layouts Command + 5
Show Warnings

Command + 6

Help Menu
Menu

Action

PrintShop Mail Help Command + ?
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Create a New Document
You can create a new PrintShop Mail document either from a blank document, a template, or a PDF file. By default, PrintShop
Mail always starts with a blank document with a default size.
To start with a blank document
1. Open the File menu
2. Select New
3. Select Blank Document
You can also create a new blank document by use the CTRL+N (Windows) and

+N (Mac OS) keyboard shortcuts.

The size of this blank layout is set to Fit to Page. For more information on layout sizes, see "Specify the Layout Size" (page
68).
To create a new document from a PDF:
1.
2.
3.
4.
5.

Open the File menu.
Select New.
Select PDF-based document.
Browse to the PDF file you want to use for your document.
Click Open.

You can also use the keyboard shortcut CTRL+SHIFT+N in Windows to create a new PDF-Based document.
PrintShop Mail will automatically create one layout per page in your PDF, so if your document has 5 pages you will now have a
PrintShop Mail document with 5 layouts. Each layout size is the same as the size of the page in the PDF. PDF pages are treated
as separate objects. It is possible to scale the PDF pages around on the layout.
You can also use a Microsoft Word (.doc) document in PrintShop Mail. If you select a Word document, it is automatically converted into PDF format and treated as a PDF throughout your design. If the original Word document is modified, PrintShop Mail
will notify you that the document has changed and will ask if you want to update the PDF in your PrintShop Mail document.
To create a new document from a template:
1.
2.
3.
4.
5.

Open the File menu.
Select New.
Select Template-based document.
Browse to the template file you want to use
Click Open.
In order to use a template you have to first create one. Please see "PrintShop Mail Templates" (page 68).
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PrintShop Mail Templates
PrintShop Mail allows you to create PrintShop Mail templates. Templates are PrintShop Mail documents that you can design for
later use, for example for Publishing to PrintShop Web. These templates contain the (background) layout and the document
settings.
To create a template
1. Create a PrintShop Mail document either by opening an existing blank one, opening an existing document, or creating a
new template-based document.
2. Make any modifications to the document that you desire in your template
3. From the File menu, select Save as Template.
PrintShop Mail templates are saved with the extension ".PSMT". By default PrintShop Mail templates will be saved in the Template folder which is located in the PrintShop Mail application folder.
Modifying the template
It is possible to modify PrintShop Mail templates to change the document settings or content.
1. From the File menu, select Open Template.
2. Make the desired changes.
3. From the File menu select Save As Template.
A template does not save the link to the database you may have used in the designed stage of the PrintShop Mail document.

Specify the Layout Size
Windows
A PrintShop Mail document may consist of one or more layouts, which can be of different sizes. PrintShop Mail for Windows supports multiple layout sizes within one document.
To access the layout size properties:

1.
2.
3.
4.
5.
6.

Select the layout of which you want to change the layout size from the "Layouts Panel" (page 19).
Open the Properties Panel by clicking on Window, the selecting Properties.
Click on the Layout Size option in the Properties Panel. This triggers the [...] button next to the layout size.
Click on the [...] button to open the Layout Size options
Modify the options you want
Click OK to save the changes.
PrintShop Mail for Windows Layout Size Options

Setting Description
Select the layout size from the following options:
l

Size

l

l
l

Fit to Page: Fits the layout so it corresponds exactly to the Page Size.
Fit to Objects:The layout will start at the top-left of the page and will resize itself dynamically to fit all the
objects on the page until the lower-rightmost corner of the lower-rightmost object.
Custom Size: Lets you specify any custom size.
A3/A4/Legal/Letter/etc: Lists all of the paper sizes available in the printer that is currently selected in
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Setting Description
the Page Setup dialog.
Width

Enter custom width. This setting is editable if you select "Custom Size".

Height

Enter custom height. This setting is editable if you select "Custom Size".

Shape

Select either Tall or Wide.

Current Layout: Will apply only to the currently selected layout.
Apply to This point forward: Will apply to this layout and any located after it.
Whole document: Will apply to all of the layouts including this one.
PrintShop Mail for Windows supports mixed layout sizes, except when layout repetition is used. When using layout
repetition, the first layout size will be the layout size for the complete document. See "Repetition Settings" (page 50).
Mac OS
A PrintShop Mail document may consist of one or more layouts, all having the same size. There are two ways to specify the layout size and orientation.
Automatic Layout Size

You can choose to base your layout size on the currently selected paper size in the Print Setup dialog, by selecting Layout
Size Automatic in the Layout menu. This will cause PrintShop Mail to dynamically resize your layouts to fit on the paper,
even when you are using layout repetition.
Fixed Layout Size

You can specify a fixed layout size in the Layout Size dialog. This will force your layout size to stay the same, independent of
the currently selected printer and paper size.

PrintShop Mail for Mac OS Layout Size Options
Setting

Description

Size

Select a standard size for the PrintShop Mail document, A4, A5, B5, US Letter, US Legal. Select Custom Size to
enter customized settings.

Width

Enter custom width. This setting is editable if you select "Custom Size".

Height

Enter custom height. This setting is editable if you select "Custom Size".

Orientation Select either Tall or Wide.
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Specify Spot Colors
Spot Colors are special premixed inks used instead of, or in addition to CMYK inks. Spot Colors are used in offset printing to
reduce printing cost or to provide solid colors that can not be exactly reproduced using process colors (such as CMYK). For
example to be able to print colors like gold and silver, some printers can accommodate an extra toner or cartridge filled with
that dedicated ink.
Spot Colors are only available in PrintShop Mail for Windows, and are not currently available in the Mac OS version.
PrintShop Mail allows you to enable Spot colors in order to print the document with the desired colors.
To open the Spot Color dialog
1. From the Edit menu, select Spot Colors.
The Spot Color window is shown

2. Spot Color " Name": A descriptive name is defined here.
3. Separation"Name": The name of the ink/cartridge as known on the device (printer/RIP). This must be identical to the
name configured on the device.
4. Alternate color: The Alternate color will be used at printing if the Spot Color is not available on the device and it
will be used as the displayed color on the screen preview at design time. This color may be complete different from the
actual Spot Color
To add a new Spot Color
1. Click the New button.
2. Type the Separation name.
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3. Select the desired Alternatecolor from the drop down list or create a Custom color.
4. Click Save.
Spot Colors are saved with the current document. The Spot Color will not be saved as an application setting.
To remove a Spot Color
1. Select the Spot Color you want to remove
2. Click the Remove button.
If a Spot Color is currently used in your document, it cannot be deleted, only modified.
To modify an existing Spot Color
1. Select the Spot Color you want to modify
2. Change the name, separation and alternate color as desired.
3. Click Save.
Spot Colors in EPS files
Spot Colors defined in EPS files are recognized and loaded in the Spot Color dialog as though it is defined in the document
itself. If a Spot Color defined in an EPS file has the same name as an already existing Spot Color definition but is in fact a different Separation, a warning will be shown. As a result the used Spot Color will be sent to the printer (unmodified) and depending on the availability of the Spot Color on the printer, the Spot Color or the Alternate color will be printed.
Limitations
There are some limitations based on the printer and PrintShop Mail capabilities.
l
l
l

l

The number of Spot colors used in a document is limited to the printer capabilities.
PrintShop Mail cannot determine if a Spot Color is available on the device.
Support for EPS with DCS (Desktop Color Separation) is limited to one separation in the DCS. If the EPS exceeds this limitation, PrintShop Mail will return a warning: "«filename».eps is a color separated file and might not print correctly."
When verifying a document, the verification results show all used Spot Colors in the document.

Open a Database
A database is a file or service that contains data that you can use in your document. PrintShop Mail can read a database one
record at a time and use the fields on that line in your text as variables. A field is a single piece of information, a record is one
complete set of fields and a file is a collection of records. Traditional databases are organized by fields, records and files.
To open a database file:
1. From the Database menu, select Open.
2. Browse for a database file (see "Supported Database Formats" (page 73)).
3. Select the database and click on Open.
If you open a delimited text file (such as CSV or Tab-Delimited files), you will be presented with the Open Delimited
Text File dialog (Windows Only). See Delimited Text Files.
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To open a database through ODBC (Windows Only):
1. From the Database menu, select Open.
2. Click on ODBC Data Sources on the left.
3. Select an ODBC Data Source on the right and click on Open.
ODBC Data Sources can be created via the Windows Control Panel / Administrative Tools / ODBC Data Sources. For
more information on creating ODBC Data Sources, please refer to the Microsoft Windows documentation.
PrintShop Mail only supports one active table at a time. If a database contains multiple tables, you will be presented with the
Select Table dialog.
To select a specific table or view in your database, simply click on it in the list of available tables in the Select Table dialog.
You can also use an SQL query in order to display custom data. This is only available with database formats that support SQL
queries (Access, SQL, Excel)
To sort the database
In Windows:
1. Select from the menu Database : Sort > Edit.
2. Specify your sort conditions by selecting a database field from the drop down menu and specifying the sort order.
3. Click OK.
In Mac:
1. Open the Database floater and click the Edit button next to Sort checkbox.
2. Select a database field in the list to the left and press Add button to copy it to the Sort Order list to the right. Double
clicking the field name has the same effect. Repeat the steps with all the fields that you want to use as further sort keys.
3. It is possible to specify the Sort Order per selected field, which is either Ascending or Descending by selecting a
sort key in the list to the right and dragging it up or down, or remove a sort key by selecting it and clicking Clear, or
double click the sort key.
4. Press Sort to sort the database and Ready to close the dialog.
To filter the database
In Windows:
1. Select from the menu Database: Sort > Edit.
2. Select up to 4 filter criteria, by selecting the database field to compare, the type of comparison to do (see list below)
and what value to compare it too.
Available types of comparison:
l Contains: Database field contains the string indicated.
l Equals: Database field is exactly equal to the string indicated.
l Does not equal: Database field is not exactly equal to the string indicated.
l Is less than: Database field is numerically smaller than the number indicated.
l Is less than or equal to: Database field is numerically smaller or equal to the number indicated.
l Is greater than: Database field is numerically larger than then number indicated.
l Is greater than or equal to: Database field is numerically larger or equal to the number indicated.
l Is empty: Database field is empty
l Is not empty: Database field is not empty (contains any character, even a space)
l Starts with: Database field starts with he string indicated.
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3. At the end of each criteria, select if you want to combine all the conditions together (And) or if any condition can be true
for the record to appear (or).
4. Click OK.
In Mac OS:
l
l
l

Open the Database window and click Edit button next to the Filter checkbox.
Enter an expression of which the result can only be true or false.
Select Filter from the Database menu or click the Filter checkbox in the database window to apply your filter settings. Selecting or deselecting the filter option, toggles between using the entire database or using only the filtered records. The filter option is enabled only when the database is currently open.
Data Fields: For the purpose of publishing PrintShop Mail documents to PrintShop Web, you can design a PrintShopMail document with or without linking it to a database. The entries you will find in the Data Fields panel in PrintShop Mail, represent data fields that occur in the document. These fields are either referred to in expressions (for
variables or layout conditions, without the need to be directly linked to a database), or they refer to actual database
fields (when the document is already linked to a specific database). Data Field Properties are relevant for Publishing
to PrintShop Web. For more information about Data Fields, see Publishing Documents.

Supported Database Formats
These are the supported database formats and associated file name extensions:
Database Format

File Name Extension

Note

dBase

DBF

Extensible Markup Language

XML

See XML Database Format

Microsoft FoxPro

DBF, DBC

(Windows Only)

Microsoft Access

MDB, MDA, MDE, ACCDB, ACCDA,
ACCDE

(Windows Only)

Microsoft Excel

XLS, XLSX, XLSB, XLSM

Paradox

DB

(Windows Only)

Text

TXT or CSV

See "Delimited Text Files" (page
73)

Oracle/SQL

Through ODBC connection

(Windows Only)

Delimited Text Files
PrintShop Mail supports opening any text file that is delimited with a special character. Generally these files are CSV files
(Comma Separated Value), but can also be tab-delimited, pipe-delimited, etc.
When you open a delimited text file using the Database, Open menu, you are presented with the Open Delimited Text File
dialog.
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1. Encoding: Select the encoding that is used in the text file. PrintShop Mail detects the encoding automatically. In most
cases, you can leave this setting as its default. If you know that the text file was created using a different encoding that
the encoding that you are using on your computer, you should change this setting to match it. For example, if your computer is set to use encoding 1251(Cyrillic, Windows), but you know that the file was created by using encoding
1252(Western European, Windows), you should change it to 1252.
2. Separator: Select the character that separates values in your text file. If the character is not listed, select the Other
check box, and then type the character in the box that contains the cursor.
3. Create field names: If no field names are part of the database, PrintShop Mail can add the field names for you. The
field names have the following structure Field <<number>>, where the number is formatted as three digits with
leading zeros starting at 1 (such as Field1, Field2, etc).
Delimited Text File Limitations:
l

l
l
l
l

l
l
l
l

The maximum number of fields supported is 255 for all types of delimited text files. Any row beyond 255 is ignored by
PrintShop Mail.
The first line in your text file should contain the field names.
Field names should only contain alphanumeric characters and underscores.
The records should be listed on the following lines.
The field separator is either a tab, a comma, a space, a semicolon or a user-defined character (not alphanumeric or
underscore) and these separators cannot be used in field contents.
If a field contains a field separator character, it should be enclosed in double quotes in order to be treated as one string.
Two adjacent field separators imply that an empty field is placed between them.
The record separator is a newline character.
Any missing fields at the end of a line are left empty.
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Objects are pieces or components that you place in your PrintShop Mail document to display some sort of data on your page.
Objects include text, images, barcodes and others.
To learn how to manipulate objects, see "Manipulating Objects" (page 33).

Text Object
You can display text on your page using a mix of static and variable text. Variable text is generally constructed using pieces
from your database, sometimes using conditions to control what text appears and when.
To add a text object to your document:
1. Click on the Text Object button in the Tools toolbar (
)
2. Using your mouse, create a box on the document by clicking and holding the mouse button where you want one corner
to be, then moving the mouse to where you want the opposite corner and letting go of the button.
3. Start typing your text using static text and variables (see "Working With Variables" (page 83)).
4. You can apply styles and formatting to your paragraphs and text. See "Text Style" (page 39) and "Paragraph Style"
(page 40)).
5. Click outside of the text object to see the result as it will appear.
You can also create a text box of the default size by dragging a Database Field onto your page. This creates a text
box that contains one variable with the same name as your data field, and that variable will have the data field as an
expression.

Add Static and Variable Images
In PrintShop Mail, image objects can contain either static or variable images. Using variable images with PrintShop Mail allows
you to personalize your documents with pictures.
Note: For a list of supported image formats, see Supported Image Formats.
About static images
Static images are not linked to a variable, which means that they are always associated with the same image file throughout
your whole document.
To insert a static image
1. Click on the Image Object button in the Tools toolbar.
2. Using your mouse, create a box on the document by clicking and holding the mouse button where you want one
corner to be, then moving the mouse to where you want the opposite corner and letting go of the button.
3. In the dialog box, browse to the image to insert.
4. Click Open.
You can also insert the Image Object via the Insert -> Image File menu. This create the Image Object at the top-left
corner of the document.
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Images added to the document will be within an area called the Bounding Box. You do not manipulate the image directly but
rather its bounding box. Images will always fit within the bounding box and their image ratio will not change. For example, if
you resize the bounding box horizontally to make it wider, the image will center itself but not be bigger. If you resize the box
vertically afterwards, then the image will grow to fit. The initial size of an image depends on its resolution. PrintShop Mail
assumes an image resolution of 96 DPI (Dots Per Inch), except for EPS (72 DPI) and TIFF files. The resolution of a TIFF image
is stored in the file itself.
About variable images
Variable images are linked to variables in the same way as variable text. The result of the expression associated with a variable image should be an image file name.
To insert a variable image
1. Click on the Insert Image Box button in the Tools toolbar.
2. Using your mouse, create a box on the document by clicking and holding the mouse button where you want one
corner to be, then moving the mouse to where you want the opposite corner and letting go of the button.
To set the variable image folder and file name
1.
2.
3.
4.

Double-click on the variable image box.
Browse to the folder where you want to look for images.
Double-click on one of the images.
Open the Variables tab and double-click on the variable that corresponds to the name of the image object you just
created (such as Image1, Image2, Image3).
5. Use the Expression Editor to determine what image will appear. The result of the expression must be the actual file
name of the image in the same folder, including the extension (.jpg, .png, etc). See "Building Expressions" (page 122).
Technically, both image objects are the same - we offer both for the convenience of adding the one that will offer the
correct dialog box. Both image types are cached using your print technology, where each individual image is cached
once and referred to multiple times.
Examples of Variable Image documents
Example: Image filename is "As is".
If your database contains a field that already has the name of the image you want do display including the extension, you can
refer to it directly in the image's expression. For example, if your database has a field called "Car Pic", you could simply use
the expression [Car Pic] in your expression.
ZIP

CAR

CAR PIC

91335 Mustang Mustang.jpg
75038 Explorer Explorer.jpg
60173 Windstar Windstar.jpg
33351 Explorer Explorer.jpg
Result:
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Example: Condition triggered by the contents of a data field.
If your database contains a small trigger that can be used to dynamically determine what image will be displayed, you can use
a condition in the expression to determine what image will be shown depending on that trigger. For example, if you have a
field called "Car Type" that contains either A, B or C which refer to a specific car type, you can use that.
ZIP

CAR

CAR TYPE

91335 Mustang

A

75038 Explorer

B

60173 Windstar

C

33351 Explorer

B

Expression
IF([CAR TYPE] = "A", "Mustang.jpg",
IF([CAR TYPE] = "B", "Explorer.jpg",
IF([CAR TYPE] = "C", "Windstar.jpg","")))

Place PDF
You can insert a PDF file as a static PDF object or as a variable image object. As a variable image object allows for using variable pages within a (single) PDF document.
To insert a PDF image as a static PDF object, you can:
1. Drag and drop a PDF file to your layout, or
2. From the File menu, select New PDF based document, or
3. In the Tools toolbar, click the Insert PDF button, or from the Insert menu, select PDF...
To insert a PDF file as a variable image object, you can:
1. In the Tools toolbar, click the Insert Image File button, or from the Insert menu, select Image File.
2. In the Tools toolbar, click the Insert Image Box button, or from the Insert menu, select Image Box.
Note: An image object can be linked to a single PDF file. As PDF files can contain multiple pages you can specify the page(s)
to be used in your document through an expression, in this way you can use variable pages within that PDF file.
Mac OS

1. In the Tools toolbar, click the Place Variable Image button and drag a rectangle to the desired size on your layout,
or from the Insert menu, select Variable Image.
2. Double click the name of your variable image in the Variables window, to display the Expression Editor.
3. In the Expression Editor, define an expression or select a database field that contains the image filename.
Note: PrintShop Mail for Macintosh converts the color space that is embedded in the image to the color space of the printer
driver. You can check the color space of the printer driver, selecting from the File menu, Print/ColorSync.
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Barcode Object
The most commonly known barcodes are composed of a sequence of vertical bars and spaces varying in width. Some barcodes use start and stop characters, which are defined as patterns of bars and spaces that tell the barcode reader where the
code begins and ends. Others have a checksum, which is an integer value that the reader can use to verify the integrity of the
barcode data. Some include human readable characters below the bars.
With PrintShop Mail you can add a variety of barcodes to your documents. For detailed descriptions of each one of the options
offered by specific barcodes, or for background information on barcodes, refer the documentation provided by individual barcode suppliers.
To add a barcode:
1. Create a new document or open an existing document.
2. Click the Barcode tool in the toolbar to insert a new barcode. The barcode object shows a default barcode.
To change the barcode properties, see "Barcode Properties" (page 31).
For a list of supported barcodes in PrintShop Mail, see "Barcodes Supported by PrintShop Mail" (page 79).
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Barcodes Supported by PrintShop Mail
Linear Bar Codes (1D)
Name

Description

CodaBar 2 Widths

CodaBar (2 Width), CodaBar2

Code11

Code 11, Code-11

Code 2OF5 Data Logic

Code 2 of 5 Data Logic Version

Code 2OF5 IATA

Code 2 of 5 IATA Version (International Air Transport Association)

Code 2OF5 Industry

Code 2 of 5 Industry Version

Code 2OF5 Interleaved Code 2 of 5 Interleaved (alias ITF or Code 2/5 IL),
Code 2OF5 Matrix

Code 2 of 5 Matrix (alias 2of5 Standard)

Code 2OF5 Standard

Code 2 of 5 (identical with Code 2 of 5 Matrix)

Code 39

Code 3 of 9 alias Code-39

Code 39 Full ASCII

Code 3 of 9 Extended Version (ASCII)

Code 93

Code 93

Code 93 Full ASCII

Code 93 Extended Version (ASCII)

Code128

Code-128 all sub sets and Compressed Mode

Code128A

Code 128 Subset A

Code128B

Code 128 Subset B

Code128C

Code 128 Subset C

EAN13

EAN-13 (also JAN or IAN),

EAN13 P2

EAN-13 (also JAN or IAN) with 2 digit add-on

EAN13 P5

EAN-13 (also JAN or IAN) with 5 digit add-on

EAN14

EAN-14 (GTIN coded with EAN-128 symbology)

EAN8

EAN-8 (also JAN or IAN)

EAN8P2

EAN-8 (also JAN or IAN) with 2 digit add-on

EAN8P5

EAN-8 (also JAN or IAN) with 5 digit add-on

EAN128

EAN-128 alias UCC-128 alias GS1-128

Flattermarken

Flattermarken

GS1-128

GS1-128, identical to EAN-128 / UCC-128

GS1-DataBar

GS1-DataBar Symbologies: all variants of GS1 DataBar are supported (GS1 DataBar is based upon
RSS)

ISBN

ISBN

ITF-14

ITF14, Code 2of 5 Interleaved (14 digits)

LOGMARS

DOD Logmars, Department of Defense Logmars

MSI

MSI Barcode variants with different check digits

NVE-18

NVE 18 (Nummer der Versandeinheit)

Pharmacode OneTrack

Pharmacode One Track (1 Track)

Pharmacode TwoTrack

Pharmacode Two Track (2 Track)
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Name

Description

PLANET 12 Digit

Planet Code 12 digits (Postal Alpha Numeric Encoding Technique)

PLANET 14 Digit

Planet Code 14 digits

Plessey

Plessey Code Unidirectional

Plessey Bidirectional

Plessey Code Bidirectional

PZN

Pharma Zentralnummer (Deutschland)

RSS Expanded

EAN/UCC RSS Expanded (Reduced Space Symbology)

RSS Limited

EAN/UCC RSS Limited (Reduced Space Symbology)

RSS-14

EAN/UCC RSS14 (Reduced Space Symbology)

RSS-14 Truncated

EAN/UCC RSS14 Truncated (Reduced Space Symbology)

RSS-14 Limited

EAN UCC RSS14 Limited (Reduced Space Symbology)

GS1 DataBar
Expanded

GS1 DataBar Expanded (Reduced Space Symbology)

GS1 DataBar

GS1 DataBar / RSS14 (Reduced Space Symbology)

GS1 DataBar Truncated

GS1 DataBar Truncated (Reduced Space Symbology)

GS1 DataBar Limited

GS1 DataBar Limited (Reduced Space Symbology)

SSCC-18

SSCC 18 Shipping Container Code

Telepen

Telepen

Telepen Alpha

Telepen Alphanumerisch

UCC/EAN-128

UCC/EAN 128

UCC-128

UCC 128

UPC12 / UPCA

UPC 12 (alias UPC-A),

UPC-A

UPC A (alias UPC-12),

UPC-A P2

UPC Version A with 2 digit add-on

UPC-A P5

UPC Version A with 5 digit add-on

UPC-E

UPC Version E

UPC-E P2

UPC Version E with 2 digit add-on

UPC-E P5

UPC Version E with 5 digit add-on

UPCSCC

UPC Shipping Container Code (refer to ITF14, SCC-14)
Postal Codes (1D)

Australian Post Custom

Australian Post Standard Customer, Customer2, Customer 3

Australian Post Redirect

Australian Post Redirection

Australian Post Reply Paid

Australian Post Reply Paid

Australian Post Routing

Australian Post Reply Routing

DPD Code

German Parcel Service Label Code

DP Identcode

Deutsche Post Identcode

DP Leitcode

Deutsche Post Leitcode

Japanese Postal

Japanese Postal Barcode

Italian Postal

Italian Postal Code (based on 2of5 IL)
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KIX

Dutch Postal Barcode

Korean Postal Authority

Korean Postal Barcode

RoyalMail 4State (RM4SCC) Royal Mail 4 State Barcode (RM4SCC)
USPS OneCode (4-CB)

USPS OneCode (4-CB) alias USPS 4-State Customer Barcode

USPS PostNet5

USPS PostNet ZIP (5 digits) with check digit computation

USPS PostNet6

USPS PostNet ZIP+CD (6 digits)

USPS PostNet9

USPS PostNet ZIP+4 (9 digits) with check digit computation

USPS PostNet10

USPS PostNet ZIP+4+CD (10 digits)

USPS PostNet11

USPS PostNet ZIP+4+2 (11 digits) with check digit computation

USPS PostNet12

USPS PostNet ZIP+4+2+CD (12 digits)
Two-Dimensional (2D) Codes

Codablock-F

CodablockF (Stacked Code128), used by HIBC

Data Matrix

Data Matrix (ECC200 standard with error correction), Auto Compaction

MaxiCode

Maxi Code (used by UPS®)

MicroPDF417

Micro PDF-417, MicroPDF

PDF417

PDF-417 (all encodation modes with auto compaction)

PDF417 Truncated

PDF-417 Truncated Version

QR-Code

QRCode (Quick Response Code) (mostly used in Asia)

Aztec Code

Aztec Code

RSS-14 Stacked

EAN/UCC RSS14 Stacked

RSS-14 Stacked Omnidir

EAN/UCC RSS14 Stacked Omnidirectional

RSS Expanded Stacked

EAN/UCC RSS Expanded Stacked

GS1 DataBar Stacked

GS1 DataBar Stacked

GS1 DataBar Stacked Omnidir

GS1 DataBar Stacked Omnidirectional

GS1 DataBar Expanded Stacked GS1 DataBar Expanded Stacked
EAN-UCC Composite Variants (2D)
RSS-14

Composite Component CC-A / CC-B

RSS-14 Stacked

Composite Component CC-A / CC-B

RSS-14 Stacked Omnidirectional Composite Component CC-A / CC-B
RSS Limited

Composite Component CC-A / CC-B

RSS Expanded

Composite Component CC-A / CC-B

RSS Expanded Stacked

Composite Component CC-A / CC-B

EAN 13

Composite Component CC-A / CC-B

EAN 8

Composite Component CC-A / CC-B

UPC A

Composite Component CC-A / CC-B

UPC E

Composite Component CC-A / CC-B

UCC/EAN128

Composite Component CC-A / CC-B / CC-C
GS1 DataBar Composite Variants (2D)

GS1 DataBar
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GS1 DataBar Stacked

Composite Component CC-A / CC-B

GS1 DataBar Stacked Omnidirectional Composite Component CC-A / CC-B
GS1 DataBar Limited

Composite Component CC-A / CC-B

GS1 DataBar Expanded

Composite Component CC-A / CC-B

GS1 DataBar Expanded Stacked

Composite Component CC-A / CC-B

Related Symbologies
With the listed symbologies you can generate also the following variants:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

USS Code 39
AIAG
HIBC
USS Code 128
UCC-128
ISBT-128
SCC-14
JAN
Bookland
ISSN
USS ITF 2-5
I-2/5
ITF-14
SSC-14
DUN14
USPS
DOD Logmars (Department of Defense Logmars)
UPC SCS (UPC Serial Shipping Symbol)

DirectSmile plug-in
Despite the fact that the integration of DirectSmile with PrintShop Mail benefits from state-of-the-art optimization and speed
improvements techniques, the generation of personalized images can still consume considerable amount of computer
resources. Therefore, DirectSmile must run on a separate computer than the one where PrintShop Mail is installed in order to
spread computer resources. System responsiveness may be affected dependent upon system specifications and number and
complexity of images used.
The DirectSmile plug-in should be installed and available by default. If not, please re-install PrintShop Mail and check
the DirectSmile plugin option.
If the connection between PrintShop Mail and DirectSmile is lost, images can no longer be requested nor received. It is therefore very important to verify the connection settings and make sure the PrintShop Mail document has access to the DirectSmile
server. The same holds true when using DirectSmile in a multiple users environment as well as when printing PrintShop Mail
documents with PrintShop Mail Web.
To insert a DirectSmile object on the page:
l
l
l
l

Click the DirectSmile icon in the Tools toolbar.
Double-Click the object that is added to the page.
Type in the Server name and select an image set.
Click Open.

The properties of a DirectSmile object are available in DirectSmile Properties.
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Working With Variables
Variables are basically words that contain data, which can be used throughout your document in any text object. You can have
as many variables as you want in your text, and they can be re-used as many times as you want. Changing the expression
(content) of one variable will change its result in each place it is used.
Variables can be created manually by typing its name in a text object, automatically by dragging a data field on your document, or automatically by objects that you add.
To create a variable manually:
1. Create a new text object in your layout or use an existing text object.
2. Type in a variable name, surrounded by the variable delimiter (by default, this is the @ symbol). For example: @FIRSTNAME@ , or @Last Name@ .
3. Click outside of the text object. The variable appears in the "Variables Panel" (page 20).
To create a variable from a data field:
1.
2.
3.
4.

Open the "Data Fields Panel" (page 21).
Click on a data field and hold your mouse button.
Move your mouse to where you want the contents of the data field to appear.
Let go of the mouse button. A variable with the same name as the data field appears in the "Variables Panel" (page 20).

To assign database fields to the variables
The next step is to connect the variables to fields in the database. To do this,
1. (Windows): Double click on a variable in the Variables Panel to display the Expression Editor, or right click on
the text object and select the variable in the Edit Expression submenu.
(Mac OS): Double click on a variable in the Variables floater.
2. Double click on the database field to which to associate the variable.
3. Click OK to close the window.

Use Layout Conditioning
Use layout conditioning to conditionally skip certain pages of your document or to leave them blank during the printing process. The PRINT and BLANK commands will not influence the amount of pages printed.
There are three options for applying a condition to a layout:
l
l
l

PRINT: The layout will be printed (default).
BLANK: A BLANK page will be printed instead of the layout.
SKIP : The layout will be skipped and the next layout will take its place.

To specify layout conditioning
Select the layout for which you want to set the condition:
l

(Windows): It is possible to specify layout condition in three ways:
1. From the Layout menu, select Edit Condition.
2. Right click on the layout and select Edit Layout Condition.
3. In the Layouts panel, select the layout and click on Action to Edit Condition.
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l

(Mac OS):
1. From the Windows menu, select Show Layout Conditions.
2. From the Windows menu, select Show Variables and click on Layout Conditions.

Use Case Example
You want to print a one page newsletter or promotional letter, but you want to use a different page (different colors or images,
for example) for your clients depending if they are male or female. Luckily, your database contains a field that says "M" for
male clients and "F" for female clients.
The following expression can be used on the layout that is meant for your male clients:
IF( [GENDER] = "M", Print, Skip)
In plain words, "If the GENDER field is equal to "M", print the page, otherwise skip it".
The expression for your female audience will be very similar:
IF( [GENDER] = "F", Print, Skip)
FreeForm and FreeForm 2 print technologies do not fully support layout conditioning and do not allow you to conditionally Skip layouts. When SKIP is used, a BLANK page will be printed instead.
Note: When you use layout condition SKIP for your PrintShop Mail documents with multiple layouts, or when you have applied
variable Number of Copies, this may cause that the size of the record sets (the number of actual printed layouts per record)
will be different per record set. This in turn may cause that some record sets will be split across different stacks.
When should Layout Conditions be applied?
l
l

l

Output of multiple versioned documents within one PrintShop Mail file.
Sending a different promotional coupon to clients that have purchased more or less than a specific amount (perhaps
when sending a "thank you for your previous purchase" letter)
Inserting blank pages

Note: For more information on expressions, see Expression Overview.

Use Layout Repetition
PrintShop Mail can print multiple layouts on a single page that is larger than the layout itself, which is useful for printing
address stickers, postcards and business cards. This concept is sometimes referred to as Multi-Up or N-Up, where N is the
number of layouts in a page (e.g. 2-up, 4-up, 8-up, etc). The technique can also be used to save "clicks" on printers that
charge you each time a physical page is ejected, by placing multiple copies or records on a single, larger sheet.
This is done by using the Layout Repetition settings in the PrintShop Mail Preferences dialog (see "Repetition Settings" (page
50)).
Use Cases and examples:
l

l

l

You can print 10 business cards on a single Letter-sized thick paper by creating a layout that is 3.5" wide by 2" high,
with 2 horizontal repetitions and 5 vertical repetitions.
You can use half as many physical pages ("clicks") on your printer by using an 8.5"x11" layout, repeated twice horizontally on a Tabloid-sized page.
You can print postcards 4-up (2 horizontal, 2 vertical) on a Tabloid page.
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Cut & Stack (aka Through-the-Stack) in Simplex mode
You can use the repetition settings to re-order the output so it creates stacks. This is useful when you are cutting the stack at
printout, in order to retain the precise order of the records. For example, if you are printing 500 "tickets" 4-up using a
"COUNTER" (page 144) function to display a serial number, you would probably want to keep the order as 1-500.
To do this, you can set the first priority settings to be (1) on Front to back, the second to be (2) on Top to bottom and
finally (3) on Left to right. This way the first record is printed on the top-left of the first page, the second record on the topleft of the first page, etc. Record 126 will be on the top-right of the first page, and 500 will be at the bottom-right of the last
page.
When you cut the output stack in 4, you can then simply order them in the order of: top-left, top-right, bottom-left then bottom-right stacks, and this will retain your 1-500 order.
Cut & Stack and Duplex mode
If you are creating a PrintShop Mail document with two layouts per record and Cut & Stack, you will need to use the Front to
back option in priority 1 as described above, or else your "back" layout would end up besides your front one instead of on the
back of the page. In order for this system to work correctly, you need to make sure that every record always generates two
layouts.
When duplexing, you also need to remember to correctly select the proper Mirroring setting to the same option as your Duplexing option on the printer, so the layouts on the back are correctly ordered. For example, if you print in Short-Edge Duplex in
your printer, select Flip on Short-Edge in the Mirroring option.
When you use layout condition SKIP for your PrintShop Mail documents with multiple layouts, or when you have
applied variable Number of Copies, this may cause the size of the record sets (the number of actual printed layouts
per record) to be different per record set. This in turn may cause some record sets to be split across different stacks.
To avoid this, always make sure that the number of layouts per record is correct (you can use conditional "blank"
layouts to do this).

Select Paper Trays
If your printer supports different paper trays and your document consists of multiple layouts, you can send different layouts to
different trays.
To associate a layout with a paper tray
Windows
1. From the File menu select Page Setup, or right click on the layout and choose Page Setup. Alternatively in the
Properties panel, select Page Size.
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2. From the Tray box, select the desired paper tray.
3. In the Apply to box select:
Current layout: layout or layouts selected in the Properties Panel.
This point forward: current layout and all layouts below it.
Whole document: all layouts in the document.
4. Click OK.
If your printer supports more trays but they are not available in the Page Setup window, use the following steps to select a tray
in the Advanced properties of the printer driver:
1.
2.
3.
4.

From the File menu select Page Setup, or right click on the layout and choose Page Setup.
Click on the Advanced tab.
In the Printer Document Properties select Advanced.
In the Printer Advanced Options select Printer Features.
The options outline above, must be repeated for each layout, if each layout need a different tray.

Another way to associate a layout with a paper tray is by selecting the layout in the Layouts panel, then select the Paper Tray
property and choose the desired tray from the drop down menu.
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Mac OS
From the Layout menu, select Paper Tray. Depending on the selected PPD, a list with the available trays will be displayed.

Number of copies
PrintShop Mail allows you to print a number of copies per page. The Expression Editor can be used to generated multiple
copies of each page in your document.
To setup the number of copies
l
l

Select the Layouts panel.
Select the desired layout and click on Number of Copies, to open the Expression Editor.
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Number Text String

Once the Expression Editor is open:
1. Double click on the VAL function from the function list. The expression will be pasted into the Expression Edit field.
2. Select the string value of the database field containing the number of copies.

Non-numerical Text String
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In this case, the data field does not contain a number string, but it does have a field to be used as "Trigger".

In the expression "IF([TRIGGER]="A",VAL("12"),IF([TRIGGER]="B",VAL("8"),VAL("1"))) ", the field name "TRIGGER" has
either an "A" or a "B" in it. The number of copies for "A" would be 12, and the number of copies for "B" would be 8. At the end
of the expression, you need to add VAL("1"), because the function must result in a numeric value.
Note: When you use layout condition SKIP for your PrintShop Mail documents with multiple layouts, or when you have applied
variable Number of Copies, this may cause that the size of the record sets (the number of actual printed layouts per record)
will be different per record set. This in turn may cause that some record sets will be split across different stacks.
You can also print multiple copies of your document by entering the desired number of copies in the Print Dialog. To do this:
l
l

On the File menu, click Print.
In the Number of copies box, enter the number of copies you want to print.

To print a complete copy of the document before the first page of the next copy is printed, select the Collate check box. If you
prefer to print all copies of the first page and then print all copies of subsequent pages, clear the check box.
Limitations
l
l

The output result will be one copy if a single zero ("0") is used in any part of the Expression.
For multi-page documents, you need to set the number of copies per each individual page.
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l
l

Number of copies can not be used in combination with Layout Repetition.
Number of copies can not be used when FreeForm Print Technology is selected, use FreeForm 2 instead.

Verify a Document
Before printing, you can verify your document for possible problems.
To perform document verification
PrintShop Mail performs the following checks at Layout level:
l
l
l
l

Are any images or PDF files missing?
Are all items placed within the printable area?
Does a text object contain more text than the text box can hold?
Are there fonts missing in your system that are referred to in the document?

When you select Verify Document from the Layout menu, a progress bar will be displayed, showing the amount of records being checked. The warnings for the whole document will be listed in the Verification Results panel.

Verify document checks the document at two levels:
l
l

Layout level: Warnings at layout level will show the warning with the layout number in the Warnings panel.
Record level: Warnings at record level will show the warning with the layout number and record number in the
Warnings panel.
Verify document will be stopped when 1000 warnings are found or when you press the Cancel button on the progress bar.

Here is a list of a few possible messages:
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Error Message

Possible Solution

Object is placed beyond the printable area Move the object on the layout so it is directly on the page
Object is not entirely placed on the layout

Move the object on the layout so it is completely on the page

Text file not found

Verify the expression that creates the filename used by the TEXT_FILE function.

Variable X is not linked to an expression

Check the Variables Panel for any variable that does not have an expression.

Text does not fit in its bounding box

Verify the text box where the error occurs. Either make the text box bigger, or
use Text Links to flow the text into another text box.

Image X not found

Verify the file name or expression that calls the images file in your Image box.

Error loading image

Verify that the image you are calling is a valid type supported by PrintShop Mail
and that it is not corrupted.

Page number X is invalid; this PDF only
contains Y pages

Verify the expression used to choose the page displayed by the PDF, and that
the PDF name is the correct one.

Variable X: argument Y is invalid

Verify the expression for the variable.

Variable X: barcode input string Y is
invalid

Verify the expression for the barcode object and make sure it corresponds to
what the barcode is expecting.

Variable X: date format Y is invalid

Verify the date format for the variable.

X contains at least one TrueType font that
Recreate the PDF in order to embed all the TrueType fonts.
is not embedded in the PDF
Variable X: database field Y not found

Verify the database field name in the variable's expression.

You can save any error message in the Verification Results panel or the Warnings panel. To do so, right-click on the
message and select Copy. You can then paste it somewher else, for example by emailing it to technical support.

Save a Document
When saving a document, it is recommended to use one folder for the document file and its supporting files that is, the image
files and the database. The reason for this is because the supporting files for a PrintShop Mail document are not included in the
document file. This file only contains references, stored as paths relative to the document folder.
For example:
If you save your document in...
"C:\My Documents"
and it contains an image...
"C:\My Documents\Images\Car.tif",
the reference to this image is stored as...
"Images\Car.tif"
If you move the Documents folder and its subfolders to another drive, PrintShop Mail will still be able to locate the image.
Windows Note: PrintShop Mail 6.1 documents can be opened in all PrintShop Mail 6.X versions (downward/upward compatibility). You can import PrintShop Mail 98, 4.x, 5.x and 6.x documents into new versions of PrintShop Mail, but PrintShop
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Mail 98, 4.x and 5.x will not be able to interpret documents saved by the new version of PrintShop Mail . If you try to overwrite
an existing PrintShop Mail 98/4.x/5.x/6.x document in the new PrintShop Mail format, PrintShop Mail will issue a warning.
Mac OS Note: You can open PrintShop Mail documents created in PrintShop Mail 4.3.X or older, but PrintShop Mail 4.3.x will
not be able to interpret documents saved by the new version of PrintShop Mail. If you open an existing PrintShop Mail 4.3.x document in the new PrintShop Mail format, PrintShop Mail will issue a warning, asking you whether you really want to save this
document as soon as you close the document, even if you have not changed anything.
When opening PrintShop Mail documents from versions 4.3.6 or 4.2.9 (Japanese language) in PrintShop Mail 5, the following
settings might be lost:
-Format settings in DATE and TODAY expressions will not be converted automatically; this settings can be rest manually.
-Variable images will be opened with an empty expression.
-Leading between lines setting can not be converted, this setting can be reset manually. Variables embedded in an EPS (@variable@) is not supported.
-Transparency will be converted to white, this setting can be reset manually.
-The COUNTER function will be converted using an end value of 2.000.000.
If you wish to use documents made in earlier versions of PrintShop Mail than versions 4.3.6/4.2.9 (Japanese language) before
you open them in PrintShop Mail 5.x.
To save your documents

You can save a PrintShop Mail document in three ways:
1. As a PrintShop Mail document, with the extension ".PSMD".
From the File menu, select Save as.
2. As a PrintShop Mail template, with the extension ".PSMT".
From the File menu, select Save as Template. For further guidance in saving PrintShop Mail templates, see Create a
New Document.
3. Save for Output archived in a "ZIP" file which contains all files used in the PrintShop Mail document.
From the File menu, select Save for Output.
When selecting Save for Output, PrintShop Mail collects and copies all the files needed into a compressed folder. The
collected data includes the PrintShop Mail document, static and variable images, database, fonts and a summary file
which shows a list of all the copied image file names.
To revert to the last saved version of the document, select Revert from the File menu.

Publishing Documents
PrintShop Web is an easy to use, powerful and open Web to print application that allows for printing over the Web.
PrintShop Mail allows to prepare and add documents to PrintShop Web. PrintShop Mail documents are used as the basis for
print jobs, meaning that it is possible to reuse the documents by uploading new databases. The designer can publish (upload)
an existing or new document and customers will be able to use PrintShop Web to order print jobs based on this document. Print
jobs can be previewed and validated before they are submitted to the printer.
How to create PrintShop Mail documents for publishing

You, "the designer" create documents and templates in PrintShop Mail.
When the document is ready for publishing, you can start the upload process by clicking on Publish to PrintShop Web
selecting the File menu or clicking the Publish to PrintShop Web button in the Standard toolbar.
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You can design a document with or without linking it to a database. The variable data in the document preview in PrintShop
Web will be based upon Data Fields that you assign in PrintShop Mail.
Note: Keep in mind that when you design a template, the template does not save the link to the database.
Data Fields are representatives for the variable data that can be provided either directly through a database that you link to
a PrintShop Mail document, or through any other data source, for example a database which is uploaded by a PrintShop Web
client or a web form.
The entries you will find in the Data Fields panel in PrintShop Mail, represent data fields that occur in the document. These
fields are either referred to in expressions (for variables or layout conditions, without the need to directly being linked to a
database), or they refer to actual database fields (when the document is already linked to a specific database).
When a data field is used in the PrintShop Mail document, it will have a check mark in the Data Fields panel.
Example

The Type column displays the type of data in the data field. "Default" means that at the moment no data source is available for
this field. Once there is a data source available, the Type column will display the data type for that field, as specified in the
data source, like number, text, etc.
Example

By selecting a Data Field, you can view and edit its properties:
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Name: A unique identifier. You can not modify this value here.
Default Value: You can set a Default Value here, this will be a string value that will be displayed in PrintShop Web, once the
document is published, as a placeholder when no data source is available (yet) for this Data Field. You will find this string value
back in PrintShop Web, after the document has been selected (before the stage where a data source is provided).
Note: When no database is (yet) available, this Default Value will be displayed as the current value in the Data Fields panel
and in the text object in the layout, in case the data field is in use in the document:

How to create a Data Field without opening a database?
1.
2.
3.
4.

Create a variable: @variable@.
Enter the Expression Editor by double clicking on the @variable@ in the Variables panel.
Type: [My data field].
Click OK.

Now you will find the data field back in the Data Fields panel.

Remarks: You can define a Remark here, this will be a string value that will be displayed in PrintShop Web once the document is published. You can use this, for example, to give clients a hint about this variable data field.
Source: The data source can be either "Database", a database uploaded by the PrintShop Web client, or "User input", data
provided by for example a web form.
Note:These Data Fields properties are only relevant for PrintShop Web, they will not affect the behavior of PrintShop Mail.
How to publish documents from PrintShop Mail

Publishing PrintShop Mail documents to PrintShop Web can be done from PrintShop Mail directly.
When publishing documents the first time, you will need to specify the URL and the login account for your company Web
Server.
1. Launch PrintShop Mail.
2. From the Edit menu, select Preferences and click the PrintShop Web icon. To tell PrintShop Mail how to log on to
your company Web Server, specify:
URL: The Web address of your company.
Login : The user name and password assigned by the administrator.
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Once you have specify all the necessary information to login to your company Web server, you can start publishing documents
to PrintShop Web. The connection can be tested clicking the Test Connection button. It verifies only if all three options
(URL, Username, Password) are valid. If no PrintShop Web Server address has been defined in the PrintShop Mail Preferences, the document and its attributes (images and fonts) will be saved in a zip archive (Publish to zip) for later publishing.
1. From the File menu, select Publish to PrintShop Web or click the Publish to PrintShop Web button in the
Standard toolbar.
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Before publishing PrintShop Mail documents, a document designer can add a note containing Operator Instructions
about for example, duplex settings, paper weight etc.
2. A dialog Publish to PrintShop Web opens.
3. Select the Publication Type where you want to place the document.
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In PrintShop Web documents are organized within Publications Types. Publication Types are a way to mark a document
as being in a particular category (such as envelop, business cards, invitation etc). Each Company can have a range of
Publication Types. Within the Company each Publication Type is unique. Each Publication Type can contain one or multiple documents.
When a customer of a company logs on to the PrintShop Web web site all Publication Types available for that Company
will be shown.
4. Click Next.
5. On the next dialog click the Show Browser button to display the folder containing the image files.
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Note: Adding files is only necessary when variable images and txt/rtf files are used. If the document does not contain
variable images or txt/rft files, the wizard will take you to step 7.
6. Select the additional files for the document and click the Add button.
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Note: In this dialog, you can choose to add variable image and .txt/.rtf files that belong to the document. The PrintShop Mail document, its used fonts and static images are added automatically.
7. Click Next.
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8. Click Finish to publish the document.
9. Once the message Successfully uploaded the new document appears, click OK.
Note: It is possible to upload documents made in older versions of PrintShop Mail WE to PrintShop Web through PrintShop Mail
5.2 and higher.
PrintShop Mail shows a list of warnings prior uploading the PrintShop Mail document to PrintShop Web.
The following features are checked:
Fonts

Only freely distributable fonts will be added automatically. A warning message will be displayed about fonts that need license
before publishing. You need to verify if the necessary licenses are available to add the fonts that need licenses. It is possible to
choose to upload the licensed fonts directly to avoid a manual upload of the fonts at the PrintShop Web server.
PrintShop Mail version

PrintShop Mail verifies if the version used at the PrintShop Web server is the same or if the document needs to be converted.
List of used plugins

When publishing a PrintShop Mail document which contains plugin objects, the availability and the version of the plugin will be
checked with the PrintShop Web server before publishing.
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List of used Macro’s

When publishing a PrintShop Mail document which contains external macros, the availability of the macro will be checked with
the PrintShop Web server before publishing. The check is based on the filename only.

When pressing OK, the uploading process will continue.
When pressing Cancel, the uploading process will stop and you will be back in the default PrintShop Mail environment.
If you have enough access privileges you can create a "New Company" and "Publication Type" from the Publish to
PrintShop Web dialog in PrintShop Mail.
How to create a New Company

To create a New Company, do the following:
1. In the Publish to PrintShop Web dialog click the New Company button. The New Company dialog appears.
Enter the name for the company and click OK.

2.

How to create a New Publication Type

To create a New Publication Type, do the following:
1. In the Publish to PrintShop Web dialog, select the company.
2. Click the New Publication Type button. The New publication type dialog appears.
Enter the name for the Publication Type and click OK.

3.

More information about managing uploaded documents, Companies and Publication Types can be found in PrintShop Web
Help.
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Related Topics

"Create a New Document" (page 67)
"Default Settings" (page 57)
"Save a Document" (page 91)

Printing Basics
Before you do the actual printing, PrintShop Mail offers different ways to optimize your output, allowing you to select how
many pages or records you want to print. Additionally, you may wish to print the currently selected record, or proof your document in PDF format before printing. To do this, click on the File menu and select Print to open the Print Dialog.
Print Dialog Options
l

l

l

l
l

Operating System Default Print Options
l Printer: The printer you wish to print to.
l Printer Properties: Controls printer options, for example layouts options and paper quality.
l Print to File: Instruct the printer driver to print to a file on the disk, instead of the printer.
l Number of copies: Indicates the number of copies you wish to print of each page. If the value is set to one,
only the original page will be printed.
l Collate: Determines how the layouts are ordered within a record, the layouts within the record set will keep
the order intact. By default this option is On.
Print Options:
l All Records: By default "All Records" is selected. This option allows you to print the complete job. Behind this
selection the amount of available records is displayed.
l Record Range: This option allows you to print a certain range of records. If the range of records you wish to
print exceeds the number of records available, a message will be displayed until the amount of records is equal
or less than the total amount of records available.
l Page Range: This option allow you to print a certain range of pages. When using layout repetition and you
select this option the complete number of pages needs to be calculated to output the correct pages.
l Current Record: This option allows you to print the selected record, using Standard PostScript print technology. No Credits will be charged from your hardware key.
l Softproof PDF: This option generates a PDF file of the current record, using Standard PostScript print technology. No Credits will be charged from your hardware key. When a non PostScript printer is selected, it will use
the PostScript printer driver installed by the PrintShop Mail installer to generate output.
l Report Page: This option allows you to print a Report Page, using Standard PostScript print technology. No
Credits will be charged from your hardware key.
l Variable Markers: This option allows you to print the current layout(s) with the variable markers on it, using
Standard PostScript print technology. No Credits will be charged from your hardware key.
Split job: This option allows you to split the job per record or per page in several outputs. Print speed will be improved
when using limited job sizes.
Save Print Options: This option allows you to store specific print options with the PrintShop Mail document.
Print Technology: Use this option to select a specific print technology that is compatible with your printer. To select
a print technology, simply click on the name of the currently selected print technology, and click the one you want in the
drop-down. For more details on Print Technologies, see "Print Technologies" (page 103). Here are the options available
in the Print Technology group:
l Use OPI, don't spool images: Most print technologies support OPI (Open Prepress Interface), allowing you
to use an image substitution server to speed up the printing process. OPI only supports EPS and TIFF image
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l

l

l

formats.
Store forms on printer's hard disk: Storing PostScript forms (cached reusable content) on hard disk will
prevent out of memory conditions if your document contains large high resolution images. Only use this option if
your RIP has access to a hard disk.
Custom cache size: Increasing the PostScript form cache size can help to improve performance. You may
want to experiment in order to determine the optimum value. Specifying a custom cache size only works if the
system settings of your RIP are not password protected.
Job Options (Adobe PDF and Adobe PDF/VT1 only): Click on the drop-down to view the available job option
profiles found on the system, and click one to apply it to the PDF output. The job option profiles are related to
PDF quality settings and can only be created, managed or deleted through Adobe Distiller. For more information
on job options, please see the Adobe Distiller documentation.

If you use the options "Store forms on printer's hard disk" or "Custom cache size", and the RIP is password protected
you might get a printer error. Consult the RIP manual or consult the system administrator to change the settings on
the RIP.
Save as PDF Dialog
When you click on File, Save As PDF, the Print Dialog opens and selects the Adobe PDF print technology by default. This gives
you the ability to create a PDF from PrintShop Mail without having to rely on a separate PDF print such as Adobe Acrobat. The
options are the same as the Print dialog except that the only option available in the Print Technology group is the "Job Options"
drop-down list.

Print Preview
While you are working on your document, it is possible to view an on screen representation of the printed output. In this Print
Preview it is possible to browse through pages and view multiple layouts and records at the same time.
You can enter the Print Preview mode in two ways:
1. From the File menu, select Print Preview.
2. Click the Print Preview toolbar button in the Standard toolbar.
In Print Preview mode, four menu items are shown:
l

l

l

l

l

Page combo box: Allows you to select the view of a single page or multiple pages at the same time. By default you
will see two pages horizontally and one vertically.
Print button: When you click this button, PrintShop Mail returns to the design view and the Print Dialog will be
opened.
Book Preview: Click the Book Preview to force the preview window to always display the front and back of each
physical page side-by-side. The left page is the front, the right is the back. If your document is setup as Simplex in the
Page Setup dialog, only one page is shown in the preview window (the front).
Close button: When you click this button, PrintShop Mail returns to the design view. Alternatively, you can close the
Print Preview by pressing Esc, or by pressing Alt+F4.
Color softproof: Allows you to display an on-screen preview of how your documents colors will look when reproduced on a particular output device. This feature is enabled when Color Management is activated.

Print Technologies
Because every print technology uses PostScript Level 2, PrintShop Mail requires the use of a PostScript printer driver and a
PostScript Level 2 compatible RIP.
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Some technologies are based on the PostScript standard, which means that they are supported by every type of RIP available.
Other technologies are based on extensions of PostScript, which are only supported by specific RIP types.
Printing Technologies:
l
l
l

Standard PostScript
Optimized PostScript
Adobe PDF

RIP type and vendor dependent technologies:
l
l
l
l
l
l
l
l

AHT
Creo VPS
Fiery FreeForm
Fiery FreeForm 2
PPML
PPML/VDX 7(Windows only)
PrintStreamer(Mac OS only)
VIPP

If you want to print to a non PostScript printer, you just have to select the printer driver for that printer. PrintShop Mail will print
through that printer driver non optimized output. Printing and spooling time will be significantly slower compared to other print
technologies like Optimized PostScript.
To select a print technology
1. (Windows): From the Edit menu (Ctrl+K), select Preferences.
(Mac OS): From the PrintShop Mail menu (Command,), select Preferences.
2. In the left pane, click the Print job icon.
The Print job settings dialog box appears.
3. Check if your RIP supports one of the RIP type and vendor dependent technologies. If so, you can select that specific
technology. If not, it is advisable to select Optimized PostScript.
You can also select the print technology directly from the Print dialog. Simply click on the currently selected print technology and select the one you want from the drop-down.
To specify technology specific options
1. From the File menu, select Print.
2. On the Print dialog box, specify technology specific options .
Standard PostScript
Standard PostScript does not use any special optimization mechanism, except that you can use OPI to speed up spooling.
Use this technology if your system does not support any of the other technologies.
Print dialog box settings
1. Use OPI, don't spool images.
Optimized PostScript
Optimized PostScript caches image data in reusable PostScript forms. This speeds up the printing process, since each unique
image is only sent once.

©2010 Objectif Lune Inc

- 104 -

Note: Some printer drivers offer the possibility to change the PostScript Output Options: "Optimize for Speed" or " Optimize for Portability". For a maximum print speed, change the PostScript Output Option to "Optimize for Speed". You can
find this property, in the Printer driver/Advanced Options.
Print dialog box settings
1. Store forms on printer's hard disk
2. Custom cache size
3. Use OPI, don't spool images
Adobe PDF
Adobe PDF Print Technology allows you to save optimized PDF output files to disk directly from PrintShop Mail. The PDF output
files can be used for printing to PostScript level 3 printers and soft proofing when uploading PrintShop Mail documents to PrintShop Web.
When using “Adobe PDF” Print Technology, it is advised to activate Split job option for the best performance.
AHT
Select this technology if you have an AHT RIP. AHT uses an optimization mechanism similar to Optimized PostScript.
Print dialog box settings
1. Store forms on printer's hard disk
2. Custom cache size
3. Use OPI, don't spool images
Creo VPS
VPS (Variable Print Specifications) is a PostScript language extension, created and maintained by Creo.
It allows PrintShop Mail to classify each element on a page as either reusable (occurring more than once) or inline (occurring
only once). This distinction allows the VPS RIP to decide when image data can be reused. This avoids unnecessary repeated
processing and speeds up the print process.
One of the main differences between Optimized PostScript and VPS is that VPS reuses rasterized data instead of PostScript.
Print Technology specific setting

Use Automatic Picture Replacement: Automatic Picture Replacement (APR) allows you to speed up the printing process
by using the image substitution capabilities of your VPS RIP. The image format support of APR is limited to EPS, but some RIP
versions support other formats like TIFF and JPEG.
Fiery FreeForm
FreeForm makes use of the fact that the data in your document is divided in two layers, which contain the text and image
objects in the document.
The master layer in a FreeForm job consists only of "static" objects, but the variable layer can contain a mix of both variable
and static objects, depending on the order of the objects on your layout. This is a consequence of the fact that FreeForm does
not allow data in the master layer to be printed on top of data in the variable layer.
These layers are sent to the FreeForm RIP in two separate jobs, not necessarily at the same time. The master data job is rasterized first, and stored under a user defined numeric ID. The RIP overlays the rasterized master data with the rasterized data
of any variable data job that references the same ID. In this way, you can reuse the same master data for different variable
data jobs.
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How the objects are separated

Static objects have content that remains constant throughout the entire record set. An image object is static when it has an
expression with a constant result. A text object is static when it does not contain any variable markers. A PDF object is always
static. All other objects are considered to be variable. A variable object is reusable when its content is the same for at least two
different records in the record set.
At printing, PrintShop Mail tries to assign as many static objects to the master layer as possible, starting with the object at the
back of your layout, and working towards the front. All static objects up to (but not including) the first variable object are put in
the master layer. All other objects make up the variable layer. Any reusable data in the variable layer will be cached in PostScript forms.
Note: When using Freeform, try to make sure that static objects are not placed on top of variable objects in the object order
on your layout.
Note: FreeForm does not fully support layout conditioning. In particular, it does not allow you to conditionally skip layouts.
When SKIP is used, a BLANK page will be printed instead.
Preference settings

Form number: A numeric ID used to identify the master data job.
Print Technology specific settings

Along with the regular print dialog box settings (see Print a Document), Fiery Freeform has these options:
l
l
l

Send Master data: Send only the Master (template) to the Fiery server.
Send Variable data: Send only the variable data, assuming the Master is already present in the Fiery server.
Send Master and Variable data: Send both the Master and Variable data together.

Fiery FreeForm 2
FreeForm 2 makes use of the fact that the data in your document is divided in two layers, which contain the text and image
objects in the document.
The master layer in a FreeForm 2 job consists only of "static" objects, but the variable layer can contain a mix of both variable
and static objects, depending on the order of the objects on your layout. This is a consequence of the fact that FreeForm 2
does not allow data in the master layer to be printed on top of data in the variable layer.
These layers are sent to the FreeForm 2 RIP in two separate jobs, not necessarily at the same time. The master data job is rasterized first, and stored under a user defined numeric ID. The RIP overlays the rasterized master data with the rasterized data
of any variable data job that references the same ID. In this way, you can reuse the same master data for different variable
data jobs.
How the objects are separated

Static objects have content that remains constant throughout the entire record set. An image object is static when it has an
expression with a constant result. A text object is static when it does not contain any variable markers. A PDF object is always
static. All other objects are considered to be variable. A variable object is reusable when its content is the same for at least two
different records in the record set.
At printing, PrintShop Mail tries to assign as many static objects to the master layer as possible, starting with the object at the
back of your layout, and working towards the front. All static objects up to (but not including) the first variable object are put in
the master layer. All other objects make up the variable layer. Any reusable data in the variable layer will be cached in PostScript forms.
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Note: When using Freeform 2, try to make sure that static objects are not placed on top of variable objects in the object order
on your layout.
FreeForm 2 is an extension of FreeForm. The differences are:
1. FreeForm 2 fully supports layout conditioning.
2. The FreeForm 2 master ID consists of a name instead of a number.
Preference settings

Form ID: A name used to identify the master data job.
Print Technology specific settings

Along with the regular print dialog box settings (see Print a Document), Fiery Freeform has these options:
l
l
l

Send Master data: Send only the Master (template) to the Fiery server.
Send Variable data: Send only the variable data, assuming the Master is already present in the Fiery server.
Send Master and Variable data: Send both the Master and Variable data together.

PPML
PPML is short for Personalized Printing Markup Language . A PPML file describes the entire personalized printing job and contains all necessary elements to print the contents (layout and variable data).
The technology PPML in PrintShop Mail is very similar to PPML/VDX. The difference is that the content (PDF) and page layout
description (PPML) are sent separately.
Windows

Print Technology specific settings

1. Create ZIP archive: When checked, the PDF and PPML files will be zipped before being sent to the printer. This
option is used for specific printers, which expect a PPML-ZIP file. The ZIP file contains the PPML and the PDF file.
2. Embed images in PDF: When checked, all images will be embedded in the PDF.
3. Environment: The path specified in the Environment setting will place the images with a "Global Scope" in the Environment. The Consumer (RIP) stores and/or caches the images for later use.
4. Send.
4.1- Send "All Images": A PDF file will be created containing images that have a "Global Scope" or a "Local Scope".
This option also creates a PPML job, using this PDF, with instructions to use the Local and the Global images. Images
with a "Global Scope" are stored in the specified Environment. After this job the "Global images" can be reused for recurring print projects, for example with the option "Send Local Images".
4.2- Send "Global Images": A PDF file will be created containing images that have a "Global Scope". This option also
creates a PPML job, using this PDF, with instructions for storing these images into the specified Environment.
4.3- Send "Local Images": A PDF file will be created containing images that have a "Local Scope". This option also
creates a PPML job, using this PDF, with instructions to use these Local images and the Global Images that are stored in
the specified Environment. For that reason, images that have a "Global Scope" should be present in the specified Environment. Images with a "Global Scope" will only be referenced in the PPML job.
Note: The settings "Environment" and "Send" should not be changed when you are not familiar with PPML terms!
For more information about PPML, visit the Website of PODi (Print On Demand Initiative), http://www.podi.org.
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PrintShop Mail offers an option to define if an image should have a "Global Scope". If the Global Scope of an image is set to
"Yes" in the Properties Panel, the image will have a "Global Scope". For recurring print projects, a central benefit of PPML
is its ability to reference Reusable Objects using Global Scope. This feature allows for transmitting smaller datasets and eliminates repetitive processing of the reusable content.
Note: Please make sure that your RIP supports at least PPML 1.5, including the "application/pdf" source format.
Printing speed can be improved by using a "Global Scope" for one or more images, or possibly (depending on your RIP) by
unchecking the "Embed images in PDF’" checkbox in the Print dialog.
Mac OS

When using PPML as Print Technology, printing directly to the printer/RIP will result in the output being placed o the Desktop
(either a ZIP file or a folder), which conatins the PPML file and (if used)images recurring in the document. In order to print the
PrintShop Mail document you need to download the output to your printer/RIP.
PPML/VDX 7
PPML/VDX is an abbreviation for Personalized Print Markup Language/Variable Data Exchange. The output consists of an optimized PDF in which reusable content elements occur only once. The PDF also contains a block of PPML data that describes the
page layout.
Note: PPML/VDX 7 requires both Adobe Acrobat(r) and Distiller(r) to be installed on your system.
To help ensure correct output there are "PSMail joboptions" files for the Acrobat Distiller versions 5, 6, or 7 in the Printshop
Mail installation folder.
These settings will tell Acrobat Distiller how to handle fonts, color, images, etc., when it creates the optimized PDF.
If so desired, you can change these output options for PPML and VDX by changing the Distiller joboptions. Double click on the
"joboptions" file you want to modify, change and save it.
Note: PSMailx.joboptions files should be saved in the PrintShop Mail installation folder, next to the executable. The "x" specifies the Acrobat Distiller version that the file corresponds to.
More information about the Acrobat Distiller joboptions can be found in the online Help of the Acrobat Distiller.
Print Technology specific settings

1. Environment: The path specified in the Environment setting will place the images with a "Global Scope" in the Environment. The Consumer (RIP) stores and/or caches the images for later use.
2. Send
2.1- Send "All Images": A PDF file will be created containing images that have a "Global Scope" or a "Local Scope".
This option also creates a PPML job, using this PDF, with instructions to use the Local and the Global images. Images
with a "Global Scope" are stored in the specified "Environment". After this job the "Global images" can be re-used for
recurring print projects, for example with the option "Send Local Images".
2.2- Send "Global Images: A PDF file will be created containing images that have a "Global Scope". This option also
creates a PPML job, using this PDF, with instructions for storing these images into the specified Environment.
2.3- Send "Local Images": A PDF file will be created containing images that have a "Local Scope". This option also
creates a PPML job, using this PDF, with instructions to use these Local images and the Global Images that are stored in
the specified Environment. For that reason, images that have a "Global Scope" should be present in the specified Environment. Images with a "Global Scope" will only be referenced in the PPML job.
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PrintStreamer
This printing technology sends two separate files to the RIP, one master file and one with variable data.
Print dialog box settings
1. Use OPI, don't spool images
Print Technology specific settings

1. Send Master and variable data
2. Send Master data
3. Send Variable data
VIPP
VIPP is an acronym for Variable data Intelligent PostScript Printware. The output of this technology consists of a PostScript
stream in which reusable images occur only once.
The main difference between VIPP and Optimized PostScript is that images are cached using a proprietary VIPP specific mechanism instead of PostScript forms. The cached images are stored in print ready format.
Print Technology specific settings

1. Don't spool images (EPS, TIFF, JPEG): This option allows you not to send the recurring images twice to the RIP.
The output will only contain references (by filename) to images stored in the project folder.
2. Project Folder:This option allows you to store recurring images on the fly, and before printing the job, to a "project
folder" on the (VIPP enabled) RIP. The folder name can be specified in the Print Dialog.
Encapsulated VIPP supports the following image formats: JPEG, TIFF, EPS and PDF.
Note: This technology requires a RIP that has been enabled for Encapsulated VIPP, and a hardware key that has been
upgraded to enable VIPP. For more information on how to upgrade the hardware key, see Upgrading PrintShop Mail.

Page Setup
The Page Setup of your document allows you to specify which printer to print to, the paper size, source, and other characteristics of your print media.
The settings in the Print dialog are applied to the current print job only, but the settings in the Page Setup dialog will be
stored in your document file.
You can specify a different Page Setup for each layout, but you can only send layouts to one printer. This allows you to mix
paper sizes (Windows only), orientations, media types, and finishing options throughout your document, provided that this
is supported by your printer.
Windows
There are different ways of changing the Page Setup:
1. From the File menu, select Page Setup, and choose either:
Selected Layouts: layouts selected in the Layouts window.
Current layout: layout selected in the Layouts window.
This point forward: current layout and all layouts below it.
Whole document: all layouts in the document.
2. Select the Layouts tab in the Properties panel, select one or more layouts, select Page Size, and click on the [...]
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button.
3. Right click on the layout and select Page Setup to open the dialog.
Use the Page Setup dialog box to specify printer options, as well as the media your job will be printed on.
Mac OS
To change the Page Setup:
1. From the File menu, select Page Setup.
2. In the dialog box, you can change:
l
l
l
l

Settings
Format
Orientation
Scale

Use this dialog box to specify printer options, as well as the media your job will be printed on.

Subset Finishing
Subset finishing is the process of applying a finishing option (such as stapling or binding) to each subset in a print job.
PrintShop Mail defines a subset as a set of pages belonging to the same record. If you are not using layout repetition or layout
conditioning, the number of pages in each subset will equal the number of layouts in your document.
To use subset finishing

You can specify a finishing option in the printer driver, using the Properties button in the Print dialog or using the
Advanced button in the Print Setup dialog box.
PrintShop Mail can embed certain PostScript instructions in the output to signal that the finishing option should be applied.
You can specify which instructions to embed in the Embed PostScript dialog box.
It is possible to write your own PostScript set and save them. If you go to New you can give the PostScript set a name. The
given instructions at the "Start of Page", "Start of Job" and "Between Sets" will be saved. You can also turn it to the default setting by selecting the button "Set Default".
Locating this dialog box
File > Embed PostScript
There are 4 options:
1.
2.
3.
4.

General: This option can be used to give the PostScript set a "Name" and write a "Description".
Start of Page: These instructions will be injected at the start of each page.
Start of Job: Instructions given there will be injected in the header of the job.
Between Sets: Instructions given in this field will be injected between the sets.

For stapling or binding, the default setting (Generic Subset Finishing) should suffice.

Any Output Engine
Any Output Engine Print Technology allows you to print to a non PostScript Printer.
This option is not available in the Preferences panel as the others Print Technologies. Any Output Engine will be automatically applied when selecting a non Postscript printer in the Page Setup or in the Print Dialog.
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When selecting a non PostScript printer the print output will not be optimized, printing and spooling time will be significantly
slower compared to other technologies.
The Print Dialog will show the following message:
"The selected printer driver is not a Postscript Level 2 compatible device. Printing speed will be reduced and some features
might not be supported”.
The following features might not be supported by non Postscript printers:
-Subset finishing
-Color Management
-Spot color

Print To Web
Print to Web allows you to print PrintShop Mail documents to PrintShop Mail Web. The output will be generated on the PrintShop Mail Web server, not on the computer where the PrintShop Mail document is created.
From the File menu, select Print to Web…
When selecting Print to Web… option, the PrintShop Mail document can be saved before it is uploaded, otherwise
the original document will be sent to PrintShop Mail Web.
The following options are displayed in the Print to Web dialog:
l

l

l

Destination Group
l Server address (read-only): Displays the server configured in the PrintShop Mail preferences. See PrintShop Web Preferences.
l Company: This option list the available Companies. PrintShop Mail will store the last
selected company with the document.
l Remote Printer: This option list the available printers installed on the PrintShop Mail Web
server. If no printers are installed, the combo box will show “No printers available” and the
print button will not be enabled.
Print Group:
l All Records: By default "All Records" is selected. This option allows you to print the complete job. Behind this
selection the amount of available records is displayed.
l Record Range: This option allows you to print a certain range of records. If the range of records you wish to
print exceeds the number of records available, a message will be displayed until the amount of records is equal
or less than the total amount of records available.
l Split job: This option allows you to split the job per record or per page in several outputs. Print speed will be
improved when using limited job sizes.
Print Technology: Use this option to select a specific print technology that is compatible with your printer. To select
a print technology, simply click on the name of the currently selected print technology, and click the one you want in the
drop-down. For more details on Print Technologies, see "Print Technologies" (page 103). Here are the options available
in the Print Technology group:
l Use OPI, don't spool images: Most print technologies support OPI (Open Prepress Interface), allowing you
to use an image substitution server to speed up the printing process. OPI only supports EPS and TIFF image formats.
l Store forms on printer's hard disk: Storing PostScript forms (cached reusable content) on hard disk will
prevent out of memory conditions if your document contains large high resolution images. Only use this option if
your RIP has access to a hard disk.

©2010 Objectif Lune Inc

- 111 -

l

l

Custom cache size: Increasing the PostScript form cache size can help to improve performance. You may
want to experiment in order to determine the optimum value. Specifying a custom cache size only works if the
system settings of your RIP are not password protected.
PDF Settings (Adobe PDF and Adobe PDF/VT1 only): Click on the drop-down to view the available job
option profiles found on the system, and click one to apply it to the PDF output. The job option profiles are
related to PDF quality settings and can only be created, managed or deleted through Adobe Distiller. For more
information on job options, please see the Adobe Distiller documentation.

Save Print Options: This option allows you to store specific print options with the PrintShop Mail document.
Print: When printing the document and its related files will be sent to PrintShop Mail Web print queue.
Directsmile note: In order to print PrintShop Mail documents using DirectSmile objects with a PrintShop Mail Web
server, you must make sure that the PrintShop Mail Web server has the proper access to the DirectSmile server.

Automated Printing
PrintShop Mail allows you to automate certain tasks, such as opening and printing documents.
Automation features are no longer sold and are being deprecated. You may continue to use the features, however no
new dongles are shipped with these features enabled and no upgrades are possible with this feature enabled. Automation features are now available by combining PrintShop Mail with the power of PlanetPress Workflow Tools, part of
PlanetPress Suite.
Windows
When you right click on a PrintShop Mail document file in a Windows Explorer window, you will notice that the menu contains
the submenu Print. You can print the document without starting PrintShop Mail, and you can drag a PrintShop Mail document
to a specific printer.
More advanced ways of automate the printing process is to use one of the next available features:
l
l
l

Automated Printing using Command-line Arguments
Automated Printing using Extended Scripting
Automated Printing using DDE

Note: To be able to use this feature, you need to activate the automated printing option. See Upgrading PrintShop Mail to
learn how to add this feature to your license.
Note:When using automated printing, any errors will be logged in the Autoprint.log file, which usually is located in:
C:\Documents and Settings\User\Application Data\PrintShop Mail.
If you have installed .NET Framework 2.0, the errors will be logged in the Event Viewer.
To open the Even Viewer:
l
l

Start/Run/eventvwr.msc, or
Start/Control Panel/Administrator tools/Event Viewer

Note: Automated printing allows you to print PrintShop Mail documents and PrintShop Mail templates automatically through
the Command line or script file . Make sure to use the appropriate extension (<document name>.psmd or <document
name>.psmt) in the Command line or in the script file.

©2010 Objectif Lune Inc

- 112 -

Mac OS
PrintShop Mail allows you to automate the printing process to a high extend. Instead of opening a document in PrintShop Mail
and selecting the "Print" submenu, the program can be told to monitor a HotFolder and execute print jobs as soon as the necessary files (a PrintShop Mail document and/or a database file) are found there.
l

Automated Printing using the HotFolder

Command line Arguments
You can order PrintShop Mail to perform certain actions by specifying them on the command line.
Supported command line arguments

Argument

Description

<document name>

Filename of a PrintShop Mail document.
Example: "Mailing November.psmd"

-p

Prints the specified document to the default printer selected in the PrintShop Mail document properties.
Example: "Mailing November.psmd" -p

-pt

Prints the specified document to a specific printer, enclosed in quotes.
Example: "Mailing Novembert.psmd" -pt "Laserwriter 16/600"

-db <database>

Links the specified document to a certain database.
Example: "Mailing November.psmd" -db "Database.mdb"

How to use command line arguments

A simple example using command line arguments can be created by following the next steps:
1. Create a PrintShop Mail document, for example "Sample.psmd"
2. Create a database you wish to use with this document, or copy an existing database to the folder where you saved the
PrintShop Mail document.
3. Create a shortcut to the PrintShop Mail executable usually located at "C:\Program Files\PrintShop Mail6 \PSMail6x.exe".
Copy this shortcut to the same folder as you saved the document you created in step 1.
4. Right click on the shortcut and choose Properties. In the field Target, specify the document name by adding it to the
target. It should look something like "C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd.
If you double click on the shortcut you've just created, PrintShop Mail will be started and the specified document will be
opened. You are now ready to use any of the other supported command line arguments by adding them to the target.
A few examples

"C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd -db "Database.mdb"
"C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd -p
Dropping a database on a shortcut

You can create a shortcut that will make PrintShop Mail open any supported database you drop on it, by specifying the next
text in the target field of the Shortcut's properties:
"C:\Program Files\PrintShop Mail6\PSMail6x.exe" Sample.psmd -db
If you drop a database on the shortcut, PrintShop Mail will be started, opening the document "Sample.psmd" with the database
you just dropped.
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Note: Automated printing allows you to print PrintShop Mail documents and PrintShop Mail templates automatically through
the Command line or script file . Make sure to use the appropriate extension (<document name>.psmd or <document
name>.psmt) in the Command line or in the script file.
Extended Scripting
Extended Scripting is a fast and flexible way of automating your print jobs. This feature allows you to print any PrintShop Mail
document, combined with any database to any printer. You can even schedule an Extended Scripting job on a certain date
and/or time where your printer is usually idle.
You specify a certain action, or a range of actions, in a plain text file and tell PrintShop Mail to use that file by adding it to a
shortcut:
1. Create a shortcut to the PrintShop Mail executable usually located at "C:\Program Files\PrintShop Mail6\PSMail6x.exe".
2. Add "-script scriptfile.txt" to the Target in the properties of the shortcut.
Note: When the script file has a name with spaces ("My<space>Script.txt") be sure to enclose this file name with quote
marks ("") in the Target line of the PrintShop Mail shortcut: "C:\Program Files\PrintShop Mail 6\PSMail6x.exe” -script “My
Script.txt”. Include the quote marks if you copy this line.
In the script you can specify a set of predefined commands to perform certain actions.
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Supported Commands

Command

Description

FileOpen [name]

Opens the specified document. If another document is opened, it will be closed by PrintShop Mail.
Example: FileOpen C:\Documents\MassMailing.psmd

FileClose

Closes the currently opened document.

FilePrint

Prints the currently opened document to the default printer selected in the PrintShop Mail document properties.

FilePrintTo [printername]

Prints the currently opened document to the specified printer.
The name of the printer should equal the name specified in the Printer's properties.
Example: FilePrint MyPrinter

FilePrintToFile [filename]

Prints the currently opened document to the specified file. If its print technology would create multiple
files, FilePrintToFile will generate a zip file.

SetPrintTech [technology]

Will change the current print technology.
Example: SetPrintTech Standard

Prints the specified record range to the default printer selected in the PrintShop Mail document propFilePrintRange [start] erties.
[stop]
Note: It is not possible to print a record range to a non-default printer.
Example: FilePrintRange 5 10 Prints record 5 to 10 from the currently opened document.
FileExit

Quits PrintShop Mail. No other scripting commands followed by this command are executed.

Opens the specified database. If any other database is opened, it will be closed by PrintShop Mail. If the
database contains multiple tables, DatabaseOpen will automatically select the first table. You can then
DatabaseOpen [file] use DatabaseSelectTable to select a different table.
Example: DatabaseOpen C:\Documents\Example.mdb
Opens the Microsoft Access database "Example" from the folder C:\Documents.
Opens the specified data source. If any other database is opened, it will be closed by PrintShop Mail.
DatabaseOpenODBC
Example: DatabaseOpenODBC MyDSN
[source]
Opens the data source called "MyDSN"
DatabaseSelectTable
Selects a different database table in the currently opened document.
[table name]
Filters the database according to the specified filter.
DatabaseFilter [filter] Example: DatabaseFilter [CITY] = 'New York'
Filters the database, only records where the value of field "CITY" equals "New York" will be used.
DatabaseClose

Closes the currently opened database.
Example: DatabaseClose

The argument <technology> must have one of the following predefined values.
Print Technology

Script Value

Standard PostScript SetPrintTech Standard
Optimized PostScript SetPrintTech Optimized
Adobe PDF

SetPrintTech PDF

Adobe PDF/VT1

SetPrintTech PDF/VT1

AHT

SetPrintTech AHT

Creo VPS

SetPrintTech VPS

FreeForm

SetPrintTech FreeForm

FreeForm2

SetPrintTech FreeForm2
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Print Technology

Script Value

PPML

SetPrintTech PPML

PPML/VDX

SetPrintTech PPMLVDX

VIPP

SetPrintTech VIPP

How do I create an Extended Scripting job?

You create an extended scripting job by following the next steps:
1.
2.
3.
4.

Create a PrintShop Mail document and save it, for example "ScriptTest.psmd".
Create a textfile containing all commands you want to perform.
Create a shortcut to PrintShop Mail.
Add the argument "-script scriptfile.txt" to the command line (where "scriptfile.txt" is the textfile containing the commands)

Note: It is advised to save your script file as "UNICODE" encoding.
Note: Automated printing allows you to print PrintShop Mail documents and PrintShop Mail templates automatically through
the Command line or script file . Make sure to use the appropriate extension (<document name>.psmd or <document
name>.psmt) in the Command line or in the script file.
In the script file, you specify all commands you want to perform:
FileOpen ScriptTest.psmd
FilePrint
FileExit
This simple scriptfile opens the document "ScriptTest.psmd", prints it to the default printer and quits PrintShop Mail.
You can create a batch process by telling PrintShop Mail to use another document:
FileOpen ScriptTest.psmd
FilePrint
FileOpen AnotherDocument.psmd
FilePrint
FileExit
PrintShop Mail first opens the document, "ScriptTest.psmd" and prints it to the default printer. When this is done, PrintShop
Mail opens the second document, "AnotherDocument.psmd" and prints it to the same default printer. Of course, you can
choose to specify a different printer by using the command "FilePrintTo". Finally, PrintShop Mail exits.
It's possible to use the same document with different databases:
FileOpen ScriptTest.psmd
FilePrint
DatabaseOpen AnotherDatabase.MDB
FilePrintTo Printer2
FileExit
This opens the document "ScriptTest.psmd" and prints it to the default printer. When this is done, PrintShop Mail opens the
database "AnotherDatabase.MDB" and prints it to another printer, called "Printer2". Finally, PrintShop Mail exits.
A combination of the commands is also possible:
FileOpen ScriptTest.psmd
FilePrintRange 5 10
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DatabaseOpen AnotherDatabase.MDB
FilePrintRange 10 15
DatabaseOpen ThirdDatabase.XLS
FilePrintTo Printer2
FileOpen Document2.psmd
FilePrint
FileExit
This opens the PrintShop Mail document "ScriptTest.psmd" and prints records 5 to 10 to the default printer. When this is finished, it opens the database "AnotherDatabase.MDB" and records 10 to 15 are printed to the default printer. Then, the database "ThirdDatabase.XLS" is opened and all records are printed to printer "Printer2". Eventually, the PrintShop Mail document
"Document2.psmd" is opened, printed to the default printer and PrintShop Mail exits.
It's possible to change the Print Technology used when the document was created, or print the same document using different
Print Technologies:
FileOpen ScriptTest.psmd
SetPrintTech Optimized
FilePrint
FileOpen ScriptTest.psmd
SetPrintTech Standard
FilePrint
Database Filters

A database filter consists of a field name, an operator and a condition. Suppose you have the following database:
NAME

CITY

GENDER

Eddy

New York

M

Pamela Los Angeles
Tim

F

Washington

M

Robert New Jersey

M

The available field names in this database are "Name", "City" and "Gender". The database has 4 records.
An operator should be one of the ANSI SQL operators listed in the table below.
Operators Definition
=

Equal

<>

Not equal

<

Less than

>

Greater than

<=

Less than or equal

>=

Greater than or equal

A filter is used to construct the WHERE clause of an SQL statement. It does not include the reserved word WHERE to filter the
record set.
Except for "Distinct", "Like" and "Between", all SQL commands are supported. For more information about the SQL commands, please visit www.sql.org.
If you want to select and print the records where the field name "City" equals "New York", the following line should be added
to the script file:
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DatabaseFilter [CITY] = 'New York'
Result: One record will be printed.
Note: Please notice that we have used single quotes around the conditional values 'New York'. SQL uses single quotes around
text values. Numeric values should not be enclosed in quotes.
Suppose you want to send a mailing to all persons in the database where [GENDER] does not equal 'F'. The filter should look
like:
DatabaseFilter [GENDER] <> 'F'
Result: Three records will be printed.
Or, you want to print all records where the [GENDER] equals 'F' OR where [CITY] does not equal 'Washington':
DatabaseFilter [GENDER] = 'F' OR [CITY] <> 'Washington'
Result: Three records will be printed
These are just three examples of a database filter. You can create very advanced and powerful database filters. Please refer
to your SQL manual or an online resource for advanced examples.
If you need to have data from more than one table in the database, you can make a query in SQL or MS Access and export the
result of this query into Excel, Access or a text file. This file can be used as a database in PrintShop Mail.
Scheduling a job

It is possible to schedule a certain job on a certain date and time. This can be achieved by using the Windows Scheduler. For
more information about the Windows Scheduler and how to create a scheduled task, please refer to your Microsoft Windows®
manual.
DDE
DDE Dynamic Data Exchange is a more flexible way to automate printing than using command line arguments, but it requires
knowledge of a programming language that supports DDE, such as Visual Basic or C++. Please refer to the Win32 API documentation to learn how to establish a DDE connection.
To connect to the PrintShop Mail DDE Server, make sure PrintShop Mail is running and open a DDE-connection to server "PrintShopMail6".
Visual C++ 6.0

// include "ddeml.h"
UINT iReturn = DdeInitialize(&idInst, (PFNCALLBACK)DdeCallback,
APPCLASS_STANDARD | APPCMD_CLIENTONLY, 0 );
HSZ hszApp = ::DdeCreateStringHandle(idInst, "PrintShopMail6", 0);
HSZ hszTopic = ::DdeCreateStringHandle(idInst, "C:\\untitled.psmd", 0);
HCONV hConv = ::DdeConnect(idInst, hszApp, hszTopic, NULL);
::DDEExecute(idInst, hConv, "[FileExit]");
Visual Basic 6.0

TextBox.LinkTopic = "PrintShopMail6|Connect" ' Set link topic.
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TextBox.LinkMode = vbLinkManual ' Set link mode.
On Error Resume Next 'TextBox thinks DDE is not executed,
'when actually it is.
TextBox.LinkExecute "[FileExit]"
On Error GoTo 0
PrintShop Mail accepts the following DDE commands:

Command

Description

[FileNew]

Closes the current document (if any) and creates a new document.

[FileOpen "filename"]

Opens the specified document.

[FileClose]

Closes the current document.

[FilePrint]

Prints the current document to the default printer.

[FilePrintRange "start", "end"]

Prints a range or records to the default printer.

[FileExit]

Closes PrintShop Mail.

[DatabaseOpen "filename"]

Opens the specified database.

[DatabaseClose]

Closes the current database.

[DatabaseOpenODBC "source"] Opens the specified ODBC data source.
Note: This only applies to PrintShop Mail 6.x or later. PrintShop Mail 4.x and 5.x are slightly different. If desired, the text can
be adapted for 4.x and 5.x by changing the word “PrintShopMail6” to “PrintShopMail4.x” or PrintShopMail5.x (all 3 occurrences).
HotFolder
This feature allows more than one user to "drop" their database files and/or documents into the "HotFolder", causing a print
job to start without further interaction (and without even needing access to the PrintShop Mail program from their computers).
Initializing the HotFolder

1.
2.
3.
4.
5.

From the PrintShop Mail menu, select Preferences and click on the HotFolder icon.
Click on Browse to select the folder containing the desire documents to monitor.
Click Apply.
From the File menu, select Monitor HotFolder.
To stop monitoring and automatic printing of the document, click on the Cancel button.

Using the HotFolder

1. Create a PrintShop Mail document and store it in the HotFolder.
Since there will not be any user interaction with the program when the document is automatically printed, users should
verify the document before saving it.
2. Drop the document or/and the database file into the HotFolder.
Within 30 seconds, PrintShop Mail combines the database with the available PrintShop Mail document and starts the
print job.
3. After PrintShop Mail has printed the document, the database file is moved to a folder "PSMPrinted", in the HotFolder.
The PrintShop Mail document remains in the same location and can be used again.
4. PrintShop Mail writes a log of its actions into a log file. Since the timestamp of the log file is automatically adjusted every
time when PrintShop Mail becomes active, this timestamp can be used to check whether PrintShop Mail is still running
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or not. If no PrintShop Mail document and/or database file was found, the log file is still updated. The log file is located
in the folder /Users/user name/Library/Logs/PSM.log.
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The Expressions Editor
Expressions allow you to display information in your document by using special functions, operators and conditions. By combining these features, you can manipulate data and text coming from the database and display it on the page depending on certain criteria.
The Expression Editor interface appears whenever you edit a variable by double-clicking on it in the Variables tab (see "Working With Variables" (page 83))
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1. Expression Edit field: Allows adding, deleting and modifying the expressions. See "Building Expressions" (page
122).
2. Expression result: Checks the expression and shows the result if the expression is valid.
3. Favorites: Allows saving the favorites expressions. See "Favorite Expressions" (page 126).
4. Components: Shows the components you can use to build your expressions, such as Functions, Operators and Data
Fields.
5. Functions: Shows the functions list. See "Functions Overview" (page 128).
6. Open Assistant button: Opens a new Expression Assistant window for that function. See "Building Expressions"
(page 122).
7. Data Fields: Shows the content of the opened database.
8. Operators: Allows combining, comparing or modifying the value of an expression.
9. Help text: Shows the description of the selected function.
10. Example: Shows an example of the selected function and the result of the function when applied.
Expression texts are displayed as follows:
l
l
l
l
l

Blue text: Functions
Green text: String
Purple text: Database fields
Red text: Logical
Dark red text: Variables

Building Expressions
Expressions are built from the following components:
l

l

l
l

l

l

Database Fields: You can add fields from your database into the Expression Editor, by double-clicking on the field in
the "Data Fields:" list. Database fields are always surrounded by square brackets (e.g. : [FirstName])
Variables: You can refer to any variable except the one that you are currently editing. Variables are always surrounded by the variable markers (e.g.: @MyVariable@)
Constants: PrintShop Mail has a few constant values you can use such as "true" and "false".
Functions: You can use functions to manipulate the data into many different ways. Functions are built from the function name followed by its parameters surrounded by parenthesis, such as FUNCTION(Param1,"Param2").
Strings: You can add static text to the expressions. Static text is always surrounded by double quotes (e.g.: "Hello
World!").
Operators: You can manipulate data using operators such as mathematical operators (+, -, etc) and concatenations
(&, AND, OR, etc).

You build your expression by adding these components so they work together. You can do this manually by starting to type
any of the component's name in the Expression Edit field.
The Expression Editor tries to automatically complete variable names, database fields, functions and constants for
you. For example, if you type "P" in the Expression Edit field, a list of functions will automatically appear, starting
with the ones with the letter P. You can use the up/down arrow keys to navigate this list and press Enter to select it
from the list.
You can also add components to the expression automatically by using the function list, data field list and operators box below
the Expression Edit field. For example, double-clicking on the PROPER() function will automatically add PROPER(Text) to
your Expression Edit field.
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The Expression Assistant
When using functions in your expression, you can use the Expression Assistant to help you fill in the function's parameters
and values. To do this, click on the [...] icon next to the function name. You can also double-click on the function name in the
Expression Edit field to open the Expression Assistant.
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To help you to add the correct names of database fields, variables or functions, you can select those items from the pop up
menu on the right hand side of the edit box.

The result of the function you created here, will be pasted into the Expression Edit field. For example: PROPER ([First
name]).

Result and debugging
You can always see the result of the expression itself just under the Expression Edit field. If there are any errors in the expression or if your expression returns no result, this box will be empty. If the result is a constant such as PRINT or SKIP, or if it is a
number, the result is always shown as a string of text in the Expression Results box.
If there is any error in your expression, a few things can happen:
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Database fields that do not exist will be shown in darker purple, and will be italicized.
Functions that do not exist will remain in normal, black text.
Parameters of the wrong type will be underlined and put in bold (example: putting a number in the PROPER() function,
which expects a string)
The Expression Result box will not display anything.
An error will be displays in a small tooltip with a red X icon. This tooltip should explain the error in a basic way.

l
l
l

l
l

When you click OK to save the expression and close the Expression Editor, further validation is done, and any error will be
shown in the Expression Edit field as a tooltip. The expression will not be saved until you correct the error and click OK again.

Variable Dependencies
You can use regular and global variables within your expression the same way you would use them in your document by entering the variable name surrounded by the variable marker (by default the @ symbol, e.g. @MyVariable@). If you attempt to
use the name of a variable within its expression (such as entering @MyVariable@ while editing the MyVariable expression),
this causes a "Deadlock" error, also known as a circular reference. This permits you to re-use expressions by calling their variable within another expression, as well as break up complex expressions into smaller parts.
Variables names are case-sensitive. This means that @myvariable@ is not the same as @MyVariable@, or @MyVaRiAbLe@. If you type in a variable name that does not exist, it will be created in the Variables panel and given an
empty string ("") expression.

Expression Operators
The operators used in the expressions are displayed in PrintShop Mail in the "Components" section of "The Expressions Editor"
(page 121). To add an operator in your Expression Edit field at the location where your cursor is located, simply click on the
desired operator (you can also type any of these operators except the Line Feed character, which is not on your keyboard).

There are more than one kind of operator. Here is an exhaustive list.

Mathematical Operators:
Operator Definition Example Result
+

Add

23 + 11

34

-

Subtract

30 - 2

28

*

Multiply

2*5

10

/

Divide

42 / 2

21
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Comparison Operators:
Operators Definition
<

Example

Result

Less than

(32 < 21)

FALSE

<=

Less than or equal

(21 <= 21)

TRUE

<>

Not equal

("Foo" <> "Bar")

TRUE

Greater than

(55 > 3)

TRUE

>
>=
=

Greater than or equal (43 >= 44)
Equal

FALSE

("String" = "Strings") FALSE

Other Operators:
Operators Definition
( and )

Description

Left and
Gives priority to what is inside of the parentheses just like in mathematical operations. Can also
Right parenbe used to give priority to conditions.
theses

""

Double
quotes

Literal strings (text) entered into an expression needs to be surrounded by double-quotes to be
identified as such (e.g. "Hello, World!"). However, no other component should use double-quotes
(number, functions, database fields or variables).

,

Comma

Commas in strings (e.g. "hello, henry") are simply printed as commas. Commas in functions (e.g.
COUNTER(1, 50, 2) ) are used to separate the parameters used by that function.

.

Decimal
point

Decimal points in strings (e.g. "This is a sentence.") are simply printed as a decimal point. Decimal points in numbers (e.g. 529.54) are used to indicate decimal values such as currency.

&

Ampersand

The ampersand is used to concatenate (put together) two strings. For example, "Hello " &
"World!" will result in "Hello World!".

¶

New Line

The new line character will create a Carriage Return/Line Feed in a string. This is useful to create
an expression that will print out in multiple separate lines in your document. Note that the new
line character is added with surrounding ampersands, as it is always concatenated.

Favorite Expressions
You can use the Favorites tab in the Expression Editor to save expressions that you use often in your documents. These favorite expressions will be saved in the software preferences, not your document, so they can be used in any documents you
create or edit in the future.
To see your existing favorite expressions:
1. Open the Expression Editor.
2. Go to the Favorites tab.
3. The favorites are listed in the box on the left.
To add a new favorite expression:
1. Open the Expression Editor.
2. Build or write the expression that you want to save as your favorite.
3. Go to the Favorites tab.
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4.
5.
6.
7.
8.

Copy the expression (select your expression then to CTRL+C on Windows or
Click New.
Type in a name for the favorite expression in the Name field on the right.
Paste the expression in the box under the name.
Click on Save.

+ C on Mac OS)

To delete an existing expression:
1.
2.
3.
4.

Open the Expression Editor.
Go to the Favorites tab.
Click on the name of the favorite expression you want to delete.
Click on Remove.

Inserting a Salutation
You can generate salutations with a conditional IF statement. If you have a field in your database that specifies the gender of
the person, you can use it to add 'Mr.' or 'Mrs.' to the name.
Example

First Name Last Name Gender
John

Abrahams

M

Theresa

Johnson

F

William

Fremont

M

This example uses the IF function in combination with the "&" operator, which allows you to combine text strings.
"Dear" & IF([Gender]="M", " Mr. ", " Mrs. ") & [First name] & " " & [Last name]
This will result in a string that always starts with Dear , continues with either Mr. or Mrs. depending on the gender, and always
finish with the first name, then a space, then the last name:
First Name Last Name Gender Result
John

Abrahams

M

Dear Mr. John Abrahams

Theresa

Johnson

F

Dear Mrs. Theresa Johnson

William

Fremont

M

Dear Mr. William Fremont

Custom Serial Numbers
PrintShop Mail allows you to create customized serial numbers. You can use these numbers to serialize such items as raffle
tickets, coupons or self-mailers. In combination with the barcode functions, you can create serially numbered barcodes.
You do not need to have a database to create serial numbers. You can change the number of Items without a database in the
Preferences dialog box, from the Edit menu, select Preferences, or in the Database toolbar, enter the desired number of
records and press Enter. From the PrintShop Mail menu, select Preferences (Mac OS).
For example

This example creates a Code 39 barcode. The custom serial number starts with "SWA", and ends with a counter, counting
from 1 to 1000. The functions used are:
l
l

CODE39
COUNTER

After a text box with a variable for the barcode is created, the barcode function is attached to the variable.
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CODE39("SWA" & COUNTER(1, 1000, 1, 4, True))
The result in PrintShop Mail:
*SWA0001*, *SWA0002*, *SWA0003*, etc.
After the correct barcode font is selected, the result is:

Padding a string
You can use an expression to automatically pad a string or number to a certain number of positions, by using a combination of
the RIGHT() function and by concatenating the string with the characters you want to pad with.
Example: Padding a string with dots (periods) to 20 positions:
RIGHT("...................." & [DataField], 20)
Result (if [DataField] contains "Example"):
.............Example
Example: Padding a 5-digit zip code with zeroes, to 5 positions (this is useful if PrintShop Mail sees the zip code as a number
and removes the zeroes automatically):
RIGHT("00000" & [ZipCode], 5)
Result (if [ZipCode] is 1234):
01234

Functions Overview
You can use the following functions in PrintShop Mail:
Operator

Function

ABS

Returns the absolute value of <Number>.

AND

Returns True if both <Logical value 1> and <Logical value 2> are True.

ASC

Converts the leading character in <Text> to its numeric UNICODE value.

BLANK

Layout action constant. If your layout condition evaluates to BLANK, then the layout will be left blank when the document is
printed.
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Operator

Function

CHANGED

Returns True if the current expression result differs from the result of the previous record.

CHR

Returns the character represented by UNICODE index <Number>.

CODABAR

Computes a CODABAR barcode.

CODE128

Computes a CODE128 barcode.

CODE39

Computes a CODE39 barcode.

CONTAINS

Returns True if <Text> contains <Text to find>, returns False otherwise.

COUNTER

A counter which by default counts from the first to the last record. Arguments are optional.

DATE

Returns the current date, formatted according to <Date string format> (optional) or the system regional settings.

DIV

Returns the integral quotient from dividing <Number> by <Divider>.

EAN13

Computes an EAN13 barcode.

EAN8

Computes an EAN8 barcode.

FALSE

Logical constant False.

FILE_EXIST

Returns True if the file <Filename> exist on disk.

IF

Gives one of two results depending on a condition you specify.

INT

Returns the integral part of a floating point number.

ITF

Computes an ITF barcode.

JAN13

Computes a JAN13 barcode.

JAN8

Computes a JAN8 barcode.

KIX

Computes a KIX barcode.

LAYOUT_
COUNT

Returns the number of layouts associated with the current record, taking into account any skipped layouts.

LAYOUT_NR

Layout counter that is reset after every record. It does not count skipped layouts. Note: LAYOUT_NR cannot be used in layout
conditions.

LEFT

Returns the specified number of characters in the supplied text, counting from the left.

LEN

Returns the number of characters in <Text>.

LOWER

Returns all letters in the given text as lowercase.

LTRIM

Returns the supplied text, stripped of all leading spaces, tabs and newline characters.

MID

Extracts characters from the supplied text, starting at the character position specified by start position and containing the
number of characters specified by size.

MOD

Returns the remainder after the specified number is divided by a divisor.

MSI

Computes a MSI Plessey barcode.

NOT

Returns True if <Logical value> is False, and False otherwise.

NW7

Any expression which results in a logical value, example True or False.

OBJECT_
EMPTY

Determines whether a object with the specified name is empty. Returns True or False.

ONECODE

Computes a ONECODE barcode.

OR

Returns True if either <Logical value 1> or <Logical value 2> is True.

PAGE_
COUNT

Returns the total number of pages at printing for this document.

PAGE_NR

Returns the page number at printing time, or 1 at design time. Note: PAGE_NR cannot be used in layout conditions.

POS

Returns the character position of a searched string in text. Returns 0 if not found.

POSTNET

Converts a 5 digit (zip code), 9 digit (zip+4 code), or an 11 digit (delivery point barcode) to a valid POSTNET barcode.

PRINT

Layout action constant, can only be used in layout conditions.

PROPER

Convert the first letter of each word to an uppercase character, and the rest to lowercase.

RECORD_
COUNT

Returns the total number of records of the database.

RECORD_NR Returns the current record number of the database.
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Operator

Function

REPLACE

Looks for <Text to find> in <Text> and replaces every occurrence with <Replace with text>.

RIGHT

Returns the specified number of characters in the supplied text, counting from the right.

ROUND

Returns the supplied number rounded off to the specified number of decimal places.

RTRIM

Returns the supplied text, stripped of all trailing spaces, tabs and newline characters.

SGN

Returns one of three possible values (-1, 0 or 1), depending whether the number is negative, zero, or positive.

SKIP

Layout action constant, can only be used in layout conditions.

STR

Converts a number to data type Text, for use with functions that expect text arguments.

TEXT_FILE

Returns the contents of the TXT or RTF file <Filename>.

TODAY

Returns the current date, according to the computers internal calender, formatted according to the system regional settings.

TOTALPAGES Returns the number of pages in a PDF file, or the number of frames in a multi-frame TIFF or GIF file.
TRIM

Returns the supplied text, stripped of all leading and training spaces, tabs and newline characters.

TRUE

Logical constant True.

UPCA

Computes a UPCA barcode.

UPCE

Computes a UPCE barcode.

UPPER

Returns all letters in the given text as uppercase. Use the UPPER function to ensure consistent data entry of such things as
state abbreviations or postal codes.

VAL

Converts a string representing a number to data type Number, for use in functions that expect numeric arguments.

YuBar

Computes a YuBar barcode.

Barcode Functions
Barcode functions and fonts are deprecated in PrintShop Mail 7 for Windows. This section only applies to PrintShop
Mail 5 for Mac.
Available Barcode Types in PrintShop Mail:
l

l
l

l

l

l
l
l

l
l
l

Codabar: Codabar (also known as NW7) is generally used in health care, chemical processing, express delivery and
government.
Code 128: The most common use of Code 128 is for shipping labels.
Code 39: Code 39 is a widely used industrial barcode and is mandated for some automotive industry and Department of
Defense labels, because of its ability to represent alphanumeric data. Code 39 is a bidirectional, self-checking, discrete
and variable length code.
EAN/UPC: The EAN (European Article Numbering) and UPC (Universal Product Code) is used through the world to mark
physical goods in retail shops.
ITF (Interleaved 2 of 5): ITF is one of the most popular barcode used by shipping and warehouse industries for identification. It is also used in the medical and automotive fields.
JAN: The JAN (Japanese Article Numbering) is similar to EAN, used in Japan.
KIX: KIX barcode is used by the Dutch post office for mail addressing.
MSI/Plessey: MSI/Plessey (Modify Plessey Code) barcode, are mostly used for marking retail shelves for inventory control. MSI is a variable length symbology, however various applications use fixed length codes.
NW7: Is used at library, parcel delivery service and various other purposes.
ONECODE: ONECODE barcode used to sort and track packages from their origins to their destination.
POSTNET: The POSTNET (Postal Numeric Encoding Technique) symbology was developed in the United States for the
automatic sorting of mail. POSTNET is only used for mailing address marking.

Barcode Fonts

The table below reflects an example of which font name can be used with each barcode.
Barcode

PrintShop Mail Font Name Example
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CODABAR

PSMCbar

PSMCbarHrP24DhTt

CODE 128

PSMC128

PSMC128Bwr3P36DhTt

CODE 39

PSMC39

PSMC39HrP24DhTt

EAN 13/ EAN 8 PSMEan

PSMEanBwrP36Tt

ITF

PSMIntHrP72DmTt

PSMInt

JAN 13/JAN 8 PSMJan

PSMJanBwrP36Tt

MSI

PSMMsi

PSMMsiHr72DhTt

NW7

PSMNW7

PSMNW7HrP48DmTt

ONECODE

OneCode Barcode

OneCode Barcode

POSTNET

PSMPostNet

PSMPostNetHrTt

UPCA/UPCE

PSMUpc

PSMUpcP72Tt

PrintShop Mail font name description

P = Point size. The Point size refers only to the height of the font. For example if you see C39HrP24DmTt, the P used here
refers to the point size of 24.
Dh, Dm and Dl = Density (high, medium and low).The density of a barcode is the number of characters per inch (cpi) of the
printed barcode. It is of great practical importance since it determines the minimum barcode length required to print the
desired information. The higher the density, the shorter the barcode.
Hr= Human Readable characters. These characters are printed below the barcode.
Bwr = Bar Width Reduction. The font includes technology to reduce the width of the individual bars uniformly across the barcode without changing the center line of the barcodes.
Note: You can install the barcode fonts library from the PrintShop Mail Installers folder on the CD.
The PSMFimCodesTt font, used to generate POSTNET barcode, is a special font used by the US Post Office to separate business reply mail from other mail. The FIM font consist of four unique barcodes, each barcode represents a unique reply mail
classification.
Font Information
l
l
l

l

Each font name starts with the letters “PSM”.
Some fonts come in human readable versions.
Each font has different densities (thicknesses) depending on printer capability. It is recommended that samples of each
density be printed to verify quality and readability.
Font Style: must always be Regular.

Barcode Setup

Below are the steps for setting up a barcode. A Postnet barcode is used for this example.
1.
2.
3.
4.

Click on the text tool on the Tools toolbar to draw a text box, or from the Insert menu, select Variable Text.
Type a variable name, example @Barcode@.
Double click on the Barcode field in the Variables panel, to open the Expression Editor.
Click the radio button titled "Barcode" to display all barcode generators and select the required function from the list. A
barcode function translate a numerical code to a text string, which yields the desired barcode when printed with a special barcode font. Select POSTNET by double clicking on it.
5. As the argument to the barcode function, enter the database field that contains the code that should be translated into a
barcode. Some barcode functions require another argument.

©2010 Objectif Lune Inc

- 131 -

Using Expressions

6. Click OK.
Note: PrintShop Mail Postnet function and font, only works with 5, 9 and 11 digit number strings. No hyphens can be in
the string.
7. Select the variable @Barcode@, and pick the barcode font, that is specified for use with the chosen barcode generator.
8. From the Text Formatting toolbar or from the Text menu, select the desired PrintShop Mail font. Adjust the font size to
show the barcode at the specified or desired size.
CODABAR
Syntax

CODABAR(Text, Start character, Stop character, Check digit)

Description Computes a CODABAR barcode.
Example

CODABAR("123456", "A", "B", True)

Result

Parameter description

Text

The value represented by the barcode.Codabar barcodes can include numeric characters, special characters
(-$:/.+) and spaces.

Start character

One of four special start/stop characters A,B,C and D.

Stop chararcter

One of four special start/stop characters A,B,C and D.

Check digit

True or False. Default value is False.

Codabar is useful for encoding dollar figures and mathematical figures. These barcodes are slightly larger than Interleaved 2
of 5 barcodes.
Codabar requires start and stop characters. The check digit is optional.
CODE 128
Syntax

CODE128(Text)

Description Computes a Code128 barcode
Example

CODE128("123456")

Result

Parameter description

Text The string to be represented as barcode. The full (128-character)ASCII character set can be encoded.
This symbology is a very compact barcode for all alphanumeric applications.
The full (128-character) ASCII character set can be encoded in this symbology without the double characters found in
extended Code 39.
If the barcode has four or more consecutive numbers (0-9), the numbers are encoded in double density mode (where two
characters are encoded into one character position).
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Code 128 actually has three different character code subsets. It has two forms of error checking, making it a very stable barcode.
Checksums are not required.
If you have a choice, Code128 is generally the best all round one.
CODE 39
Syntax

CODE39 (Text[,Check digit])

Description Computes a Code39 barcode.
Example

CODE39("Example", True)

Result

Parameter description

Text

The string to be represented as barcode. The full (128-character)ASCII character set can be encoded.

[,Check digit] Optional,True or False. Default value is False.
Code 39 (or Code 3 of 9) is the most common barcode in use for custom applications. It is popular because it:
l
l
l

Supports both text and numbers (A-Z, 0-9, +, -, ., and <space>).
Can be read by almost any barcode reader in its default configuration.
Is one of the oldest of the modern barcodes.

Code 39 is a variable width barcode, and it can support any number of characters that the reader can scan.
It is used in many military and government specifications.
Code 39 barcodes are self checking and are not prone to substitution errors.
EAN 13
Syntax

EAN13(Text)

Description Computes an EAN13 barcode
Example

EAN13("978123456789")

Result
Parameter description

Text Any text expression or data field containing a text to be represented by the barcode.
EAN (European Article Number)
This function prints the variable barcode for the string using the EAN13 standard, which consists of an 12 digit numeric code.
To print the barcodes, a special barcode font is needed.
The EAN13 code is used for overseas applications where a country code is required. The UPCA symbology is actually a subset
of the EAN13 symbology.
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This barcode is composed of 2 numbers for the country code, 10 numbers for the data characters, and a checksum. The checksum is generated automatically.
EAN 8
Syntax

EAN8(Text)

Description Computes an EAN8 barcode.
Example

EAN8("9712345")

Result

Parameter description

Text Any text expression or data field containing a text to be represented by the barcode.
EAN (European Article Number)
This function prints the variable barcode for the string using the EAN8 standard, which consists of an 7 digit numeric code. To
print the barcodes, a special barcode font is needed.
The EAN8 code is similar to the EAN13 barcode. Is used for overseas applications where a country code is required, only five
numbers are used.
This barcode is composed of 2 numbers for the country code, 5 numbers for the data characters, and a checksum. The checksum is generated automatically.
ITF
(Interleaved 2 of 5)

Syntax

ITF(Text [,Check digit)

Description

Computes an ITF barcode .ITF has the flexibility to encode any even number of digits. If you have an odd
number of digits, a leading zero will be added.

Example

ITF("1234567890")

Result

Parameter description

Text

Any text expression or data field containing a text to be represented by the barcode.

Check digit Interleaved 2 of 5 is prone to substitution errors, it is advised to use a check digit.
Also known as I2of5, this is a numeric only barcode that prints out a little larger than the UPCA barcode when 10 digits are
encoded.
This symbology has the flexibility to encode any even number of digits.
This barcode is an excellent candidate for numeric only applications, and it is the best symbology to use for fixed mount readers.
Because Interleaved 2 of 5 is prone to substitution errors, you should always use a checksum.
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JAN 13
Syntax

JAN13(Text)

Description Computes JAN13 barcode
Example

JAN13 ("123456789012")

Result

Parameter description

Text Any text expression or data field containing a text to be represented by the barcode.
JAN (Japanese Article Number)
JAN code is most popular barcode for products in the shop. JAN13 is called as standard code.
JAN13 represents fixed length 13 digits number. It requires fixed length 12 digits of numeric characters for input.
MOD10 check digit is automatically calculated and added.
This barcode is composed of 2 numbers for the country code, 10 numbers for the data characters, and a checksum. The checksum is generated automatically.
For JAN barcodes the first two numbers must be 45 or 49 which identifies Japan.
JAN code is equal to EAN code.
JAN 8
Syntax

JAN8(Text)

Description Computes JAN8 barcode.
Example

JAN8 ("1234567")

Result

Parameter description

Text Any text expression or data field containing a text to be represented by the barcode.
JAN (Japanese Article Number)
JAN code is most popular barcode. JAN8 is called simplified code.
JAN8 represents fixed length 8 digits number. It requires fixed length 7 digits of numeric characters for input.
MOD10 check digit is automatically calculated and added.
This barcode is composed of 2 numbers for the country code, 5 numbers for the data characters, and a checksum. The checksum is generated automatically.
For JAN barcodes the first two numbers must be 45 or 49 which identifies Japan.
JAN code is equal to EAN code.
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KIX
Syntax

KIX(Postcode, Street address number,Country code)

Description Computes a KIX barcode. KIX barcode are used by the Dutch post office for bulk mail addressing.
Example

KIX("3842BX", "Daltonstraat 42-44", "NL")

Result

NL3842BX

Parameter description

Postcode

Any text expression or data field containing a text.

Street address number Any text expression or data field containing a text.
Country code

Any text expression or data field containing a text.

KIX barcode are used by the Dutch post office for bulk mail addressing.
It is imperative that the point size of the KIX code font is 10 point.
MSI Plessey
Syntax

MSI(Text)

Description Computes a MSI Plessey barcode.
Example

MSI("1234567890")

Result

Parameter description

Text Any text expression or data field containing a text. Numbers must be provided as text.
The MSI Plessey barcode was designed in the 1970s by the Plessey Company in England and is used primarily in libraries and
retail applications.
This is a numeric only code that stands up well to frequent use.
This code is not self checking, a checksum is highly recommended.
The symbology of the MSI Plessey character set consists of barcode symbols representing the numbers 0-9, the start character and the stop character.
NW7
Syntax

NW7 (Text, Start character, Stop character, Check digit)

Description Any expression which results in a logical value, example: True or False.
Example

NW7 ("123456", "A", "B", True)

Result
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Parameter description

Text

Any text expression or data field containing a text to be represented by the barcode.

Start character Start character.
Stop Character Stop character.
Check digit

Optional, True or False. Default value is False.

NW7 is used at library, parcel delivery service and various other purposes.
NW7 supports variable length number up to 100 digits.
When use DR7 / DSR7 / DR9 / DSR9 and if original text includes more than 16 digits of numeric strings, error will be returned.
ONECODE
Syntax

ONECODE(Barcode ID, Special services, Customer ID, Sequence no.[,Zipcode])

Description Computes a ONECODE solution barcode.
Example

ONECODE("10","042","123456","123456789",[""])

Result
Parameter description

Barcode ID

ID String of exactly 2 characters containing only numeric digits.

Special services String of exactly 3 characters containing only numeric digits.
Customer ID

String of either 5 or 6 characters containing only numeric digits.

Sequence no.

String with a length of 0 to 9 digits.

Zipcode

Optional string with a length of 0 to 11 digits.

For more information about the ONECODE barcode, please visit www.ribbs.usps.gov/onecodesolution.
POSTNET
Syntax

POSTNET(Text[,Street address number])

Description

Converts a 5 digit (zip code), 9 digit (zip+4 code), or an 11 digit (delivery point barcode) to a valid POSTNET
barcode.

Example

POSTNET("12345-6534","152 Oxford Street")

Result

Parameter description

Text

Any text expression or data field containing a text to be represented by the barcode.

Street address
number

Any text expression or data field containing a text to be represented by the barcode. The delivery point
number is calculated from this text.

POSTNET (Postal Numeric Encoding Technique)
This barcode is the special code that is placed on the lower right portion of an envelope.
It is used to speed mail through the postal service (by automated sorting) and get reduced rates.
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Start and stop characters are automatically added by PrintShop Mail.
It is recommended that you have an U.S Postal Service Mailpiece Design Analyst review and approve all POSTNET barcodes
generated from PrintShop Mail. The Mailpiece Design Analyst is trained to analyze POSTNET barcodes and determine whether
or not they meet the U.S Postal Service's technical requirements. Output can be send to them via email (digital file) fax or mail.
Point your Web browser to: http://pe.usps.gov/mpdesign/mpdfr_mda_lookup.asp to find the name and contact information
for the Mailpiece Design Analyst that is assigned to your geographical area.
UPCA
Syntax

UPCA(Text, System number)

Description Computes a UPCA barcode
Example

UPCA("123456789", 0)

Result

Parameter description

Text

Any text expression or data field containing a text to be represented by the barcode.

System number Numeric expression or data field containing a number which results in a one digit system number (0-9).
UPC is the standard barcode for items for sale to the public. It is the code seen on items at the local supermarket. UPCA is a
fixed length, numeric only barcode.
It contains:
l
l
l
l

1 digit for a system number
5 digits for the manufacturer number
5 digits for the product number
One checksum digit

The position and value of the digits is standardized by a grocery industry committee. UPCA and UPCE also allow two or five
digit supplemental numbers.
UPCA and UPCE codes have an automatic checksum.
Only tags with the system character of 0 can be encoded with this symbology.
UPCE
Syntax

UPCE(Text)

Description Calculates an UPCE barcode
Example

UPCE("123456")

Result

Parameter description

Text Any text expression or data field containing a text to be represented by the barcode.
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UPCE is ideal for small packages, because it is the smallest barcode available. This symbology contains the same information
as UPCA, except that at least four zeros are suppressed.
The position and value of the digits is standardized by a grocery industry committee. UPCA and UPCE also allow two or five
digit supplemental numbers.
UPCA and UPCE codes have an automatic checksum.
Only tags with the system character of 0 can be encoded with this symbology.
YUBAR
Rolan barcode consists of YUBAR.
YUBAR is for Japanese postage barcode defined by Postal Services Agency.
Syntax

YUBAR(Address code, Postal code)

Description Computes a YUBAR barcode
Example

YUBAR("1-1-11", "1030013")

Result
Parameter description

Address code Any expression or text field to represent the address code.
Postal code

Any expression or text field to represent the address code.

YUBAR is Japanese postal barcode named Yusei Customer Barcode.

Layout Functions
You can use the following layout functions in PrintShop Mail:
l
l
l

Blank
Print
Skip

Use these functions to specify which layout should be printed, left blank, or skipped.
PRINT and BLANK commands won't influence the amount of printed pages.
To edit layout conditions

1. Go to the layout for which you want to change the expression.
2. From the Layout menu, select Edit Condition or select the layout in the Layout panel, in the properties click on
Action.
3. Select one of the layout functions.
Example

A specific page must go to clients of a specific sales representative ("John"). This field is called 'SALES REP' in the database.
The expression used is:
IF([SALES_REP] = "John", Print, Skip)
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When PrintShop Mail encounters the name "John" in the "SALES REP" field, it prints the page. In all other cases, the page will
be skipped.
Note: Fiery FreeForm does not support the SKIP function. BLANK is used instead.
Fiery FreeForm 2 uses BLANK instead of SKIP when Layout Conditioning is used in combination with Layout Repetition.

Related Topics

"OBJECT_EMPTY" (page 142)
"Use Layout Conditioning" (page 83)
BLANK
Syntax

BLANK

Description

Layout action constant. If your layout condition evaluates to Blank, then the layout will be left blank when the
document is printed.

Example

IF(VAL([AGE])<55,Print,Blank)

PRINT
Syntax

PRINT

Description Layout action constant. If your layout condition evaluates to Print, then the layout will be printed.
Example

IF([SALES_REP] = "John", Print, Blank)

In this example, the layout is printed when PrintShop Mail finds the name "John" in the "SALES_REP" field of the database.
SKIP
Syntax

SKIP

Description Layout action constant. If your layout condition evaluates to Skip, then the layout will be skipped.
Example

IF([SALES_REP] = "John", Print, Skip)

In this example, the layout is skipped when PrintShop Mail finds anything else but the name "John" in the "SALES_REP" field of
the database.

Logical Functions
You can use the following logical operators to define conditions in PrintShop Mail:
l
l
l
l
l
l
l
l

AND
FALSE
FILE_EXIST
IF
NOT
OBJECT_EMPTY
OR
TRUE
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AND
Syntax

(Logical value 1) AND (Logical value 2)

Description Returns True if both <Logical value 1> and <Logical value 2> are True.
Example

False AND True => False

Parameter description

Logical value 1 Logical expression.
Logical value 2 Logical expression.
CHANGED
CHANGED returns True if the current expression result differs from the result of the previous record.
Syntax

CHANGED(Expression)

Description

Determines if the result of <Expression> has changed compared to the previous record. The previous record is
the current record minus one. CHANGED will return False for record 1.

Examples

CHANGED([Customer])
IF (CHANGED([zipcode]), Print, Skip)

Parameter Description

Expression Expression to evaluate for the current record and the previous record.
FALSE
Syntax

False

Description Logical constant False
Example

(1<10) = False => False

The result of the example is "False", "1<10", which is True, does not equal "False".
FILE_EXIST
Syntax

FILE_EXIST (Filename)

Description Returns True if the <filename> exist on disk.
Example

FILE_EXIST([Image])

Checks whether a resource, for example an image file exists on your computer. This function returns "True", if the image exist
on disk.
Parameter description

Filename Filename of file to check the existence of. Any text expression or data field containing a text.
IF
This function manipulates the database output without changing the content. Its purpose is to make a conditional selection
from the database.
Syntax

IF(Logical test, Value if True, Value if False)

Description

Gives one of two results depending on a condition you specify. Returns <Value if True> when <Logical test> is
True, and <Value if False> otherwise.
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Example

IF([GENDER]="M", "Mr.", "Mrs.")

In this example, the IF function checks the database field [GENDER], if it contains "M", it returns the string "Mr.". If the database field contains anything else, it returns "Mrs".
Parameter description

Logical test

Logical expression that determines which of the 2 parameters values will be returned.

Value if True Any expression of fieldname. Will be returned if test condition evaluates to True.
Value if False Any expression of fieldname. Will be returned if test condition evaluates to False.
You can use the IF function, for example, to create a salutation. See "Inserting a Salutation".
NOT
Syntax

NOT(Logical value)

Description Returns True if <Logical value> is False, and False otherwise.
Example

NOT(True)=>False

Parameter description

Logical value Any expression which results in a logical value, example: True or False.
OBJECT_EMPTY
(Windows only)
Syntax

OBJECT_EMPTY(Object name)

Description Determines whether an object with the specified name is empty. Returns True or False.
Example

OBJECT_EMPTY("Text1")

Parameter description

Object name Name of the object to check.
Checks whether the name of an object exist, even when moving objects backward or forward on the same layout or to
another layout.
This function can also be called upon via the menu Layout>Skip if Object is Empty.
OR
Syntax

Logical value 1 OR Logical value 2

Description Returns True if either <Logical value 1> or <Logical value 2> is True.

Example

True OR False => True
False OR True => True
True OR True => True
False OR False => False

Parameter description

Logical value 1 Logical expression.
Logical value 2 Logical expression.
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TRUE
Syntax

True

Description Logical constant True
Example

(1<10) = True =>True

This example returns "True", because the logical test (1<10) is true.

Number Functions
You can use the following functions to manipulate numbers and values in PrintShop Mail:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

ABS
CHR
COUNTER
DIV
INT
LAYOUT_COUNT
LAYOUT_NR
MOD
PAGE_COUNT
PAGE_NR
RECORD_COUNT
RECORD_NR
ROUND
SGN
VAL

ABS
Syntax

ABS(Number)

Description Returns the absolute value of <Number>.
Example

ABS(-2.3) => 2.3

Parameter description

Number Numeric expression or data field containing a Number.
CHR
Syntax

CHR(Number)

Description Returns the character represented by ASCII index <Number>.
Example

CHR (97) => "a"

Parameter description

Number ASCII index of character to represent.

©2010 Objectif Lune Inc

- 143 -

Using Expressions

COUNTER
Syntax

COUNTER([Start value][,End value] [,Step size] [,Number of positions] [,Leading zeroes])

Description A counter which by default counts from the first to the last record. Arguments are optional.

Example

COUNTER (1,100)
COUNTER (1,100, 5, 3, True)
COUNTER (1, 100, 0.5, 3, False)
COUNTER()

Parameter description

Start value

The start value of the counter. Default 1 .

End value

The end value of the counter. Default 10000000000.

Step size

The step size to the next number. Default 1.

Number of positions

The number of characters the counter will create. By default no extra characters will be added.
Default 0.

Leading zeroes

True for leading zeroes, False for no leading zeroes (default).

You can use a counter when printing tickets or numbering your mailing. You do not need to open a database within PrintShop
Mail when using a COUNTER, if this is the only variable.
The first example creates numbers, starting with 1 and ending with 100. As you browse through the fields of the database, the
series is as follows:
1, 2, 3, 4, ..., 99, 100, 1, 2, 3, ...
The counter restarts once it has reached 100.
The series generated by the second example looks like this:
001, 005, 010, ..., 090, 100, 005, 010, ...
The parameters step size, number of positions and leading zeroes have been added.
The third example has a fraction for the step size. This means that the counter increases by 0.5.
1, 1.5, 2, 2.5, 3, ..., 99.5, 100, 100.5, ...
The last example, COUNTER() starts with 1 and ends at whatever number is set in Items without database (Program settings in the Preferences).
DIV
Syntax

DIV(Number,Divider)

Description Returns the integer quotient from dividing <Number> by<Divider>.
Example

DIV (25, 3) => 8

Both may be a floating point number, and an integer result is returned.
Parameter description

Number Numeric expression or data field containing a number.
Divider Numeric expression or data field containing a number.
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INT
Syntax

INT(Number)

Description Returns the integral part of floating point number <Number>.
Example

INT(2.78) => 2

Parameter description

Number Numeric expression or data field containing a number.
LAYOUT_COUNT
Syntax

LAYOUT_COUNT()

Description Returns the total numbers of layouts for the current record of the database.
Example

LAYOUT_COUNT()=>10

LAYOUT_NR
Syntax

LAYOUT_NR()

Description Returns the current layout number.
Example

LAYOUT_NR()=>3

Note: When using layout conditions, the function LAYOUT_NR will respect the SKIP argument. When using PRINT and
BLANK, the LAYOUT_NR function will return the number for those layouts.
MOD
Syntax:
MOD(number, divider)
Attributes:
l
l

number: Numeric expression or data field containing a number.
divider: Numeric expression or data field containing a number.

Returns:
The remainder of the first number divided by the divider.
Example Uses
MOD(20, 9) => 2
MOD(5,3)
MOD(5.5,3)

// Returns true
// Returns 2
// Returns 2.5

PAGE_COUNT
Syntax

PAGE_COUNT()

Description Returns the total numbers of pages at printing for this document.
Example

PAGE_COUNT()=>10
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PAGE_NR
Syntax

PAGE_NR ([Reset after each record])

Description

Returns the page number at printing. If <Reset after each record> equals TRUE, the page number will be reset
to "1" after each record.

Example

PAGE_NR()=>10

Parameter description

Input number
value

True to reset to 1 after each record. Leave empty to increment the page number continuously throughout all printed records.

This function can also be called upon via the menu:
Insert>Page Numbers
Entire Job: Prints the page number for the entire job.
Reset After Each Record: Prints the layout number within a record set.
RECORD_COUNT
Syntax

RECORD_COUNT()

Description Returns the total number of records of the database.
Example

RECORD_COUNT()=>10

RECORD_NR
Syntax

RECORD_NR()

Description Returns the current record number of the database.
Example

RECORD_NR()=>10

The function RECORD_NR() yields the current record number. It has no arguments and it does not perform any calculations.
When no records are filtered out and no BLANK is used as a layout expression, it simply increases 1 at a time.
ROUND
Syntax

ROUND(Number, Precision)

Description Returns the supplied number rounded off to the specified number of decimal places.
Example

ROUND (1.678,2) => 1.68

Parameter description

Number Numeric expression or data field containing a number.
Precision Number of decimal places. Numeric expression or field containing a numeric expression.
SGN
Syntax

SGN(Number)

Description Returns one of three possible values (-1,0 or 1), depending whether the number is negative, zero, or positive.
Example

SGN (-345) => -1
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Parameter description

Number Numeric expression or data field containing a number.
TOTALPAGES
Syntax

TOTALPAGES(Filename)

Description Returns the number of pages in a PDF file, or the number of frames in a multi-frame TIFF or GIF file.
Example

TOTALPAGES("Example.pdf") => 10

Parameter Description

Filename Path to a PDF, TIFF or GIF file.
VAL
Syntax

VAL(Text)

Description Returns number in text as data type Number, for use with formulas involving numbers or numeric functions.
Example

VAL ("123") => 123

Parameter description

Text Any text expression or data field containing a text to be converted to a numeric value.
You can use this function to convert text fields to fields that hold a value.
If you have a text field that holds number characters, you can convert that field so you can do calculations with it.
Example:
The field [COUPON] holds a text, (for example, "7")
VAL([COUPON])/365 => 0.02

String Functions
You can use the following functions to manipulate strings in PrintShop Mail:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

ASC
CONTAINS
DATE
LEFT
LEN
LOWER
LTRIM
MID
POS
PROPER
REPLACE
RIGHT
RTRIM
STR
TEXT_FILE
TODAY
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l
l

TRIM
UPPER

ASC
ASC(Text)

Syntax

Description Converts the leading character in <Text> to its numeric UNICODE value.
ASC ("abc") => 97

Example

Parameter description
Text String from which to get UNICODE code from first character.

CONTAINS
Syntax

CONTAINS(text,Text to find)

Description Returns True if<Text> contains<Text to find>, returns False otherwise.
Example

CONTAINS("PrintShop", "Mail")=>False

Parameter description

text

Any text expression or data field containing a text.

Text to find Any text expression or data field containing a set of characters you want to verify the existence of.
Searches for a given text in another given text. This example returns "False", because the text ("PrintShop"), does not contain
the text to find ("Mail").
DATE
Windows

Syntax

DATE(Input date string[,Date string format])

Description

Returns the current date, formatted according to <Date string format> (optional) or the system regional settings.

Example

DATE(database field, "DD MMMM YYYY") or DATE("19740227", "").

Parameter description

Input date string

Date in "YYYYMMDD" format (Example: 20070206).

Date string format Enter the output date format. Use the D, M and Y symbols to represent the date.
You can use the following parameters for "date string format":
d

Number of the day, no leading zero

1

dd

Number of the day, with leading zero

01

ddd

Short weekday name

Mon

dddd

Long weekday name

Monday

m

Number of the month, no leading zero

6

mm

Number of the month, with leading zero 06

mmm

Short month name

mmmm Long month name
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yy

Short year notation

01

yyy

Long year notation

2001

Mac OS

It is possible to specify the format of the expression with format specifiers as shown below. These can be used with the DATE
and the TODAY function.
Format Specifier

Result

%%

A"%" character

%a

Abbreviated weekday name

%A

Full weekday name

%b

Abbreviated month name

%B

Full month name

%c

Shorthand for "%X %x", the locale format for date and time

%d

Day of the month as a decimal number (01-31)

%e

Same as %d but does not print the leading 0 for days 1 through 9 (unlike strftime(), does not print a leading
space)

%F

Milliseconds as a decimal number (000-999)

%H

Hour based on a 24-hour clock as a decimal number (00-23)

%I

Hour based on a 12-hour clock as a decimal number (01-12)

%j

Day of the year as a decimal number (001-366)

%m

Month as a decimal number (01-12)

%M

Minute as a decimal number (00-59)

%p

AM/PM designation for the locale

%S

Second as a decimal number (00-59)

%w

Weekday as a decimal number (0-6), where Sunday is 0

%x

Date using the date representation for the locale, including the time zone (produces different results from
strftime())

%X

Time using the time representation for the locale (produces different results from strftime())

%y

Year without century (00-99)

%Y

Year with century (such as 1990)

%Z

Time zone name (such as Pacific Daylight Time; produces different results from strftime())

%z

Time zone offset in hours and minutes from GMT (HHMM)

Examples:
You can use the format specifier to generate different results.
DATE() - Yields a date according to the specified format or according to the date preferences (specify format:"")
DATE("20020701", "") => 2002-07-01 00:00:00 +0000
DATE("20020701","%m-%d-%y") => 07-01-02
DATE("20020701","%m-%d-%y") will give 07-01-02
DATE("20020701","%b-%A-%Y") will give Jul-Monday-2002
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DATE("20020701","%B-%w-%Y") will give july-1-2002
TODAY() - Yields today's date according to the specified format or according to the date preferences (if format="")
TODAY("") => "2002-11-07 12:40:10 +0100"
TODAY("%A %d-%m-%Y %H:%M:%S") => Thursday 07-11-2002 12:40:10
LEFT
Syntax

LEFT(Text, Number of characters)

Description Returns the specified number of characters in the supplied text, counting from the left.
Example

LEFT ("Personalized Printing", 6) => Person

Parameter description

Text

Any text expression or data field containing a text.

Number of characters Numeric expression or data field containing the number of characters to get.
This function allows you to print a number of characters, counting from the left side of the value in the defined database field.
You can use this function to separate field content or to create a unique code with parts of someone's name.
LEN
Syntax

LEN(Text)

Description Returns the number of characters in <Text>.
Example

LEN ("Personalized Printing") => 21

Parameter description

Text Any text expression or data field containing a text.
You can use this function to calculate the length (the number of characters) of the database field. For example, certain ZIP
codes or barcodes might need to have a specific number of characters to print correctly.
LEN is often used in combination with other functions, such as LEFT, RIGHT, MID and IF, where it can be used to determine
exactly how many characters are printed of a selected database field.
In the following example, IF and LEN are combined to calculate the length of the "gender" database field. It also ensures that
fields without text, but with spacing, are recognized and eventually the correct output is generated.
First Name Last Name Gender
John

Abrahams

M

Theresa

Johnson

F

William

Fremont

M

Tom

Cooper

IF(LEN([GENDER]) = 0, "Dear Sir, Madam", IF([GENDER] = "m", "Dear Mr." & [Name], "Dear Ms" &
[Name] ) )
The result is:
Dear Mr John Abrahams
Dear Ms Theresa Johnson
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Dear Mr William Fremont
Dear Sir, Madam
LOWER
Syntax

LOWER(Text)

Description Returns all letters in the given text as lowercase.
Example

LOWER ("Personalized Printing") => personalized printing

Parameter description

Text Any text expression or data field containing a text.
This function allows you to print the selected database fields in lowercase.
For example, if your database is filled out with information in capitals, you could use this expression to amend this.
LTRIM
Syntax

LTRIM(Text)

Description Returns the supplied text, stripped of all leading spaces, tabs and newline characters.
Example

LTRIM (" 12") => "12"

Parameter description

Text Any text expression or data field containing a text.
This function removes extra spacing (at the left side of the word) in a combination of variables (for example, when the database has set a defined number of characters for each particular database field or when a database field is left empty).
MID
Syntax

MID(Text, Start position,Size)

Description

Extracts characters from the supplied text, starting at the character position specified by start position and containing the number of characters specified by size.

Example

MID ("Personalized Printing", 5, 4) => onal

Parameter description

Text

Any text expression or data field containing a text.

Start position Any numeric expression or data field containing a number (start position to get characters from).
Size

Any numeric expression or data field containing the number of characters to get.

This function allows you to print a number of characters of the value in the defined database field.
With MID, you can decide which character you want to start with and how many characters from that point onwards you want
to print.
POS
Syntax

POS(Text, String to find, Start position)

Description Returns the character position of a searched string in text. Returns 0 if not found.
Example

POS("Personalized Printing", " ", 1) => 13
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Parameter description

Text

Any text expression or data field containing a text.

String to find String to search for.
Start position Position to start search from.
This function allows you to search for certain character in the value of a database field. The result will be the position of the
character you are searching for.
PROPER
Syntax

PROPER(Text)

Description Converts the first letter of each word to an uppercase character, and the rest to lowercase.
Example

PROPER ("PERSONALIZED printing") => Personalized Printing

Parameter description

Text Any text expression or data field containing a text.
This function allows you to clean up improperly filled out databases or to amend all lowercase or all uppercase information.
REPLACE
Syntax

REPLACE(Text, Text to find, Replace with text)

Description Looks for<Text to find> in <Text> and replaces every occurrence with <Replace with text>.
Example

REPLACE("PrintShop Mail", " ", "") => PrintShopMail

Parameter description

Text

Any text expression or data field containing a text.

Text to find

Any text expression or data field containing a text.

Replace with text String to replace occurrences of <Find string>. Any text expression or data field containing a text.
RIGHT
Syntax

RIGHT(Text, Number of characters)

Description Returns the specified number of characters in the supplied text, counting from the right.
Example

RIGHT ("Personalized Printing", 8) => Printing

Parameter description

Text

Any text expression or data field containing a text.

Number of characters Numeric expression or data field containing the number of characters to get.
Use this function to separate field content or create a unique code with parts of someone's name.
RTRIM
Syntax

RTRIM(Text)

Description Returns the supplied text, stripped of all trailing spaces, tabs and newline characters.
Example

RTRIM ("12 ") => 12
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Parameter description

Text Any text expression or data field containing a text.
This function removes extra spacing (at the right side of the word) in a combination of variables. For example, you can use this
function when the database sets a defined number of characters for each particular database field or when a database field is
left empty.
STR
Syntax

STR(Number)

Description Returns the supplied number as data type Text, for use with formulas involving text or text functions.
Example

STR (123.55) => 123.55

Parameter description

Number Numeric expression or data field containing a number.
TEXT_FILE
(Windows only)

Creating variable text blocks, such as paragraphs and bodies of letters is easier with the TEXT_FILE function. The ability to
read .RTF (Rich Text Format) and .TXT files eliminates the need to copy and paste text strings into Expression logic formulas.
Syntax

TEXT_FILE(Filename)

Description Returns the contents of the TXT or RTF file<Filename>
Example

TEXT_FILE("TEST.TXT")

Parameter description

Filename Any text expression or data field containing a text which holds the Filename of TXT or RTF file.
Allows you to link variable (external) text files in .RTF or .TXT text format to your PrintShop Mail document.
TODAY
Syntax

TODAY([Number])

Description

Returns the current date, according to the computers internal calender, formatted according to the system
regional settings.

Example

TODAY() => 20070208

Parameter description

Number The amount of days added to the current date. Numeric expression or field containing a number.
This function takes no arguments. It returns the current system date (at the time the current record is printed).
The date format depends on the preferences defined in regional settings.
TRIM
Syntax

TRIM(Text)

Description Returns the supplied text, stripped of all leading and training spaces, tabs and newline characters.
Example

TRIM (" 12 ") => 12
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Parameter description

Text String to remove leading and trailing spaces, tabs and newline characters from.
This function removes extra spacing in a combination of variables (for example, when the database has set a defined number
of characters for each particular database field or when a database field is left empty).
TRIM removes any extra spacing at the left and at the right side of the word in the database field that has been selected.
UPPER
Syntax

UPPER(Text)

Description

Returns all letters in the given text as uppercase. Use the UPPER function to ensure consistent data entry of
such things as state abbreviations or postal codes.

Example

UPPER ("Personalized Printing") => PERSONALIZED PRINTING

Parameter description

Text Any text expression or data field containing a text.
You can use this function to print the selected database field in capital letters.
If you are creating a mailing for which you need to print the names in capitals, although the names in the database are in lowercase, perform the conversion with UPPER.
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ELECTRONIC END USER LICENSE AGREEMENT FOR PRINTSHOP MAIL

NOTICE TO USER: THIS IS A CONTRACT. BY INSTALLING THIS SOFTWARE YOU ACCEPT ALL THE TERMS AND CONDITIONS OF THIS AGREEMENT.
This Objectif Lune End User License Agreement accompanies the PrintShop Mail product and related explanatory materials
("Software"). The term "Software" also shall include any upgrades, modified versions or updates of the Software licensed to
you by Objectif Lune. Please read this Agreement carefully. Upon your acceptance of this Agreement, Objectif Lune grants to
you a nonexclusive license to use the Software, provided that you agree to the following:
1. Use of the Software.
You may install the Software on a hard disk or other storage device; install and use the Software on a file server for use
on a network for the purposes of:
(i) permanent installation onto hard disks or other storage devices or
(ii) use of the Software over such network; and make backup copies of the Software.
You may make and distribute unlimited copies of the Software, including copies for commercial distribution, as long as
each copy that you make and distribute contains this Agreement, the PrintShop Mail installer, and the same copyright
and other proprietary notices pertaining to this Software that appear in the Software. If you download the Software
from the Internet or similar on-line source, you must include the Objectif Lune copyright notice for the Software with
any on-line distribution and on any media you distribute that includes the Software.
2. Copyright.
The Software is owned by Objectif Lune and its suppliers, and its structure, organization and code are the valuable
trade secrets of Objectif Lune and its suppliers. The Software also is protected by Dutch Copyright Law.
3. Restrictions.
You agree not to modify, adapt, translate, reverse engineer, decompile, disassemble or otherwise attempt to discover
the source code of the Software. You may not alter or modify in any way the installer program or create a new installer
for the Software. The Software is licensed and distributed by Atlas for creating optimized print jobs.
4. No Warranty.
The Software is being delivered to you AS IS and Objectif Lune makes no warranty as to its use or performance.
OBJECTIF LUNE AND ITS SUPPLIERS DO NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULTS YOU MAY
OBTAIN BY USING THE SOFTWARE OR DOCUMENTATION. OBJECTIF LUNE AND ITS SUPPLIERS MAKE NO WARRANTIES, EXPRESS OR IMPLIED, AS TO NONINFRINGEMENT OF THIRD PARTY RIGHTS, MERCHANTABILITY, OR FITNESS FOR ANY PARTICULAR PURPOSE. IN NO EVENT WILL OBJECTIF LUNE OR ITS SUPPLIERS BE LIABLE TO YOU
FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS, EVEN IF AN OBJECTIF LUNE REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES,
OR FOR ANY CLAIM BY ANY THIRD PARTY.
Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, or
the exclusion of implied warranties or limitations on how long an implied warranty may last, so the above limitations
may not apply to you.
5. Governing Law and General Provisions.
This Agreement will be governed by the laws of the Netherlands, excluding the application of its conflicts of law rules.
This Agreement will not be governed by the United Nations Convention on Contracts for the International Sale of
Goods, the application of which is expressly excluded. If any part of this Agreement is found void and unenforceable, it
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will not affect the validity of the balance of the Agreement, which shall remain valid and enforceable according to its
terms. You agree that the Software will not be shipped, transferred or exported into any country or used in any manner
prohibited by any export laws, restrictions or regulations. This Agreement shall automatically terminate upon failure by
you to comply with its terms. This Agreement may only be modified in writing signed by an authorized officer of Objectif Lune.
Objectif Lune Inc.
2030 Pie IX, Suite 500
Montréal, QC
Canada H1V 2C8
www.objectiflune.com
YOUR ACCEPTANCE OF THE FOREGOING AGREEMENT WAS INDICATED DURING INSTALLATION.

©2010 Objectif Lune Inc

- 156 -

Contact Information

Contact Information
To find an Objectif Lune office near you and for more information on our products and services, visit www.objectiflune.com.
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Trademarks
PrintShop Mail
All trademarks referenced in this user's guide and the PrintShop Mail application, are the trademarks or registered trademarks
of their respective holder.
l
l
l
l
l
l
l
l
l
l
l

Adobe,Acrobat, PostScript and all related products are registered trademark of Adobe System Incorporated.
The included Adobe ICC Profiles are copyright of Adobe System Incorporated.
LibTIFF : Copyright (c) 1988-1997 Sam Leffler; Copyright (c) 1991-1997 Silicon Graphics, Inc.
Apple and Macintosh are registered trademarks of Apple Computer, Inc.
Creo VPS is a registered trademark of Creo Corporation Ltd.
PPML is a registered trademark of PODi.
VIPP is a registered trademark of Xerox Corporation.
PrintStreamer is a registered trademark of Barco
Windows, Word and Excel are registered trademarks of Microsoft in the U.S. and other countries.
PlanetPress Suite is a registered trademark of Objectif Lune Inc.
PrintShop Web is a registered trademark of Objectif Lune Inc.

©2010 Objectif Lune Inc

- 159 -

©2010 Objectif Lune Inc

- 160 -

Index
ABS

143
Contain

Access

73

Acrobat

108

CONTAINS
Administrative Tools

71

Administrator

92

23

Copies

87

Adobe Type Manager
AHT

COUNTER

127, 143

Create ZIP

107

39
102, 105
Credit Information
35

Alternate color

70

Creo
Creo VPS
AND

140

APR

26, 30, 105

Crop Marks
Custom Serial Number
Arranging
ASC
Asian
Automated Printing
Barcode

BLANK
Bleed Margin

CHR
CMYK

Data Fields

82

Data Triggers

75

24, 31
Database

55, 92

Database Toolbar

14, 18

112
128, 132-139
DBF

71

DDE

112, 118

83, 139
44, 53, 60-61
40

23
70-71, 82, 92

126
10, 92

37
Dictionary

39

direct

82

directsmile

82

directsmile plug-in

82

143
23, 26, 30, 46

CODE128

130

CODE39

130

DIV
Document
Color Management

46

Color profiles

46

Colorimetric

46

©2010 Objectif Lune Inc

147

110

130

Company Web Server

126-127

147

CODABAR

Commandline

53, 61

71

Designer
Child's

102

Data Field Properties

Design
Capitalizing

102, 105

36

Default Tab Stops
Bounding

10

112, 118

DATE
Between Sets

35

102, 105

Align Edges

Arguments

23-24, 31, 40

108
Copying Objects

Adobe PDF

147

Convert

Copy fitting
Adobe

75

143
57, 90

Document's colors

46

Documents

92

Dongle

10

DPI

75

113
53

- 161 -

Driver

85, 104

EAN13

130

EAN8

130

Email

55

Embed
Empty Lines

46, 110
24, 31

Encapsulated

109

Environment

107

EPS
EVIPP
Excel
Expression Editor Window
Extended
Extended Scripting
Eyedropper

75, 105
102
73, 114
82
114
71, 112
39

Favorite Expressions

127

Favorite Expressions Overview

121

Faxing
FILE_EXIST
Filter
Finishing
Folding

55
140
71
110
44, 53, 58-59

Font

39

Font Panel

39

Formats

71, 75, 82

Formatting Marks

40

FoxPro

73

FreeForm

102

Gap size

60

Global Images
Global Scope
Guide

107-108
107
58

Guide line

44, 59

Help menu

10

HotFolder

112, 119

ID

106

IF

140

©2010 Objectif Lune Inc

- 162 -

Image Objects Properties

75

Imposition

53

INT

143

ITF

130

JAN13

130

JAN8

130

Kern

39

KIX

130

Layout Basics

57

Layout Conditioning

83

Layout Functions

128, 140

Layout menu

85, 90

Layout Repetition

50, 84

LAYOUT_CONUNT

143

LAYOUT_NR

143

LEFT

147

LEN

147

Linking
Local Images
Local Scope
Locking
Logical Functions

37
107-108
107
36
128, 140-142

Login account

92

Loosen

39

LOWER

147

LTRIM

147

Magnetic strength
Margin
Master Object

44
49, 60
37

MID

147

MOD

143

Monitor HotFolder

119

MS Access

114

MSI

130

Multi-up

50

Multi-User

10

Network

10

NOT
Number Functions

140
128, 143-147

NW7

130

OBJECT_EMPTY

140

Objects

33, 37

Objects Toolbar

14, 16

ODBC

71

ONECODE

130

OpenType

39

Operator
OPI

92, 114, 125, 140
102, 104

Optimize

104

Options

10

OR

140

Oracle/SQL

73

Page Setup

85, 102, 109

Page Size

109

PAGE_COUNT

143

PAGE_NR

143

Paper Trays

85

Paragraph

40

PlanetPress Suite

55

plug-in

82

Plugins

75

PODi

107

POS

147

POSTNET

130

PostScript

105

PPD

85

PPML

102, 107

PPML/VDX

102, 108

Preferences

46, 57, 82

Preview
PRINT

©2010 Objectif Lune Inc

102
83, 109, 139

- 163 -

Print Dialog

110

Print Preview

102

Print Setup dialog

110

Print Technology
PrintShop Mail documents
PrintShop Web
PrintStreamer
PROPER
Properties Panel
PSMT
Publication
Publishing
Publishing documents
Rasterized

49, 110
75
53, 92
102, 108
147
23, 68, 71, 85
67, 91
92
67, 71
111
105-106

RECORD_COUNT

143

RECORD_NR

143

Remove
Remove Empty Lines

37
23-24, 31, 82

Rendering

46

Repetition

50

REPLACE

147

Resizing

33

RGB
RIGHT
RIP

26, 30
147
105-106

Rolan barcode

139

ROUND

143

RTRIM

147

Salutation

126

Save

91

Save for Output

91

Scale

23

Schedule
Select Paper Trays

114
19

Selecting
Separation
Server
Set
Setup
SGN
Single-User

33, 67
70
118
67
9, 68
143
10

Size

67-68

SKIP

83-84, 105

Skip Empty Lines
smile
Snap Frame

24, 31
82
23, 37

Soft

46

Sort

71

Sources

71

Spacing

40

Specify

68

Specify Spot Colors

70

Specify Text color
Spelling
SQL
Standard
Standard PostScript
Standard Toolbar

24, 31
39
114
10
102, 104
14-15

Start

110

STR

147

String
String Functions
Subset

87
128, 148, 150-154
110

Supported Image Formats

61

Tab Stops

40

Template-based

67

Templates

67, 91-92

Test

92

Text Formatting Toolbar

15

Text Link Toolbar
text objects

©2010 Objectif Lune Inc

14, 16
37

- 164 -

TEXT_FILE
Through-the-stack
TIFF

147
50
107

Tighten

39

TODAY

147

Tools Toolbar

17

Trays

85

Trigger
TRIM
Two Colors
TXT

75, 87
147
26, 30
71, 153

UPCA

130

UPCE

130

Upgrading
UPPER

10, 109, 112
147

USB

10

Use Layout Condition

19

VAL

87, 143

Variable Images

75

Variable Markers

44, 82

Variable Text

82

Variables

82

Variables Panel

19

Verification Result Panel

19, 90

Verify Document

90

View Toolbar

18

VIPP

109

Visual Basic

118

VPS

102, 105

Warnings

19, 90

XLS

71, 73

XML

71, 73

